[Opensim-users] Region boot failure after upgrade

John Hopkin opensim at jfhopkin.karoo.co.uk
Sun Jun 28 11:15:53 UTC 2009

John Hopkin wrote:

>I've upgraded my install of OpenSim from 9841 to 9943, and it's
>stopped working, not booting up properly.  I can't work out why.
>The final lines of the console display are:
>14:38:22 - [RADMIN]: Creating default avatar entries
>14:38:22 - [RADMIN]: Exception whilst loading default avatars ; Object
>reference not set to an instance of an object
>14:38:22 - [RADMIN]: Default avatars not loaded
>14:38:22 - [LOADREGIONS]: Loading region configurations from
>Region UUID [aab42553-721d-4539-99b1-fac0b58a9715]:
>at which point it waits, presumably for a UUID to be entered.
>The full text from the console is here: http://tinyurl.com/rymjkt
>Prior to this, it was working fine, and the only differences between
>OpenSim.ini and the new OpenSim.ini.example are for known
>customisations - script engine, connect strings, etc.
>Anyone any clue?
>Vital statistics:
>- Ubuntu Jaunty
>- Pentium 4/3.6GHz/2GB
>- Mono 2.2
>- MySQL 5.0.75
>- OSGrid UGAIM, 7 regions

Solved, thanks to Warin in the OSGrid forums.

I had OpenSim.ini and the region XML files in the same, separate
directory.  Creating a "Regions" subdirectory there and moving the XML
files down a level into that directory (changing regionload_regionsdir
accordingly) solved the problem.
John Hopkin

More information about the Opensim-users mailing list