[Opensim-dev] Renaming innerscene
Michael Wright
michaelwri22 at yahoo.co.uk
Thu Nov 6 14:29:06 UTC 2008
I'd rather have some separation of 3d/ base scene level and region level, so that it is easier to customise things change things in applications based on opensim. Not every application is going to want all the region level things, and some might not even want any. They might just want a basic multi user 3d scenegraph with their own higher level handling.
I think there has to be a base layer than handles 3d objects in the world with support for adding/removing 3d objects, updating physics etc. And sends updates to the clients, and accepts avatar movement commands back. This is basically what InnerScene does or should do. We can separate higher level functions above this all we want.
But without that base layer that other applications can build on top of, OpenSim loses so much flexiblity and interest.
Melanie <melanie at t-data.com> wrote: As one who has spent a lot of time in InnerScene with the local
dragons, I see that in lots of cases, even having it InnerScene at
all complicates things horrendously.
There are actions that change between Scene and InnerScene 4 times
to get the job done. That could be done much more efficiently if
those methods were combined and then split up into functional units,
rather than "3d" scoped.
One flow I found was like this:
Caller calls Scene:A
Scene:A calls InnerScene:A
Scene:A calls Scene:B
Scene:A calls InnerScene:C
InnerScene:C calls Scene:C
Scene:A returns.
This is overcomplex and baffling to new coders. I am not surprised
that many people choose not to touch it.
Needless to say, I removed the above flow and made it into a single
call into InnerScene. It was part of attachment rezzing. When i did
that, I streamlined that flow.
I believe InnerScene and Scene should not be separate, or not be
separated along the line they are separated now.
On the name, I don't really care.
+-0 there.
Melanie
Frisby, Adam wrote:
> +1'ing,
>
> I had no idea what InnerScene was for myself.
>
> Adam
>
> From: opensim-dev-bounces at lists.berlios.de [mailto:opensim-dev-bounces at lists.berlios.de] On Behalf Of Michael Wright
> Sent: Thursday, 6 November 2008 5:22 AM
> To: opensim-dev at lists.berlios.de
> Subject: [Opensim-dev] Renaming innerscene
>
> A long time ago, we started the process of separating the 3d scene handling code into its own class, rather than having it mixed in with more region level code, like rezzing/inventory handling.
>
> It was always planned to renamed the InnerScene and Scene classes, once this separation of the 3d scene graph code was completed. The original plan being that Scene became Region (or something like that) and InnerScene changed to Scene.
>
> It might be a bit to much work to rename the Scene class at this stage. But what are everyone thoughts on renaming InnerScene to something like SceneGraph.
>
> I think the InnerScene class is one of the more confusing areas as a lot new coders aren't really aware what design role it is meant to play.
>
>
>
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Opensim-dev mailing list
> Opensim-dev at lists.berlios.de
> https://lists.berlios.de/mailman/listinfo/opensim-dev
_______________________________________________
Opensim-dev mailing list
Opensim-dev at lists.berlios.de
https://lists.berlios.de/mailman/listinfo/opensim-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://opensimulator.org/pipermail/opensim-dev/attachments/20081106/e61dbbad/attachment-0001.html>
More information about the Opensim-dev
mailing list