Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008914opensim[REGION] OpenSim Corepublic2021-07-18 11:512021-07-28 15:35
ReporterKayaker Magic 
Assigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusnewResolutionopen 
PlatformDel T1400Operating SystemUbuntu LinuxOperating System Version16.04
Product Version 
Target VersionFixed in Version 
Summary0008914: Animesh vehicles dissapear and snap back on some region crossings.
DescriptionSometimes (more than half the time) an animesh vehicle disappears on a border crossing, then comes zooming from a great distance to snap back into place. In an airplane made out of one animesh prim and several seat prims, the seat prims cross properly and only the animesh prim disappears for a while.
This video shows the problem happening:
https://www.youtube.com/watch?v=Z__HrxukEtQ [^]
It looks as if the animesh prim arrives with the last co-ordinate in the from region and has to fly clear across the region to get to the correct position in the new region.
I've tried this in several recent builds of OpenSim, including the latest.
Steps To ReproduceIf the description isn't enough to find the problem, I'll try building a simpler animesh vehicle to demonstrate the problem.
TagsNo tags attached.
Git Revision or version number5e26ede0f1362acef0a3ad4af9ca37d65ad0f3b2
Run Mode Grid (1 Region per Sim)
Physics EngineubODE
Script EngineYEngine
EnvironmentMono / Linux64
Mono Version6.x
ViewerFS 6.4.21
Attached Files

- Relationships

-  Notes
(0037885)
UbitUmarov (administrator)
2021-07-20 01:03

To me it looks like a viewer side issue ( like that strange sound ??)
But some more testing needed.
(0037903)
Kayaker Magic (reporter)
2021-07-24 10:31

I demonstrated the problem in SL, so it probably is a viewer issue. I'll talk to Beq.
I built a simpler animesh model with no animated parts and no animations running, so it isn't the animations. I used a simpler vehicle script also, if anyone wants the model and the script for testing let me know.
I saw the problem in SL in FS 6.4.13, in OpenSim in FS 6.4.21. I'm told it does not happen in FS 6.3.9, but that may be a pre-mesh FS so it is pre-bug.
(0037904)
UbitUmarov (administrator)
2021-07-24 10:33

thanks for the information update
(0037916)
Kayaker Magic (reporter)
2021-07-28 15:35

I downloaded a copy of the SL Viewer and with that I tried the test with the simple animesh and the simple script. It also showed the same behavior: Animesh disappears on every crossing, then flies towards me from the other end of the new region and snaps into place.

- Issue History
Date Modified Username Field Change
2021-07-18 11:51 Kayaker Magic New Issue
2021-07-20 01:03 UbitUmarov Note Added: 0037885
2021-07-24 10:31 Kayaker Magic Note Added: 0037903
2021-07-24 10:33 UbitUmarov Note Added: 0037904
2021-07-28 15:35 Kayaker Magic Note Added: 0037916


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker