Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008885opensim[GRID] Hypergridpublic2021-03-31 14:552021-04-13 11:10
ReportereagleFX 
Assigned To 
PriorityhighSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformLinux/MonoOperating SystemDebian BusterOperating System Version10
Product Version0.9.1.0 
Target VersionFixed in Version 
Summary0008885: Inworld movement problem when loading/wearing full Body Alpha, with Diva d2 sim and remote mysql service.
DescriptionThis is kind of a strange problem, and seems to only be there when the mysql
server is on remote. the mySQL is setup according to Diva's reccomendations from her Github.(MariaDB) https://github.com/diva/d2/wiki/MySql [^]

I have installed the "MariaDb" on a Debian10 Linux VM (VMWare7)
server and this VM server only act as the mySQL.

Next I have Debian10 installed with Mono6 and DIVA D2 Distro "09110" from meteaversiink. http://metaverseink.com/download/diva-r09110.zip [^]


This sim then is setup to use the SQL server mysql only server as of the setup in MyWorld.ini.

Everything looks fine until for example loads "Athena" Full body Alpha.
AthenaMeshBody Full Alpha V2.0 (Hair Head Eyes Body)

As soon as that is done the movements in the region is like i then walk and stop walk and stop. it is like something prevents me from moving smooth as normal.

As soon as i take off the Alpha, the symptom goes away.

I have another test setup where the Same Diva D2 Sim and the MySQL is on same server and here I do not have this movement problem.


Steps To Reproduceloads "Athena" Full body Alpha. AthenaMeshBody Full Alpha V2.0 (Hair Head Eyes Body)


It actually seems like it does not really matter which alpha i wear then it makes this problem as soon as it is off i walk normal again.
Additional InformationMy testing has been done on a DIVA D2 4 region setup with a single user inworld.

Testing was done on several "Complete AVI packages" as well as this package.

"Athena Bento BOM Mesh Body 6.0 (August 7 2020) Boxed"

I have actually tested this on two very different mysql remote servers, and it is same symptoms/issue.
TagsNo tags attached.
Git Revision or version numberN/A
Run Mode Standalone (Multiple Regions)
Physics EngineBulletSim
Script EngineXEngine
EnvironmentMono / Linux64
Mono Version6.x
ViewerFirestorm 6.4.13
Attached Files

- Relationships

-  Notes
(0037696)
tampa (reporter)
2021-04-01 03:59

Create a new alpha with full transparent textures. There was a problem some time ago with some alpha using black or white textures causing massive rebake spam. Setting the alpha textures to transparent solved that. Might not be related, but one less variable. When in doubt don't trust remote import to go smoothly either, set MariaDB max packet sizes to at least 64Mb or more to prevent data being cut or corrupted.

Where possible database should bet setup as localized as possible, meaning same system. Not just for performance, but also security.
(0037711)
eagleFX (reporter)
2021-04-13 11:10

I had to go back and run the MariaDB local, to get this resolved properly.

- Issue History
Date Modified Username Field Change
2021-03-31 14:55 eagleFX New Issue
2021-04-01 03:59 tampa Note Added: 0037696
2021-04-13 11:10 eagleFX Note Added: 0037711


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker