Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008870opensim[REGION] Scripting Enginepublic2021-03-01 03:582021-03-03 06:26
ReporterCliffordHanger 
Assigned Totampa 
PrioritynormalSeverityfeatureReproducibilityalways
StatusresolvedResolutionfixed 
PlatformlinuxOperating SystemubuntuOperating System Version16.04
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0008870: on all 0.9.2 i have tried, built on Ubuntu 20.04 using multi regions per sim results in httpResponse only working on one region
Descriptionusing multi regions per sim results in httpResponse only working on one region
tested various dev builds jan and feb 2021
grid mode
Steps To Reproducecreate an instance with multiple regions per instance
test using any llHTTPRequest(url)

http_response event is received only on one region
nothing on the "bad" regions

the "good" region is the first entry in thr Regions.ini file

on all regions the url used is receiving the info


Additional Informationbuilt with > mono --version
Mono JIT compiler version 6.12.0.107 (tarball Thu Dec 10 05:26:45 UTC 2020)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
    TLS: __thread
    SIGSEGV: altstack
    Notifications: epoll
    Architecture: amd64
    Disabled: none
    Misc: softdebug
    Interpreter: yes
    LLVM: yes(610)
    Suspend: hybrid
    GC: sgen (concurrent by default)

running under:
> mono --version
Mono JIT compiler version 6.8.0.123 (tarball Tue May 12 15:13:37 UTC 2020)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
    TLS: __thread
    SIGSEGV: altstack
    Notifications: epoll
    Architecture: amd64
    Disabled: none
    Misc: softdebug
    Interpreter: yes
    LLVM: yes(610)
    Suspend: hybrid
    GC: sgen (concurrent by default)
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script EngineXEngine
EnvironmentMono / Linux64
Mono VersionNone
Viewerfirestorm 6.0.2 and 6.4.1
Attached Files

- Relationships

-  Notes
(0037583)
UbitUmarov (administrator)
2021-03-01 07:36

Thanks
Should be better on master now
(0037584)
UbitUmarov (administrator)
2021-03-01 07:40

note that running with a mono version older than the one used to compile is a invite to trouble.
(0037585)
CliffordHanger (reporter)
2021-03-01 07:58
edited on: 2021-03-01 10:31

thanks for prompt action - will test now
confirm all is good thank you

(0037586)
Manni (reporter)
2021-03-01 12:12

Hooray it works!
(0037594)
tampa (reporter)
2021-03-03 06:26

Good to hear, if anything changes feel free to re-open.

- Issue History
Date Modified Username Field Change
2021-03-01 03:58 CliffordHanger New Issue
2021-03-01 07:36 UbitUmarov Note Added: 0037583
2021-03-01 07:40 UbitUmarov Note Added: 0037584
2021-03-01 07:58 CliffordHanger Note Added: 0037585
2021-03-01 10:31 CliffordHanger Note Edited: 0037585 View Revisions
2021-03-01 12:12 Manni Note Added: 0037586
2021-03-03 06:26 tampa Note Added: 0037594
2021-03-03 06:26 tampa Status new => resolved
2021-03-03 06:26 tampa Fixed in Version => master (dev code)
2021-03-03 06:26 tampa Resolution open => fixed
2021-03-03 06:26 tampa Assigned To => tampa


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker