Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008844opensim[REGION] Scripting Enginepublic2021-01-02 18:492021-01-03 06:21
Reporterdjphil 
Assigned Totampa 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOperating SystemWindowsOperating System Version10
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0008844: [SCRIPT ENGINE] Empty string on PARCEL_MEDIA_COMMAND_URL return error
DescriptionA empty string on PARCEL_MEDIA_COMMAND_URL return a error in OpenSim (with X and Y) but not in Second Life. This did not return an error in the past.
Steps To ReproducellParcelMediaCommandList([PARCEL_MEDIA_COMMAND_URL, ""]);
return: [18:43] llParcelMediaCommandList: invalid PARCEL_MEDIA_COMMAND_URL
Additional InformationTested with Firestorm 6.4.12.62831 only.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineubODE
Script EngineXEngine, YEngine
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm
Attached Files

- Relationships

-  Notes
(0037443)
tampa (reporter)
2021-01-03 04:43

It's a void so normally shouldn't even do a return, well attached patch just removes the lines and error, though this will result in it still trying to parse everything so effects might be weird there, let me know how it goes.
(0037445)
UbitUmarov (administrator)
2021-01-03 05:05

should be better on master now

thanks for the patch, but since it is not good i removed it to avoid mistakes
(0037446)
tampa (reporter)
2021-01-03 05:45

Seems invalid urls normally just fail silently and are not treated as "" either. So this just means verbose info on invalid urls, but scripts should still function just the same(don't think anyone intentionally uses bad urls but who knows). "" is being used a clearing command to remove the url, this is now handled properly.

So yeah resolved on master, re-open if anything changes :)
(0037447)
djphil (reporter)
2021-01-03 06:20

It works fine now, ty.

- Issue History
Date Modified Username Field Change
2021-01-02 18:49 djphil New Issue
2021-01-03 04:41 tampa File Added: 0001-Don-t-return-error.patch
2021-01-03 04:43 tampa Note Added: 0037443
2021-01-03 05:05 UbitUmarov File Deleted: 0001-Don-t-return-error.patch
2021-01-03 05:05 UbitUmarov Note Added: 0037445
2021-01-03 05:45 tampa Note Added: 0037446
2021-01-03 05:45 tampa Status new => resolved
2021-01-03 05:45 tampa Fixed in Version => master (dev code)
2021-01-03 05:45 tampa Resolution open => fixed
2021-01-03 05:45 tampa Assigned To => tampa
2021-01-03 06:20 djphil Note Added: 0037447
2021-01-03 06:20 djphil Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker