Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008737opensim[GRID] Other Servicepublic2020-08-04 18:292020-10-14 23:48
ReporterWaki Janus 
Assigned ToMonamusa Kaliopov 
PrioritynormalSeveritytrivialReproducibilityN/A
StatusresolvedResolutionwon't fix 
PlatformOSOS Version
Product Version0.9.1.0 
Target VersionFixed in Version 
Summary0008737: There are three General questions in this.
Description1) It is extremely difficult finding information on exactly what updates and patches have been done to both Snail and Yeti. The whole situation is extremely confused and not helped by the failure to maintain the main pages including download pages of the Opensimulator.org web site.
2) Is EEP, or the OS equivalent, actually part of the current Opensim OS. If so please direct us to the current patch or update incorporating it
3) Please consider providing a page dedicated to providing news updates on OS developments and updates. The last news item on the current new page was posted almost a year ago in 2019.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineubODE
Script EngineYEngine
EnvironmentMono / Linux64
Mono Version6.x
ViewerFirestorm 6.4.5.60799
Attached Files

- Relationships

-  Notes
(0036656)
BillBlight (developer)
2020-08-04 18:33
edited on: 2020-08-04 18:37

It is in the dev master, and links to that are on development part of the wiki ..

But since I'm already here ...

http://opensimulator.org/viewgit/?a=shortlog&p=opensim [^]

The dev master is not intended for general release, and should only be used by people who understand what they are doing using/compiling pre-release code.

(0036657)
BillBlight (developer)
2020-08-04 18:34

There is also the dev mailing list, which is also on the wiki ..
(0036658)
BillBlight (developer)
2020-08-04 18:34

And IRC
(0036659)
Waki Janus (reporter)
2020-08-04 22:31

Thank you Bill.
(0036660)
Monamusa Kaliopov (reporter)
2020-08-05 23:56

Please ask again at the right places suggested by BillBlight
(0036661)
Waki Janus (reporter)
2020-08-06 00:06

It not very helpful to receive notes from Monamusa Kalipova the I am denied access to even though I am logged in.

I still have two major questions:
1) Does the latest patches include EEP?
2) Where is the web address to register email to get updates?
(0036662)
Aramis Soren (reporter)
2020-08-06 01:08

Mailing Lists
http://opensimulator.org/wiki/Mailing_Lists [^]

Opensim-users
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users [^]

Opensim-dev
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev [^]
(0036663)
BillBlight (developer)
2020-08-06 05:36

The master dev code does include eep a quick search on the git link I posted would show EEP commits, AGAIN this is master dev code, for development only , for testing, I'd suggest you stay far away from it, since you could not tell if eep was there .. Until it is released, although osgrid did release a test version.

It really is for developers and people who compile their own ..
(0036665)
Waki Janus (reporter)
2020-08-06 18:19

Bill, I don't pretend to be a tech, but I find myself often having to navigate lots of shit to help our techs do their job. The master tech, Kunta Kinte, who keeps our grid running is the developer (along with Melanie) of XMRE, which is Y-Engine. Even he was lost at what was happening. He also complained that UBit has stopped responding to his emails or messages. ODE physics is also a product of Kitto Flora and he's been left confused by developments. It would be nice if the Opensimulator developers paid us a little bit more attention. We are trying to help after all!!!!
(0036666)
tampa (reporter)
2020-08-06 19:05

Someone who has the expertise to develop Y-Engine should have no issue following along development. There are multiple channels that relay what's being changed and a weekly meeting that can be used to ask questions. I find no difficulty to reach Ubit or other devs, never have. You have some of the most responsive people now doing active development on it, granted their responses are not always something you want to hear or agree with, but there is plenty of discourse happening.

You can check the viewgit, read the meeting minutes, mailing list on nabble, ask on irc, show up to the meetings or simply git clone and check diff. If you want to help the project, check the mantis for outstanding issues, try to reproduce or fix them up, that's what most people seem to do and generally helps the most. You can also check the wiki for outdated articles and write new ones or providing supporting assets and materials for people to get started more quickly.

What do you want more, development work or documentation? Developers tend to not document things, because that is tedious and they'd rather spend their time actually writing code than trying to think of ways to explain it. I'd rather see development and testing instead of documentation, because I can read the code and make sense of it myself and if I cannot, I simply ask on irc, that has worked for 5+ years.
(0036667)
UbitUmarov (administrator)
2020-08-06 19:10
edited on: 2020-08-06 19:15

I did answered to all emails i did received (i think)
But this mantis is the best form to report issues.

we also have tuesdays meetings

http://opensimulator.org/wiki/Office_Hours [^]

(0036955)
Ferd Frederix (reporter)
2020-10-14 23:48

Closing as it had already been resolved as won't fix.

- Issue History
Date Modified Username Field Change
2020-08-04 18:29 Waki Janus New Issue
2020-08-04 18:33 BillBlight Note Added: 0036656
2020-08-04 18:34 BillBlight Note Added: 0036657
2020-08-04 18:34 BillBlight Note Added: 0036658
2020-08-04 18:37 BillBlight Note Edited: 0036656 View Revisions
2020-08-04 22:31 Waki Janus Note Added: 0036659
2020-08-05 23:56 Monamusa Kaliopov Note Added: 0036660
2020-08-05 23:56 Monamusa Kaliopov Status new => resolved
2020-08-05 23:56 Monamusa Kaliopov Resolution open => won't fix
2020-08-05 23:56 Monamusa Kaliopov Assigned To => Monamusa Kaliopov
2020-08-06 00:06 Waki Janus Note Added: 0036661
2020-08-06 00:06 Waki Janus Status resolved => patch included
2020-08-06 01:08 Aramis Soren Note Added: 0036662
2020-08-06 05:36 BillBlight Note Added: 0036663
2020-08-06 18:19 Waki Janus Note Added: 0036665
2020-08-06 19:05 tampa Note Added: 0036666
2020-08-06 19:10 UbitUmarov Note Added: 0036667
2020-08-06 19:15 UbitUmarov Note Edited: 0036667 View Revisions
2020-10-14 23:48 Ferd Frederix Note Added: 0036955
2020-10-14 23:48 Ferd Frederix Severity major => trivial
2020-10-14 23:48 Ferd Frederix Status patch included => resolved


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker