Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008733opensim[GRID] Grid Servicepublic2020-07-17 19:232020-07-19 21:07
ReporterSpyri 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionno change required 
PlatformPCOSWindows OS VersionWindows 10
Product Version0.9.1.0 
Target VersionFixed in Version 
Summary0008733: Unable to run updated OpenSim.exe - immediate crash
DescriptionOpensim.exe will open briefly, run through a quick log and crash. It usually happens so quick that I can't even read if there are any errors in the log before it closes.

Opensim will run through an old version of soas diva just fine (specifically r25084). I have gone through multiple setups in an attempt to get an updated version of diva opensim working and I've gone through many articles and youtube tutorials to be sure I've installed everything correctly, but I'm struggling to find out what might be causing the crash.

All required ports have been forwarded appropriately to my knowledge.

Unfortunately I am not familiar enough this to troubleshoot this on my own. I'm not certain if this is enough information to go off of, but I can provide more specific details as needed. Any help on this matter would be very much appreciated~
TagsNo tags attached.
Git Revision or version number
Run Mode Standalone (Multiple Regions)
Physics EngineBasicPhysics
Script EngineXEngine
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm
Attached Files

- Relationships

-  Notes
(0036612)
tampa (reporter)
2020-07-18 05:34

If you open a terminal and run the OpenSim.exe from that terminal instead of double clicking on the executable it will leave the window open if it crashes. Without a log we can't really help much.

Wifi may not work with master code if changes are too grave, either stick to releases or see if Diva or anyone on the mailing list knows of a well working version.
(0036625)
Ferd Frederix (reporter)
2020-07-19 20:56

Look in Opensim.log in opensim\bin for clues. And as Tampa says, run it from a command prompt so you can see what it says.

You can get a working version of Opensim set for your IP by running (once) the DreamGrid application. The Opensim folder will contain a running version after you boot it the first time. Batch files are included if you want to run Mysql, Robust and Opensim instances manually, instead of using a GUI. And it is stock Opensim 0.9.1.0. Source is at Github, and the link to the installer and source is at https://outworldz.com/Outworldz_installer/Grid/ [^]
(0036626)
Ferd Frederix (reporter)
2020-07-19 20:58

Also, this is not a bug in Opensim, so I am closing this. You can contact me directly by email and I'll be happy to assist further. fred@outworldz.com

- Issue History
Date Modified Username Field Change
2020-07-17 19:23 Spyri New Issue
2020-07-18 05:34 tampa Note Added: 0036612
2020-07-19 20:56 Ferd Frederix Note Added: 0036625
2020-07-19 20:58 Ferd Frederix Note Added: 0036626
2020-07-19 20:59 Ferd Frederix Resolution open => won't fix
2020-07-19 21:07 Ferd Frederix Status new => resolved
2020-07-19 21:07 Ferd Frederix Resolution won't fix => no change required


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker