Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008721opensim[REGION] Specific OpenSim Modulepublic2020-06-28 08:112020-09-02 12:45
Reporternixnerd 
Assigned Tonixnerd 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformLinuxOSUbuntu OS Version20.04 LTS
Product Version 
Target VersionFixed in Version 
Summary0008721: Using either opensim 0.9.1.1 stable or stable source and compiling V2 groups tables are not created
DescriptionUsing either opensim 0.9.1.1 stable or stable source and compiling V2 groups tables are not created, as apparent in the console, with error message such as: Table 'opensim.os_groups_membership' doesn't exist
Steps To ReproduceUse opensim 0.9.1.1 either stable or source, configure Robust Group Service and OpenSim.ini appropriately, as documented on the opensim web site
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineubODE
Script EngineXEngine
EnvironmentMono / Linux64
Mono Version5.x
ViewerFirestorm Latest
Attached Filespatch file icon os_groups_Store.patch [^] (383 bytes) 2020-07-23 16:56 [Show Content]
patch file icon fix-db-engines-and-charset.patch [^] (3,576 bytes) 2020-07-24 03:20 [Show Content]

- Relationships

-  Notes
(0036570)
nixnerd (reporter)
2020-06-29 07:46

Looks like this migration issue is caused by an incorrect default MySQL collation type, as indicated in the Robust log:

Robust.log:2020-06-28 18:41:07,056 DEBUG (1) - OpenSim.Data.Migration [MIGRATIONS]: Cmd was Specified key was too long; max key length is 1000 bytes in SQL: BEGIN; CREATE TABLE `os_groups_groups...

Using something like the following, on DB creation may offer a work-around:

CREATE DATABASE db_name DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_general_ci;
CREATE DATABASE db_name DEFAULT CHARACTER SET utf8 DEFAULT COLLATE latin1_swedish_ci;
(0036571)
nixnerd (reporter)
2020-06-29 12:20

Resolved
(0036635)
neil2ball (reporter)
2020-07-23 16:47

--- OpenSim/Data/MySQL/Resources/os_groups_Store.migrations 2020-07-23 18:44:28.925942653 -0400
+++ OpenSim/Data/MySQL/Resources/os_groups_Store.migrations 2020-07-23 19:07:01.774530496 -0400
@@ -18,7 +18,7 @@
   PRIMARY KEY (`GroupID`),
   UNIQUE KEY `Name` (`Name`),
   FULLTEXT KEY `Name_2` (`Name`)
-) ENGINE=MyISAM;
+) ENGINE=InnoDB;
 
 
 CREATE TABLE `os_groups_membership` (
(0036637)
tampa (reporter)
2020-07-24 03:20

There are a few more that don't have defaults set so they would default to those set by the mysql server which might cause conflicts. Attached a combined patch for them all set to the defaults reported from a fresh install of master with default db config.

- Issue History
Date Modified Username Field Change
2020-06-28 08:11 nixnerd New Issue
2020-06-29 07:46 nixnerd Note Added: 0036570
2020-06-29 12:20 nixnerd Note Added: 0036571
2020-06-29 12:21 nixnerd Status new => resolved
2020-06-29 12:21 nixnerd Resolution open => fixed
2020-06-29 12:21 nixnerd Assigned To => nixnerd
2020-07-23 16:47 neil2ball Note Added: 0036635
2020-07-23 16:47 neil2ball Status resolved => patch included
2020-07-23 16:56 neil2ball File Added: os_groups_Store.patch
2020-07-24 03:20 tampa Note Added: 0036637
2020-07-24 03:20 tampa File Added: fix-db-engines-and-charset.patch
2020-09-02 12:45 nixnerd Status patch included => resolved


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker