Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008690opensim[MISC] Compiling / Buildingpublic2020-04-20 04:182020-04-20 06:23
Reporterfds24000 
Assigned Tofds24000 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionno change required 
PlatformLinuxOSDebianOS VersionBullseye/Sid
Product Version 
Target VersionFixed in Version 
Summary0008690: Building from source throws error "Microsoft.CSharp.targets not found" for all build files
Description/usr/lib/mono/msbuild/Current/bin/Microsoft.CSharp.CurrentVersion.targets(333,5): error MSB4019: The imported project "/usr/lib/mono/msbuild/Current/bin/Roslyn/Microsoft.CSharp.Core.targets" was not found. Confirm that the expression in the Import declaration "/usr/lib/mono/msbuild/Current/bin/Roslyn/Microsoft.CSharp.Core.targets" is correct, and that the file exists on disk.
Steps To ReproducePull code from git
Build solutions using Microsoft Mono/ msbuild
Additional InformationSee attached .txt to view full console output
TagsNo tags attached.
Git Revision or version numberlatest
Run ModeStandalone (1 Region)
Physics EngineubODE
Script EngineXEngine
EnvironmentMono / Linux64
Mono VersionOther
Viewer
Attached Filestxt file icon build-log-errors.txt [^] (143,376 bytes) 2020-04-20 04:22 [Show Content]

- Relationships

-  Notes
(0036392)
tampa (reporter)
2020-04-20 05:16

Seems like it created the sln but not the csproj files, can you confirm they exist?

Which version of mono are you using?
(0036394)
fds24000 (reporter)
2020-04-20 05:21
edited on: 2020-04-20 05:23

Here's the apt policy output:

os@ossrv:~$ apt policy mono-devel
mono-devel:
  Installed: 6.8.0.105+dfsg-3
  Candidate: 6.8.0.105+dfsg-3
  Version table:
 *** 6.8.0.105+dfsg-3 500
        500 https://deb.debian.org/debian [^] testing/main amd64 Packages
        100 /var/lib/dpkg/status
     6.8.0.105-0xamarin3+debian10b1 500
        500 https://download.mono-project.com/repo/debian [^] stable-buster/main amd64 Packages
os@ossrv:~$ apt policy msbuild
msbuild:
  Installed: 1:16.5+xamarinxplat.2020.01.10.05.36-0xamarin1+debian10b1
  Candidate: 1:16.5+xamarinxplat.2020.01.10.05.36-0xamarin1+debian10b1
  Version table:
 *** 1:16.5+xamarinxplat.2020.01.10.05.36-0xamarin1+debian10b1 500
        500 https://download.mono-project.com/repo/debian [^] stable-buster/main amd64 Packages
        100 /var/lib/dpkg/status

I might have to add that I already removed all mono related packages and reinstalled them.

(0036400)
fds24000 (reporter)
2020-04-20 06:19

UPDATE:

Sorry guys, I'm a dunce. I noticed that msbuild had been installed from the Debian repos instead from download.mono-project.com (see last comment).

I simply forgot to pin the mono repo after redoing the server from scratch. Compiling/building works again, as expected.

Looks like the Debian repo msbuild has some incompatibilities when mixed with mono-devel from Mono.

My bad!
(0036401)
fds24000 (reporter)
2020-04-20 06:22

Mixing mono-devel from download.mono.org and deb.debian.org is a bad idea.
Apt pinning is your friend - do it! ;)
(0036402)
tampa (reporter)
2020-04-20 06:23

Glad it is working again :)

- Issue History
Date Modified Username Field Change
2020-04-20 04:18 fds24000 New Issue
2020-04-20 04:22 fds24000 File Added: build-log-errors.txt
2020-04-20 04:23 fds24000 Additional Information Updated View Revisions
2020-04-20 04:23 fds24000 Mono Version 2.10 => Other
2020-04-20 04:23 fds24000 Product Version 0.9.1.0 =>
2020-04-20 04:24 fds24000 Summary Buildin from source throws error "Microsoft.CSharp.targets not found" for all build files => Building from source throws error "Microsoft.CSharp.targets not found" for all build files
2020-04-20 05:16 tampa Note Added: 0036392
2020-04-20 05:21 fds24000 Note Added: 0036394
2020-04-20 05:23 fds24000 Note Edited: 0036394 View Revisions
2020-04-20 06:19 fds24000 Note Added: 0036400
2020-04-20 06:22 fds24000 Note Added: 0036401
2020-04-20 06:22 fds24000 Status new => resolved
2020-04-20 06:22 fds24000 Resolution open => fixed
2020-04-20 06:22 fds24000 Assigned To => fds24000
2020-04-20 06:23 tampa Note Added: 0036402
2020-04-20 06:23 tampa Resolution fixed => no change required


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker