Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008678opensim[REGION] OpenSim Corepublic2020-03-29 13:152020-05-06 08:49
ReporterKubwa 
Assigned ToUbitUmarov 
PrioritynormalSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0008678: REST (Remote) Console broken
DescriptionWhen running opensim with rest console, you cannot run commands trought rest console. The command will be executed but there is no result being sent.

(Compare 0.9.0 to latest DEV)

REST console works different now (doesnt work at all and especially not as decumented in wiki)
Steps To ReproduceLogin to REST console and submit a command.
The command will be executed but the result of the command is not being shown in the REST console output.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineubODE
Script EngineXEngine
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0036416)
Kubwa (reporter)
2020-05-01 08:22

I've added more details.
This problem is still in the latest dev. It looks like the console code is broken due to the recent changes.

Could you please fix that? I tried it myself and just got crazy :(
(0036417)
UbitUmarov (administrator)
2020-05-01 09:00

i do understand going crazy on this ;)
(0036418)
UbitUmarov (administrator)
2020-05-01 09:50

please try now
(0036419)
Kubwa (reporter)
2020-05-01 09:53

Is it this change?
http://opensimulator.org/viewgit/?a=commit&p=opensim&h=ab1424187114e171512d8702f6f6a9bed5381c28 [^]

Its the rest console client. The problems seems to be in the server code. It looks like the command result is not being added to the console buffer in the rest console :)
(0036420)
UbitUmarov (administrator)
2020-05-01 18:45

did you tested with this changed client ?
(0036421)
Kubwa (reporter)
2020-05-01 23:55
edited on: 2020-05-02 00:00

With the rest console, connected to my region, the console output is the following:

Z:\Unsortiert\OpenSim Updater\OpenSim Update>OpenSim.ConsoleClient
[CONFIG]: Loading environment variables for Config
08:47:47 - [SERVER BASE]: Starting in Z:\Unsortiert\OpenSim Updater\OpenSim Update
08:47:47 - [SERVER BASE]: OpenSimulator version: OpenSim 0.9.2.0 Yeti Dev
08:47:47 - [SERVER BASE]: Operating system version: Microsoft Windows NT 6.2.9200.0, .NET platform Win32NT, 64-bit
Console log level is ALL
08:47:47 - [SERVER BASE]: Logging started to file Z:\Unsortiert\OpenSim Updater\OpenSim Update\OpenSim.ConsoleClient.log

31 - [MuteListModule]: enabled
31 - [!]--[ Kubwa OpenSim Manager ]--------------------------
31 - [!]OpenSim ProccessID: 17260
32 - [SCENE COMMUNICATION SERVICE] Informing 0 neighbours that region test is up
Client# help

To enter an argument that contains spaces, surround the argument with double quotes.
For example, show object name "My long object name"

For more information, type 'help all' to get a list of all commands,
              or type help <item>' where <item> is one of the following:
Debug
General
Help

Client# help

To enter an argument that contains spaces, surround the argument with double quotes.
For example, show object name "My long object name"

For more information, type 'help all' to get a list of all commands,
              or type help <item>' where <item> is one of the following:
Debug
General
Help

Client# status
Invalid command
Client# alert hallo
36 - [DIALOG]: Sending general alert in region test with message hallo
Client# login status
Client# help login

No help is available for login

Client# login status
Client# show info
Client# show help
Invalid command
Client# help show

No help is available for show

Client# show users
Client# terrain fill 21
50 - [REGION DB]: Storing terrain
50 - [TERRAIN DATA] V2DGzip 296 bytes
Client# alert hello
52 - [DIALOG]: Sending general alert in region test with message hello
Client#


As you can see, commands like "alert" are creating an output. other commands like "login status" or "show info" does not.
"debug http in all 6" is producing output (i dont want to show that output here).

It is really weird.
Looks like asynchronous commands are being shown with their output, while synchronous commands (mostly info commands) are not.

(0036445)
Kubwa (reporter)
2020-05-05 12:30

Any news to this issue? Can i do anything more to help to find and resolve the issue?
(0036446)
djphil (reporter)
2020-05-05 12:35
edited on: 2020-05-05 12:36

As you can see on mantis 0007717,I have even more difficulties than you to get it to work under Windows ... ^^
I did not link the issues because it is not really the same problem.

(0036447)
UbitUmarov (administrator)
2020-05-05 12:36

i made another small code change, a few days ago
(0036448)
Kubwa (reporter)
2020-05-05 12:38

oh, havent seen them Ubit. I will check that out tomorrow and will give feedback. Thanks :)
(0036449)
Kubwa (reporter)
2020-05-06 08:48

Ok, i tested it with the latest dev and it seems to work :)
The ticket can be closed.

Thank you very much Ubit for fixing this issue.
(0036450)
Kubwa (reporter)
2020-05-06 08:49

Problem seems to be fixed in the latest dev from today 06. May 2020

- Issue History
Date Modified Username Field Change
2020-03-29 13:15 Kubwa New Issue
2020-05-01 08:20 Kubwa Steps to Reproduce Updated View Revisions
2020-05-01 08:22 Kubwa Note Added: 0036416
2020-05-01 09:00 UbitUmarov Note Added: 0036417
2020-05-01 09:03 Kubwa Description Updated View Revisions
2020-05-01 09:50 UbitUmarov Note Added: 0036418
2020-05-01 09:53 Kubwa Note Added: 0036419
2020-05-01 18:45 UbitUmarov Note Added: 0036420
2020-05-01 23:55 Kubwa Note Added: 0036421
2020-05-01 23:56 Kubwa Note Edited: 0036421 View Revisions
2020-05-02 00:00 Kubwa Note Edited: 0036421 View Revisions
2020-05-05 12:30 Kubwa Note Added: 0036445
2020-05-05 12:35 djphil Note Added: 0036446
2020-05-05 12:36 djphil Note Edited: 0036446 View Revisions
2020-05-05 12:36 djphil Note Edited: 0036446 View Revisions
2020-05-05 12:36 UbitUmarov Note Added: 0036447
2020-05-05 12:38 Kubwa Note Added: 0036448
2020-05-06 08:48 Kubwa Note Added: 0036449
2020-05-06 08:49 UbitUmarov Status new => resolved
2020-05-06 08:49 UbitUmarov Resolution open => fixed
2020-05-06 08:49 UbitUmarov Assigned To => UbitUmarov
2020-05-06 08:49 Kubwa Note Added: 0036450
2020-05-06 08:49 Kubwa Fixed in Version => master (dev code)


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker