Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008677opensim[GRID] Robust Serverpublic2020-03-27 08:472020-03-31 01:41
Reportervladimir Djannovic 
Assigned Totampa 
PrioritylowSeverityminorReproducibilityhave not tried
StatusresolvedResolutionno change required 
PlatformOpensim 0.9.2 devOSWindows server 2012OS VersionWindows server 2
Product Version 
Target VersionFixed in Version 
Summary0008677: Robust Table
DescriptionHello, I would like to have a little information.
Is it possible to purge the contents of the GridUser table from robust without risk?
Thank you in advance for your answers

cordially
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Script EngineXEngine
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0036303)
djphil (reporter)
2020-03-27 11:32
edited on: 2020-03-27 11:49

The Griduser table is created and populated when users register.
It is then gradually updated according to the activity of the users.
Although you can purge this table, it is not recommended to do so.

(0036304)
tampa (reporter)
2020-03-27 11:41

Actually the table only contains data regarding users home positions and last locations, some data regarding their last login/logout and their full userid including remote grid. You can technically purge the table, but it will cause issues for local users since their logins are not going to work smoothly. Hypergrid users generally have no such issues. Used to purge those of defunct grids from the table which isn't going to bother them none. I would advice against altering the table unless you have some other problem to fix.
(0036305)
vladimir Djannovic (reporter)
2020-03-27 12:54

ok, so i wouldn't touch this table, thanks
(0036312)
tampa (reporter)
2020-03-31 01:41

It is not advised to alter the table unless there are issues resulting from the entries within, generally removing the hypergrid entries should not cause problem though.

- Issue History
Date Modified Username Field Change
2020-03-27 08:47 vladimir Djannovic New Issue
2020-03-27 11:32 djphil Note Added: 0036303
2020-03-27 11:32 djphil Note Edited: 0036303 View Revisions
2020-03-27 11:41 tampa Note Added: 0036304
2020-03-27 11:49 djphil Note Edited: 0036303 View Revisions
2020-03-27 12:54 vladimir Djannovic Note Added: 0036305
2020-03-27 12:57 vladimir Djannovic Resolution open => fixed
2020-03-31 01:41 tampa Note Added: 0036312
2020-03-31 01:41 tampa Status new => resolved
2020-03-31 01:41 tampa Resolution fixed => no change required
2020-03-31 01:41 tampa Assigned To => tampa


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker