Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008640opensim[REGION] OpenSim Corepublic2020-01-14 02:172020-01-14 13:44
Reporteraiaustin 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformPCOSWindowsOS Version10
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0008640: Clicking on a chat location URL either does not retrieve the region details or show on map is using a HG URL on home grid
DescriptionI am having recent trouble with the clickable URLs inserted in local chat for the region you teleported away from. This report is for a simple test where all regions involved on one grid (OSGrid). I am using Firestorm, and this replicates on the old stable 6.0.2, as well as later experimental versions I am using. I am moving to an fro between a home region "Vue-Port" and another region "RuthAndRoth". The region details, region profile style image, etc is retrieved in the case of both links shown in nearby chat:

hop://login.osgrid.org/Vue-Port/128/128/26 [^]
hop://login.osgrid.org/RuthAndRoth/128/128/26 [^]

Except that the region name being looked up is the full hypergrid address

hg.osgrid.org:80:Vue-Port
hg.osgrid.org:80:RuthAndRoth

See attached image 2020-01-14-OSGrid-Firestorm-Mix-Up-of-Region-Names-in-Show-On-Map-Clicks.jpg

The links when clicked do work, and the map details change to drop the grid URI element if the map is used when actually on the destination region.

BUT... when I have another region running with a similar but not identical name "RuthAndRoth2"... things appear to get mixed up. Clicking on the RuthAndRoth link then fails to bring up the region details, and the profile image remains a "?". The show on map button fails to complete the Map tool information. See image Firestorm-Click-on-Chat-Hop-Link-Fails-if-Exists-Region-Names-Similar.jpg

BUT... if I restart the similarly named image with just the region name changed (to "R2-Backup" in this experiment) then click on link details show and the button to show on map works correctly again.

I have done the obvious things of checking do not have the same UUID for the regions (I don't) and the two OpenSim.exe instances for the RuthAndRoth and RuthAndRoth2 regions are on different servers and ports. Nothing I can find in the .ini configurations indicate any overlap.

Starting RuthAndRoth and RuthndRoth2 in either order appears to have no effect. Its always RuthAndRoth hat when clicked in nearby chat fails to retrieve its region information or show on map.

TagsNo tags attached.
Git Revision or version number0.9.2.0 2020-01-12 21:29
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script EngineXEngine
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm 6.0.2
Attached Filesjpg file icon 2020-01-14-OSGrid-Firestorm-Mix-Up-of-Region-Names-in-Show-On-Map-Clicks.jpg [^] (355,153 bytes) 2020-01-14 02:17
jpg file icon 2020-01-14-OSGrid-Firestorm-Click-on-Chat-Hop-Link-Fails-if-Exists-Region-Names-Similar.jpg [^] (270,278 bytes) 2020-01-14 02:17

- Relationships

-  Notes
(0036048)
UbitUmarov (administrator)
2020-01-14 02:31

This is a viewer side issue
(0036050)
aiaustin (developer)
2020-01-14 03:13
edited on: 2020-01-14 03:16

That looks to be the case Ubit... it works fine in Singularity but not Firestorm 6.0.2 or later versions I tested.

Maybe some sort of partial region name matching is taking place.

On OSGrid a region named "Marineville" existed I had a region named "Outer Space". Clicking on the links in chat for both works fine. I then renamed the "Outer Space" region to "Marineville2" and after restarting and then clicking on the link in chat to Marineville it fails, clicking on Marineville2 works.

I replicated this on another grid (AiLand) too, just to check it was not a special setup thing on OSGrid.

I will start a Firestorm JIRA on this.

(0036051)
tampa (reporter)
2020-01-14 04:01

Come to think of it I don't think I have ever seen that work, especially not in FS. The top navigation bar is supposed to also work by inputting the region name you want to go to, but last I tried I ended up just being teleported to the default region or nothing happened at all. It's a bit odd this doesn't work "well" as the protocol is the same and whether HG or not the destination is too.
(0036052)
aiaustin (developer)
2020-01-14 04:44

I have started an FS JIRA as its clearly been an issue that has been around a while. I can see the same on OSGrid where I have regions named Castle, Castle Spring, Castle Autumn and Castle Winter as region names. The clickable link for Castle fails, the others work.

https://jira.firestormviewer.org/browse/FIRE-29276 [^]
(0036053)
beqjanus (reporter)
2020-01-14 13:44

I cannot reproduce the behaviour using slurls in SL, so I am going to look at the specifics around hop:: url processing. an over eager regex perhaps

- Issue History
Date Modified Username Field Change
2020-01-14 02:17 aiaustin New Issue
2020-01-14 02:17 aiaustin File Added: 2020-01-14-OSGrid-Firestorm-Mix-Up-of-Region-Names-in-Show-On-Map-Clicks.jpg
2020-01-14 02:17 aiaustin File Added: 2020-01-14-OSGrid-Firestorm-Click-on-Chat-Hop-Link-Fails-if-Exists-Region-Names-Similar.jpg
2020-01-14 02:19 aiaustin Description Updated View Revisions
2020-01-14 02:31 UbitUmarov Note Added: 0036048
2020-01-14 03:13 aiaustin Note Added: 0036050
2020-01-14 03:16 aiaustin Note Edited: 0036050 View Revisions
2020-01-14 03:16 aiaustin Note Edited: 0036050 View Revisions
2020-01-14 04:01 tampa Note Added: 0036051
2020-01-14 04:44 aiaustin Note Added: 0036052
2020-01-14 13:44 beqjanus Note Added: 0036053


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker