Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008631opensim[REGION] OpenSim Corepublic2019-11-24 00:402019-11-27 04:09
Reportertglion 
Assigned ToUbitUmarov 
PriorityurgentSeverityblockReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version0.9.1.0 
Target VersionFixed in Version 
Summary0008631: After last update to git master, regions wil not start correctly anymore.
DescriptionAfter update to last git master
I get several errors like this:

ERROR: There was an error while scanning assembly: /opt/opensim/DeepImpact/bin/OpenSim.exe (Could not load method 5 due to Could not load file or assembly 'Mono.Cecil, Version=0.10.0.0, Culture=neutral, PublicKeyToken=50cebf1cceb9d05e' or one of its dependencies.)

What is Mono.Cecil and how can I fix this?

When I restart the region second time, this error-messages are gone, but the region does not load RegionConfig.ini anymore and stops initializations with selecting region as root, what is wrong and I can't login to this region!

MonoVersion: 5.18.0.240 (Debian 5.18.0.240+dfsg-2ubuntu2 Wed Apr 17 23:39:09 UTC 2019)
Linux-Version: Ubuntu 19.04
OpenSim-Version: master 6e2b5ac238ec5614fb9067ef94024bccf0459264
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineubODE
Script EngineXEngine
EnvironmentMono / Linux64
Mono Version5.x
ViewerFirestorm 64
Attached Files

- Relationships

-  Notes
(0035905)
UbitUmarov (administrator)
2019-11-24 00:56
edited on: 2019-11-24 00:57

Mono.Cecil is included in bin, and seems the right version, with correct dependencies

(0035906)
tglion (reporter)
2019-11-24 01:20

I have identified the problem at this commit update mono addins ( need to runprebuidl and recomp opensim)

Have todo with addins
But I have running clean with runprebuild.sh
This does not help.

This commit is the last working for me:
103ebac0823b78934d60cb06cdaf97b817f29534 : terrain: make sure modify does get unblocked

This next commit fails:
7dd5c9ccadd299b07170452a8cac3e4866fee732 : update mono addins ( need to runprebuidl and recomp opensim)

I have still no idea to solve this problem. running runprebuild will not work either
(0035907)
tglion (reporter)
2019-11-24 01:56

If I checkout last master and revert last changes to the files
bin/Mono.Addins.dll
bin/Mono.Addins.Setup.dll
bin/Mono.Addins.CecilReflector.dll
bin/mautil.exe

to version in commit 103ebac0823b78934d60cb06cdaf97b817f29534
then it works.

What is the reason to change or update mono-addins/cecilRefelctor?
Is this update necesarry or can I use the previous version, which seems working to me?
(0035908)
UbitUmarov (administrator)
2019-11-24 03:48

ok changed the mono.cecil and the all lot again
can you please test?
(0035909)
Monamusa Kaliopov (reporter)
2019-11-24 05:15

here all works fine (debian 9.x)before and after the replacement of the .dll
(0035910)
tglion (reporter)
2019-11-24 05:16

Yes, this latest commit fixed the issue :-) Thank you.
(0035911)
Monamusa Kaliopov (reporter)
2019-11-27 04:06
edited on: 2019-11-27 04:08

@tglion

so your issue was resolved .. this ticket need the status resolved.

(0035912)
aiaustin (developer)
2019-11-27 04:09

Mono .dll replaced by Ubitumarov.

- Issue History
Date Modified Username Field Change
2019-11-24 00:40 tglion New Issue
2019-11-24 00:56 UbitUmarov Note Added: 0035905
2019-11-24 00:57 UbitUmarov Note Edited: 0035905 View Revisions
2019-11-24 01:20 tglion Note Added: 0035906
2019-11-24 01:56 tglion Note Added: 0035907
2019-11-24 03:48 UbitUmarov Note Added: 0035908
2019-11-24 05:15 Monamusa Kaliopov Note Added: 0035909
2019-11-24 05:16 tglion Note Added: 0035910
2019-11-27 04:06 Monamusa Kaliopov Note Added: 0035911
2019-11-27 04:08 aiaustin Note Edited: 0035911 View Revisions
2019-11-27 04:09 aiaustin Note Added: 0035912
2019-11-27 04:09 aiaustin Status new => resolved
2019-11-27 04:09 aiaustin Resolution open => fixed
2019-11-27 04:09 aiaustin Assigned To => UbitUmarov


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker