Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008586opensim[REGION] OpenSim Corepublic2019-08-31 21:132019-09-01 10:05
Reporterdjphil 
Assigned ToBillBlight 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionno change required 
PlatformPCOSWindowsOS Version10
Product Version0.9.0.1 
Target VersionFixed in Version0.9.0.1 
Summary0008586: WorldMap does not generate the correct object color
DescriptionEverything is said in the title.
The colors are reversed it seems.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineubODE
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm
Attached Filespng file icon worldmap_colors_error_01.png [^] (214,260 bytes) 2019-08-31 21:13


jpg file icon djphilmap.jpg [^] (70,636 bytes) 2019-08-31 21:44

- Relationships

-  Notes
(0035628)
BillBlight (developer)
2019-08-31 21:44

djphil , I tried to replicate your issue , see attached image ..
(0035629)
djphil (reporter)
2019-08-31 22:25

Ok, found the problem.

WorldMapModule = "HGWorldMapModule" don't work, wrong name.
WorldMapModule = "HGWorldMap" work fine.
and WorldMapModule = "WorldMap" work fine too.

Thank's for support.
(0035630)
aiaustin (developer)
2019-09-01 01:45

Interesting… in checking my .ini files I found this is set only in OpenSimDefaults.ini.. so I don't override it... BUT in OpenSimDefaultys,.ini there is no list of the choices available..

[Map]
    ;WorldMapModule = "WorldMap"

Maybe we should list the choices that are available there... Are these just

WorldMap and HGWorldMap?

If its is a choice, then I assume this ought to be a line added into OpenSim.ini.example?
(0035632)
aiaustin (developer)
2019-09-01 06:14
edited on: 2019-09-01 07:43

I was using the default on Openvue and AiLand grids i.e. "WorldMap" though they use Hypergrid. Looking at this more and trying to find an explanation of the differences...

Strange... in the wiki at http://opensimulator.org/wiki/HyperGrid_Team/HowTo [^]

The suggested configuration includes TWO lines.. I assume that is not correct and for HG the "WorldMap" line should be commented out?

; WorldMapModule = "WorldMap"
WorldMapModule = "HGWorldMap"

I thought I shouid check if "HGWorldMap" is operational, up to date and the correct thing to enable before making changes to the Wiki page?

But whatever, the OpenSim.ini.example file ought to show the options available and have a line to say For Hypergrid use "HGWorldMap" if that is so.

(0035634)
BillBlight (developer)
2019-09-01 09:57
edited on: 2019-09-01 10:04

No , because it is in the GridHypergrid and StandaloneHypergrid config files, it does not need to be in the OpenSim.ini, it should NOT be an option unless you are actually running HG and not everyone does .. And when you set it up using the correct include files it gets set correctly .

(0035635)
BillBlight (developer)
2019-09-01 10:05

Using the correct config files, includes this setting, no change required.

- Issue History
Date Modified Username Field Change
2019-08-31 21:13 djphil New Issue
2019-08-31 21:13 djphil File Added: worldmap_colors_error_01.png
2019-08-31 21:44 BillBlight File Added: djphilmap.jpg
2019-08-31 21:44 BillBlight Note Added: 0035628
2019-08-31 22:25 djphil Note Added: 0035629
2019-08-31 22:25 djphil Status new => resolved
2019-08-31 22:25 djphil Fixed in Version => 0.9.0.1
2019-08-31 22:25 djphil Resolution open => no change required
2019-08-31 22:25 djphil Assigned To => djphil
2019-08-31 22:25 djphil Status resolved => closed
2019-09-01 01:45 aiaustin Assigned To djphil =>
2019-09-01 01:45 aiaustin Note Added: 0035630
2019-09-01 01:45 aiaustin Status closed => feedback
2019-09-01 01:45 aiaustin Resolution no change required => reopened
2019-09-01 06:14 aiaustin Note Added: 0035632
2019-09-01 07:43 aiaustin Note Edited: 0035632 View Revisions
2019-09-01 09:57 BillBlight Note Added: 0035634
2019-09-01 10:04 BillBlight Note Edited: 0035634 View Revisions
2019-09-01 10:05 BillBlight Note Added: 0035635
2019-09-01 10:05 BillBlight Status feedback => resolved
2019-09-01 10:05 BillBlight Resolution reopened => no change required
2019-09-01 10:05 BillBlight Assigned To => BillBlight


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker