Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008578opensim[REGION] Physics Enginespublic2019-08-17 11:462019-08-18 03:29
ReporterKohakuGrid24 
Assigned Toaiaustin 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformopensimulatorOSOS Version0.8.2.0
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0008578: windows 10 update
DescriptionMy windows 10 got forced last night to an update.
This is what happened after I woke up and put on my server. Server was closed and fine when I went to bed.
I am not a pro and I am sure I can't fix this but this seems related to the windows 10 update that came out recently.
I did try to switch the physics engins and I have the same errors similar to each other.
Server totally refuses all communication and I can't login.
Noting after server has 40 minutes of spaming, it does not crash.
(sorry for bad english)
(I hope I set up the Mantis report properly, if not admin please fix it?)
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
Environment.NET / Windows64
Mono VersionNone
ViewerFirestormOS-Releasex64
Attached Files? file icon cf93ee6c034f818e945c16883127d210.mp4 [^] (2,856,438 bytes) 2019-08-17 11:46

- Relationships
related to 0008549resolvedaiaustin [LAND MANAGEMENT MODULE] does not work anymore after Windows 1903 update 

-  Notes
(0035585)
UbitUmarov (administrator)
2019-08-17 11:51

Yes there is a problem with .net4.8 included on win10 1903
see discussion on mantis 8549
(0035586)
KohakuGrid24 (reporter)
2019-08-17 12:04
edited on: 2019-08-17 12:25

Sims don't work on fixing 8.2. No more tips what to do ubit?

(0035587)
UbitUmarov (administrator)
2019-08-17 12:08

try the workaround on 8549
ie
"
...
those with .net4.8 please try this:
in files OpenSim.exe.config, OpenSim32.exe.config and Robust.exe.config in section RunTime, add the line:

<useLegacyJit enabled="1" />

ie where it reads:

  <runtime>
    <loadFromRemoteSources enabled="true" />
  </runtime>

change to:

  <runtime>
    <loadFromRemoteSources enabled="true" />
    <useLegacyJit enabled="1" />
  </runtime>

this should disable the new (broken) JIT reverting to the one of .net4.5(?)
bad, but not as bad as running all in Debug mode.
"...
(0035588)
KohakuGrid24 (reporter)
2019-08-17 12:51
edited on: 2019-08-18 03:27

it is fixed thankyou

(0035589)
aiaustin (developer)
2019-08-18 03:29

Master dev code already includes changes to fix this issue without needing .config file changes.

- Issue History
Date Modified Username Field Change
2019-08-17 11:46 KohakuGrid24 New Issue
2019-08-17 11:46 KohakuGrid24 File Added: cf93ee6c034f818e945c16883127d210.mp4
2019-08-17 11:48 KohakuGrid24 Description Updated View Revisions
2019-08-17 11:49 UbitUmarov Relationship added related to 0008549
2019-08-17 11:51 UbitUmarov Note Added: 0035585
2019-08-17 11:51 KohakuGrid24 Description Updated View Revisions
2019-08-17 12:04 KohakuGrid24 Note Added: 0035586
2019-08-17 12:08 UbitUmarov Note Added: 0035587
2019-08-17 12:25 aiaustin Note Edited: 0035586 View Revisions
2019-08-17 12:29 aiaustin Description Updated View Revisions
2019-08-17 12:29 aiaustin Description Updated View Revisions
2019-08-17 12:51 KohakuGrid24 Note Added: 0035588
2019-08-17 13:14 KohakuGrid24 Note Edited: 0035588 View Revisions
2019-08-18 03:27 aiaustin Note Edited: 0035588 View Revisions
2019-08-18 03:29 aiaustin Note Added: 0035589
2019-08-18 03:29 aiaustin Status new => closed
2019-08-18 03:29 aiaustin Assigned To => aiaustin
2019-08-18 03:29 aiaustin Resolution open => fixed
2019-08-18 03:29 aiaustin Fixed in Version => master (dev code)


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker