Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008575opensim[REGION] OpenSim Corepublic2019-08-13 14:472019-08-15 13:07
Reporternixnerd 
Assigned Tonixnerd 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformlinuxOSUbuntu OS Version16.04.6 LTS
Product Version0.9.0.1 
Target VersionFixed in Version 
Summary0008575: Npc's green dots still appear on map, even when OpenSimDefaults.ini has ShowNPCs = false in [Map] section
DescriptionNpc's green dots still appear on map, even when OpenSimDefaults.ini has ShowNPCs = false in [Map] section
Steps To ReproduceUsing OpenSim commit 4812833 2019-08-10 22:18:55 +0100, rezz an NPC and still see dots on both map and mini map, even though OpenSimDefaults.ini has ShowNPCs = false in [Map] section
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineubODE
EnvironmentMono / Linux64
Mono Versiontrunk
ViewerFirestorm
Attached Files

- Relationships

-  Notes
(0035570)
nixnerd (reporter)
2019-08-13 14:54

mono -V
Mono JIT compiler version 6.0.0.319 (tarball Mon Aug 12 23:49:12 UTC 2019)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS: __thread
        SIGSEGV: altstack
        Notifications: epoll
        Architecture: amd64
        Disabled: none
        Misc: softdebug
        Interpreter: yes
        LLVM: yes(600)
        Suspend: hybrid
        GC: sgen (concurrent by default)
(0035571)
UbitUmarov (administrator)
2019-08-13 15:08

there was another spot that could send them, changed it ( no changes on minimap )
(0035572)
nixnerd (reporter)
2019-08-13 15:50

Cheers Ubit, I'll report back on what I find, after applying the fix :)
(0035573)
nixnerd (reporter)
2019-08-14 07:13

Marked as resolved - no NPC dots on the map now, thanks Ubit
(0035577)
nixnerd (reporter)
2019-08-15 06:08

Unfortunately, this doesn't seem to be resolved in retrospect.

NPC section of OpenSim.ini contains:

[NPC]
    ;# {Enabled} {} {Enable Non Player Character (NPC) facilities} {true false} false
    Enabled = true

    ;; several options to control NPCs creation

    ;# {AllowNotOwned} {} {allow NPCs to be created not Owned} {true false} true
    ;; allow NPCs to be created not Owned {true false} default: true
    AllowNotOwned = true

    ;# {AllowSenseAsAvatar} {} {allow NPCs to set to be sensed as Avatars} {true false} true
    ;; allow NPCs to set to be sensed as Avatars {true false} default: true
    AllowSenseAsAvatar = true

    ;# {AllowCloneOtherAvatars} {} {allow NPCs to created cloning any avatar in region} {true false} true
    ;; allow NPCs to created cloning any avatar in region {true false} default: true
    AllowCloneOtherAvatars = false

    ;# {NoNPCGroup} {} {if true NPCs will have no group title, if false display "- NPC -"} {true false} true
    ;; if true NPCs will have no group title, if false display "- NPC -" for easy identification {true false} default: true
    NoNPCGroup = false

OpenSimDefaults.ini contains:

[Map]

...<snipped for brevity>...

    ; Show NPCs as green world map dots
    ShowNPCs = false

Using the above configuration, NPC's still appear as green dots on the map.
(0035578)
UbitUmarov (administrator)
2019-08-15 08:28

Thats on same region you are in? or any other region?
On same region its possible viewers do bypass sim, since they know all the avatars there
that at least happens with minimap
(0035579)
UbitUmarov (administrator)
2019-08-15 10:11

well HG map module ignored that option
and there was still another spot.
(0035581)
nixnerd (reporter)
2019-08-15 12:37

Thanks Ubit, I'll apply the latest changes and report back, later.
(0035582)
nixnerd (reporter)
2019-08-15 13:06

Looks like this is fixed now, as of commit 9ddd2e842e4d34df3e298b4667f203ce06099244, thanks Ubit

- Issue History
Date Modified Username Field Change
2019-08-13 14:47 nixnerd New Issue
2019-08-13 14:54 nixnerd Note Added: 0035570
2019-08-13 15:08 UbitUmarov Note Added: 0035571
2019-08-13 15:50 nixnerd Note Added: 0035572
2019-08-14 07:13 nixnerd Note Added: 0035573
2019-08-14 07:14 nixnerd Mono Version Other => trunk
2019-08-14 07:14 nixnerd Status new => resolved
2019-08-14 07:14 nixnerd Resolution open => fixed
2019-08-14 07:14 nixnerd Assigned To => nixnerd
2019-08-15 06:08 nixnerd Note Added: 0035577
2019-08-15 06:08 nixnerd Status resolved => confirmed
2019-08-15 06:24 nixnerd Resolution fixed => open
2019-08-15 08:28 UbitUmarov Note Added: 0035578
2019-08-15 10:11 UbitUmarov Note Added: 0035579
2019-08-15 12:37 nixnerd Note Added: 0035581
2019-08-15 13:06 nixnerd Note Added: 0035582
2019-08-15 13:07 nixnerd Status confirmed => resolved
2019-08-15 13:07 nixnerd Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker