Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008573opensim[REGION] Scripting Enginepublic2019-08-10 05:292019-08-10 08:19
Reporterdjphil 
Assigned Todjphil 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Version0.9.0.1 
Target VersionFixed in Version 
Summary0008573: All linked objects with touch script are dragable
DescriptionI have very similar bug reported in mantis 0008569 with current master (2019-08-07 20:06).
All linked prims containing a script with touch are dragable.
It's panic on my regions.
Steps To Reproduce- create 2 prims and link them.
- put this basic touch script on root

default
{
    touch_start(integer n)
    {
        llSay(PUBLIC_CHANNEL, "Touch!");
    }
}

- clic link 2 (keep clicking) and drag.
Additional InformationI have tested on Sandbox Plaza (OSGrid) and the problem is same.
Tested with Xengine only and ubODE.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineubODE
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm
Attached Files

- Relationships
related to 0008569new Removing a script with llRemoveInventory after a touch start event lets you left click and drag the prim. 

-  Notes
(0035561)
djphil (reporter)
2019-08-10 08:18

Fixed in ffd5c5cc9c0d7c9bb4311caf1745a8b51e8a7d24
(0035562)
djphil (reporter)
2019-08-10 08:19

Tank's ;-)

- Issue History
Date Modified Username Field Change
2019-08-10 05:29 djphil New Issue
2019-08-10 05:29 djphil Relationship added related to 0008569
2019-08-10 08:18 djphil Note Added: 0035561
2019-08-10 08:18 djphil Status new => resolved
2019-08-10 08:18 djphil Resolution open => fixed
2019-08-10 08:18 djphil Assigned To => djphil
2019-08-10 08:19 djphil Note Added: 0035562
2019-08-10 08:19 djphil Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker