Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008528opensim[REGION] OpenSim Corepublic2019-05-14 07:532019-06-06 13:05
ReporterZauberParacelsus 
Assigned ToUbitUmarov 
PrioritynormalSeverityminorReproducibilityrandom
StatusassignedResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0008528: Random mesh pieces do not rez
DescriptionWithin the last 2-3 weeks, I've observed an issue where random mesh parts will fail to rez. The usual solution to such things is to right-click the linkset to force a refresh, but this does not work. The only workarounds are to either relog, unlink a single piece from the linkset, or shift-copy the linkset. However, if the missing mesh piece is the root prim of a linkset, then the entire linkset will fail to load.

As a wild estimate, I'd say it occurs in 1% of mesh objects on my sim at Tag, but with hundreds of mesh objects, there are always several pieces missing, or entire objects if the root goes missing.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineubODE
EnvironmentMono / Linux64
Mono Version5.x
ViewerFirestorm 6.0.2
Attached Files

- Relationships
related to 0008516assignedUbitUmarov Missing Objects and/or Terrain Parts on Teleport between Grids 

-  Notes
(0035205)
aiaustin (developer)
2019-05-14 09:10
edited on: 2019-05-14 09:12

What version of OpenSim are you using ZauberParacelsus? And if you are teleporting what version did you go to or come from when you observe this issue?

There have been issues with object, and sometimes terrain chunks, loss in recent dev master versions. But the very latest appears to resolve this problem or alleviate the issue.

Look at Mantis 8516 for more information. As usual please report back if this does not seem to be related to what you are seeing.

(0035206)
ZauberParacelsus (reporter)
2019-05-14 09:12

This is occuring on the Tag grid. I'll ask their dev what version they are on.
(0035289)
aiaustin (developer)
2019-06-05 11:23

It would be good to know what version of OpenSim is in use on TAG grid and that ZauberParacelsus was using when he saw the issue, as I believe that OpenSim dev master now has addressed the issue. See my updated comment on Mantis 8516.
(0035291)
ZauberParacelsus (reporter)
2019-06-05 11:30
edited on: 2019-06-05 11:30

Tag is running on OpenSim 0.9.1.0 Dev 0e2adbe0fb, updated to it earlier this morning as part of weekly grid maintenance.

I did a fly around on my sim, which has hundreds of mesh pieces rezzed all over (a banyan forest and one large "optiprim" structure). I did not see any missing pieces.

(0035314)
ZauberParacelsus (reporter)
2019-06-06 07:18

I requested that Ai Austin reopen this bug report, as while the issue has improved, it is not 100% resolved. I still see mesh pieces failing to rez, but far less frequently than before.
(0035315)
aiaustin (developer)
2019-06-06 07:26
edited on: 2019-06-06 07:30

Can you check something Zauber... I know you reported this as a case of the mesh not showing when you clicked on it or did various other things to make it show up. But to be sure that is what is happening now updates have occurred...

When you spot that a mesh is missing please click on where you think it is placed. Does it then appear, or does its outline bounding box show up? If so this may be the viewer issue that has been around a while, as you know.

But if you click the area and it does not show at all, and that persists until you relog then it may be a case of what is reported in Mantis 8516. If so, we are interested in some more detail. Which grid/region where you on when you saw the issue and if you can find the dev master version in use there that would be good to know. Also, if you were TPing from another grid/region or another region on the same grid, again please try to establish the dev master version in use there especially if it differs between the source and destination regions.

If for any reason the source or destination regions are using a dev master version that is more than (say) a month old (14th May 2019 or so) then it would be good if the regions involved could be updated and retested.

(0035316)
ZauberParacelsus (reporter)
2019-06-06 07:28

Right-clicking where it should be, or right-clicking another link in the same linkset, does not work.

Original post:
<pr>The usual solution to such things is to right-click the linkset to force a refresh, but this does not work
	
(0035317)
UbitUmarov (administrator)
2019-06-06 11:17

Please check several bandwidth setting on viewer, see if a reduction does improve the situation.
(0035318)
ZauberParacelsus (reporter)
2019-06-06 13:05

Some additional information:
1) I've looked briefely at report 0008516, and will note that the issue I am reporting appears upon login, rather than after a teleport
2) The issue appears to have worsened since yesterday, when it was negligible. The region had also been restarted yesterday.

@UbitUmarov: My bandwidth is set to 1500kbps

- Issue History
Date Modified Username Field Change
2019-05-14 07:53 ZauberParacelsus New Issue
2019-05-14 09:06 aiaustin Relationship added related to 0008516
2019-05-14 09:10 aiaustin Note Added: 0035205
2019-05-14 09:12 aiaustin Note Edited: 0035205 View Revisions
2019-05-14 09:12 ZauberParacelsus Note Added: 0035206
2019-06-05 10:04 Ferd Frederix Note Added: 0035285
2019-06-05 10:38 ZauberParacelsus Note Added: 0035286
2019-06-05 10:56 Constanza Amsterdam Note Added: 0035287
2019-06-05 11:05 Constanza Amsterdam Note Edited: 0035287 View Revisions
2019-06-05 11:23 aiaustin Note Added: 0035289
2019-06-05 11:24 aiaustin Note Added: 0035290
2019-06-05 11:25 aiaustin Note Edited: 0035290 View Revisions
2019-06-05 11:25 aiaustin Note Edited: 0035290 View Revisions
2019-06-05 11:30 ZauberParacelsus Note Added: 0035291
2019-06-05 11:30 ZauberParacelsus Note Edited: 0035291 View Revisions
2019-06-05 11:31 Constanza Amsterdam Note Added: 0035292
2019-06-05 11:32 Constanza Amsterdam Note Deleted: 0035292
2019-06-05 12:37 Ferd Frederix Note Added: 0035297
2019-06-05 12:38 Ferd Frederix Note Added: 0035298
2019-06-05 12:39 Ferd Frederix Note Edited: 0035297 View Revisions
2019-06-05 13:04 Constanza Amsterdam Note Added: 0035299
2019-06-05 13:31 tampa Note Added: 0035300
2019-06-05 13:48 Ferd Frederix Note Edited: 0035285 View Revisions
2019-06-05 13:49 Ferd Frederix Note Added: 0035303
2019-06-05 14:01 unregi Note Added: 0035306
2019-06-05 14:02 aiaustin Note Added: 0035307
2019-06-05 14:04 aiaustin Note Edited: 0035307 View Revisions
2019-06-05 14:04 aiaustin Note Deleted: 0035306
2019-06-05 14:04 Constanza Amsterdam Note Deleted: 0035287
2019-06-05 14:04 Constanza Amsterdam Note Deleted: 0035299
2019-06-05 14:05 aiaustin Note Deleted: 0035285
2019-06-05 14:05 aiaustin Note Deleted: 0035286
2019-06-05 14:05 aiaustin Note Deleted: 0035290
2019-06-05 14:06 aiaustin Note Deleted: 0035297
2019-06-05 14:06 aiaustin Note Deleted: 0035298
2019-06-05 14:06 aiaustin Note Deleted: 0035300
2019-06-05 14:06 aiaustin Note Deleted: 0035303
2019-06-05 14:06 aiaustin Note Deleted: 0035307
2019-06-05 14:08 aiaustin Note Added: 0035308
2019-06-05 14:09 aiaustin Note Added: 0035310
2019-06-05 14:09 aiaustin Status new => closed
2019-06-05 14:09 aiaustin Assigned To => aiaustin
2019-06-05 14:09 aiaustin Resolution open => fixed
2019-06-06 01:03 aiaustin Note Added: 0035312
2019-06-06 01:03 aiaustin Status closed => feedback
2019-06-06 01:03 aiaustin Resolution fixed => reopened
2019-06-06 01:03 aiaustin Note Deleted: 0035310
2019-06-06 01:03 aiaustin Note Deleted: 0035308
2019-06-06 02:07 aiaustin Assigned To aiaustin => UbitUmarov
2019-06-06 02:07 aiaustin Status feedback => assigned
2019-06-06 02:08 aiaustin Note Deleted: 0035312
2019-06-06 07:18 ZauberParacelsus Note Added: 0035314
2019-06-06 07:26 aiaustin Note Added: 0035315
2019-06-06 07:27 aiaustin Note Edited: 0035315 View Revisions
2019-06-06 07:28 ZauberParacelsus Note Added: 0035316
2019-06-06 07:30 aiaustin Note Edited: 0035315 View Revisions
2019-06-06 07:30 aiaustin Note Edited: 0035315 View Revisions
2019-06-06 11:17 UbitUmarov Note Added: 0035317
2019-06-06 13:05 ZauberParacelsus Note Added: 0035318


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker