Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008515opensim[REGION] OpenSim Corepublic2019-04-06 23:202019-06-23 01:43
ReporterMonamusa Kaliopov 
Assigned ToUbitUmarov 
PriorityhighSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOpenSim MasterOSLinux DebianOS Version9.8
Product Version0.9.0.1 
Target VersionFixed in Version0.9.1.0 
Summary0008515: Mesh disappears
DescriptionThe mesh, which is not in the avatar's perspective, will no longer be displayed when the avatar turns around, sometimes it will be displayed after a while and sometimes it will disappear.

I tried a build from March and February and everything is normal.
TagsNo tags attached.
Git Revision or version numberNewest Master
Run ModeStandalone (1 Region)
Physics EngineubODE
Script Engine
EnvironmentMono / Linux64
Mono Version5.x
ViewerFirestorm 64 Bit 6.0.2
Attached Files

- Relationships
related to 0008516assignedUbitUmarov Missing Objects and/or Terrain Parts on Teleport between Grids 

-  Notes
(0035041)
UbitUmarov (administrator)
2019-04-07 03:25

we don't control visibility by avatar rotation, viewers do
(0035042)
Monamusa Kaliopov (reporter)
2019-04-07 04:21

because it works on the other builds and also on the source code I have downloaded from OSGrid and the settings in the viewer nothing has changed .... so it seems logical to me something in the code causes this condition

the only thing that has changed is "the code" everything else is like before!!!
(0035043)
Monamusa Kaliopov (reporter)
2019-04-07 04:28

i do not know so much about git .. is there a way to get a master that we say ... that is from 2019-04-04 (2019-04-05)?
(0035044)
Monamusa Kaliopov (reporter)
2019-04-07 05:29
edited on: 2019-04-07 05:31

Newest Master

https://youtu.be/1I3wZ5x6HOQ [^]

Older Build (Source self compiled OSGrid 2019-23-03) works very well

https://youtu.be/bs6bhA4YakE [^]

nothing was changed on the system and not on the viewer. I did a clean install for the test and the results are the same as in the videos

(0035045)
UbitUmarov (administrator)
2019-04-07 05:40

As I said during those avatar movements and rotations regions do nothing about prims in view, that is all viewer side.
(0035046)
Monamusa Kaliopov (reporter)
2019-04-07 05:43

should that mean now that the Firestorm is from now on no longer compatible with the OpenSimulator?
(0035047)
Monamusa Kaliopov (reporter)
2019-04-07 05:45

try not to misunderstand me ..... but the firestorm is still the same, the video driver is the same the operating system on the client and server is the same ..... only the open simulator code has changed
(0035048)
UbitUmarov (administrator)
2019-04-07 06:00

several changed did happen on how prims are sent to viewers, making usage of some features they have for a long time.
that may had induced different LOD control on viewers side.

with the defaults till yesterday those changes are not active.

Avatar rotation in place or short distance movement does noting region side, relative to prims updates
(0035049)
Monamusa Kaliopov (reporter)
2019-04-07 06:04

and what do you suggest, the condition is a NO GO for me, I will stay with the old builds and wait
(0035050)
UbitUmarov (administrator)
2019-04-07 06:14
edited on: 2019-04-07 06:14

that's up to you, thanks for the report

(0035051)
UbitUmarov (administrator)
2019-04-07 06:15

btw make sure you use viewers defaults on LOD settings
(0035052)
Monamusa Kaliopov (reporter)
2019-04-07 06:17

that's right Ubit ..... because I'm not a mono programmer I can not fix it for myself and must probably live with this circumstance first of all

Thanks
(0035053)
Monamusa Kaliopov (reporter)
2019-04-07 06:18

i use the defaults
(0035054)
Monamusa Kaliopov (reporter)
2019-04-07 06:20

since I had already described above that it is synonymous after a clean install so .... I had at least ... after the clean install the defaults
(0035055)
Monamusa Kaliopov (reporter)
2019-04-07 06:36

but I still thought as a noob about the LOD .....

The farther I go the more inaccurate the object is displayed.

The further I get to the object, the object is shown in more detail, but in the videos you can see that they disappear at the same distance and reappear after a few seconds
(0035056)
UbitUmarov (administrator)
2019-04-07 06:39

on viewers distance is from camera
(0035057)
Monamusa Kaliopov (reporter)
2019-04-07 06:43

but I have both ways chosen .. zoom once with the mouse once go ..... ok in one thing I give you right ... if I am very close to the object it does not disappear.

But that does not make the situation any better. I can only say that it was ok a few days ago
(0035058)
UbitUmarov (administrator)
2019-04-07 07:58

about LODs see for example:
http://beqsother.blogspot.com/2018/01/for-lods-sake-stop.html [^]
(0035059)
UbitUmarov (administrator)
2019-04-07 08:02
edited on: 2019-04-07 08:02

about firestorm tools to help checking them and physics see for example

http://beqsother.blogspot.com/2017/10/coming-to-firestorm-soon-couple-of-new.html [^]

(0035060)
Monamusa Kaliopov (reporter)
2019-04-07 19:55

@Ubit
Thanks for the links, but I thought about it again, the fact is it worked before.

At the moment I will take the old builts, the condition as it is after 6 April is unacceptable.

Thank you


"I'll do a git pull at bigger intervals and see if anything has changed with a test build."
(0035065)
aiaustin (developer)
2019-04-08 07:54
edited on: 2019-04-08 09:44

I am reopening this issue.. to act as a place to note observations as the recent code changes related to SupportViewerObjectsCache are tried out more. Ubit and myself have discussed this quite a bit and done some cross grid hypergrid testing with a range of viewer bandwidths rather than my usual (the default I think) 1500Kbps I use on Firestorm (on a 100Mbps link at home and gigabit networking at work). With recent dev master code I was losing both objects and terrain chunks and not able to get them back without moving away and back or relogging. Sending a "force update" from the Server console also had no effect. This was both with SupportViewerObjectsCache set to false and true (true now being the default in master code). Ubit indicated the mechanism changed even if the parameter was set to false.

I turned the viewer bandwidth down to 750KBps and that did seem to improve things a lot... but I still do see some items go AWOL occasionally even at 750Kbps. I have yet to identify the specifics of such a situation as its not all the time now. I have also seen a couple of viewer crashes on teleport but again cannot be specific yet.

We do note packet loss in the stats tool (ctrl+shift+1) when the issues arise.. though Ubit indicates that we should be resilient to reasonable packet loss.

So, reopen to allow for notes as others put the latest dev master into use with SupportViewerObjectsCache = true and a range of viewers and bandwidth settings.

(0035066)
aiaustin (developer)
2019-04-08 07:56

The missing objects and terrain MAY be a separate issue, as they simply do not show up at all wherever you point your camera or click, but I wonder if we have a common root issue here?
(0035067)
BillBlight (developer)
2019-04-08 07:56

@aiaustin, this is not the issue you were testing on ..
(0035068)
BillBlight (developer)
2019-04-08 07:58
edited on: 2019-04-08 07:59

Cannot replicate the issue that is specified in this mantis, at least not past the point of mesh that have bad LOD's.


Same thing actually occurs in SL if the mesh has bad LODs

(0035070)
Monamusa Kaliopov (reporter)
2019-04-08 21:39
edited on: 2019-04-08 22:52

ok the Report is reopen ...

In terms of my problem, the patch testing has nothing at all .... in that case, all patches (until the time this LOD issue is fixed again) are unusable. (in my case)

I always thought the user is in the foreground and for what he sees on the screen.

And I want to make it clear again "A few days ago the world was still fine"

(0035071)
aiaustin (developer)
2019-04-09 03:32

I agree with Bill that my observations might (or might not!) be a separate issue.. so I have moved my notes to a new mantis...
http://opensimulator.org/mantis/view.php?id=8516 [^]
(0035429)
Monamusa Kaliopov (reporter)
2019-06-23 01:43

Newest Master resolve the Problem

- Issue History
Date Modified Username Field Change
2019-04-06 23:20 Monamusa Kaliopov New Issue
2019-04-07 03:25 UbitUmarov Note Added: 0035041
2019-04-07 04:22 Monamusa Kaliopov Note Added: 0035042
2019-04-07 04:28 Monamusa Kaliopov Note Added: 0035043
2019-04-07 05:29 Monamusa Kaliopov Note Added: 0035044
2019-04-07 05:31 Monamusa Kaliopov Note Edited: 0035044 View Revisions
2019-04-07 05:40 UbitUmarov Note Added: 0035045
2019-04-07 05:43 Monamusa Kaliopov Note Added: 0035046
2019-04-07 05:45 Monamusa Kaliopov Note Added: 0035047
2019-04-07 06:00 UbitUmarov Note Added: 0035048
2019-04-07 06:04 Monamusa Kaliopov Note Added: 0035049
2019-04-07 06:14 UbitUmarov Note Added: 0035050
2019-04-07 06:14 UbitUmarov Note Edited: 0035050 View Revisions
2019-04-07 06:15 UbitUmarov Note Added: 0035051
2019-04-07 06:17 Monamusa Kaliopov Note Added: 0035052
2019-04-07 06:18 Monamusa Kaliopov Note Added: 0035053
2019-04-07 06:20 Monamusa Kaliopov Note Added: 0035054
2019-04-07 06:36 Monamusa Kaliopov Note Added: 0035055
2019-04-07 06:39 UbitUmarov Note Added: 0035056
2019-04-07 06:43 Monamusa Kaliopov Note Added: 0035057
2019-04-07 07:58 UbitUmarov Note Added: 0035058
2019-04-07 08:02 UbitUmarov Note Added: 0035059
2019-04-07 08:02 UbitUmarov Note Edited: 0035059 View Revisions
2019-04-07 19:55 Monamusa Kaliopov Note Added: 0035060
2019-04-07 19:57 Monamusa Kaliopov Status new => resolved
2019-04-07 19:57 Monamusa Kaliopov Resolution open => won't fix
2019-04-07 19:57 Monamusa Kaliopov Assigned To => Monamusa Kaliopov
2019-04-08 07:54 aiaustin Assigned To Monamusa Kaliopov => UbitUmarov
2019-04-08 07:54 aiaustin Note Added: 0035065
2019-04-08 07:54 aiaustin Status resolved => feedback
2019-04-08 07:54 aiaustin Resolution won't fix => reopened
2019-04-08 07:56 aiaustin Note Added: 0035066
2019-04-08 07:56 BillBlight Note Added: 0035067
2019-04-08 07:58 BillBlight Note Added: 0035068
2019-04-08 07:58 BillBlight Note Edited: 0035068 View Revisions
2019-04-08 07:59 BillBlight Note Edited: 0035068 View Revisions
2019-04-08 08:03 aiaustin Note Edited: 0035065 View Revisions
2019-04-08 09:44 aiaustin Note Edited: 0035065 View Revisions
2019-04-08 21:39 Monamusa Kaliopov Note Added: 0035070
2019-04-08 21:39 Monamusa Kaliopov Status feedback => assigned
2019-04-08 22:52 Monamusa Kaliopov Note Edited: 0035070 View Revisions
2019-04-09 03:32 aiaustin Note Added: 0035071
2019-04-09 03:32 aiaustin Relationship added related to 0008513
2019-04-09 03:32 aiaustin Relationship deleted related to 0008513
2019-04-09 03:33 aiaustin Relationship added related to 0008516
2019-06-23 01:43 Monamusa Kaliopov Note Added: 0035429
2019-06-23 01:43 Monamusa Kaliopov Status assigned => resolved
2019-06-23 01:43 Monamusa Kaliopov Fixed in Version => 0.9.1.0
2019-06-23 01:43 Monamusa Kaliopov Resolution reopened => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker