Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008474opensim[REGION] OpenSim Corepublic2019-02-06 15:202019-03-07 04:16
ReporterJeffKelley 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.9.0.1 
Target VersionFixed in Version 
Summary0008474: Scripts cannot modify some sides of a prim
DescriptionIn release 0.9.0.1, all sides of a 8-side cut/hollowed prim cannot be modified by script.
Steps To ReproduceMake a cube, change type to prism, set path cut begin/end to 0.2/0.8, hollow to 65.

Drop the following script. Each side will change color when touched, except side 7.


default {
    touch_start (integer n) {
         integer side = llDetectedTouchFace (0);
         llOwnerSay ((string) side);
         llSetColor (<0,0,0>, ALL_SIDES);
         llSetColor (<1,0,0>, side);
    }
}
Additional InformationThis kind of prim is used to display 5 alphanumeric characters ('xyText') using llSetPrimitiveParams to set texture scale and offset along with a font texture. All objects using this technique are failing under O.9.1 Release (see pictures).
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono VersionOther
ViewerFirestorm 6.0.1
Attached Filespng file icon xytext_0.9.0.1.png [^] (305,517 bytes) 2019-02-06 15:20
png file icon xytext_0.9.0.png [^] (337,392 bytes) 2019-02-06 15:20

- Relationships
related to 0008497new Cutting a prim into multiface 

-  Notes
(0034620)
tampa (reporter)
2019-02-06 15:34

Unable to reproduce in master. I believe there were some material changes that also saw a commit about some mismatched face numbers.
(0034621)
JeffKelley (reporter)
2019-02-06 15:40

Unfortunately, i cannot compile 52947b6

(GCLargeObjectHeapCompactionMode' does not exist in the current context
System.Runtime.GCSettings' does not contain a definition for `LargeObjectHeapCompactionMode')
(0034622)
tampa (reporter)
2019-02-06 15:42

Are you following the correct build procedure and have all the required dependencies installed? Compilation errors should not occur with OpenSim unless the build environment is not proper.
(0034649)
JeffKelley (reporter)
2019-02-06 17:28

The issue is fixed in master 52947b6 (2019-02-05), so it should be in the next release.
(0034650)
JeffKelley (reporter)
2019-02-06 17:29

Closing.

- Issue History
Date Modified Username Field Change
2019-02-06 15:20 JeffKelley New Issue
2019-02-06 15:20 JeffKelley File Added: xytext_0.9.0.1.png
2019-02-06 15:20 JeffKelley File Added: xytext_0.9.0.png
2019-02-06 15:34 tampa Note Added: 0034620
2019-02-06 15:40 JeffKelley Note Added: 0034621
2019-02-06 15:42 tampa Note Added: 0034622
2019-02-06 17:28 JeffKelley Note Added: 0034649
2019-02-06 17:29 BillBlight Status new => resolved
2019-02-06 17:29 BillBlight Resolution open => fixed
2019-02-06 17:29 BillBlight Assigned To => BillBlight
2019-02-06 17:29 JeffKelley Note Added: 0034650
2019-02-06 17:33 BillBlight Status resolved => closed
2019-02-06 17:33 BillBlight Assigned To BillBlight =>
2019-03-07 04:16 JeffKelley Relationship added related to 0008497


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker