Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008458opensim[REGION] OpenSim Corepublic2019-01-18 19:492019-02-05 12:27
Reportermewtwo0641 
Assigned Tomewtwo0641 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0008458: Unlinking prims not working properly
DescriptionAs of commit 950b605b429e95ffef8a184ff0218a9d36ab608a, unlinking of prims is not working properly.

It is impossible to unlink selected child prims and when attempting to unlink a whole object it only unlinks one prim at a time and have to spam CTRL + SHIFT + L until every thing is eventually unlinked.

This was tested on Singularity but I also see it on Firestorm; I have also noticed that Firestorm will refuse to enable the "Edit" option when right clicking the afflicted object(s).

Reverting this commit as part of my tests makes unlink work properly again.
Steps To Reproduce1. Create a few prims (I used 4 prims for my test)

2. Link them all together

3. Try to unlink them all at once
    a. Only one prim will be unlinked at a time
    b. Multiple calls to unlink have to be made to eventually unlink every thing

4. Try to select a child prim and unlink it
    a. Child prim will not be able to be unlinked
    b. Root prim can be unlinked in a selection
Additional InformationGit Bisect Results:

$ git bisect good
950b605b429e95ffef8a184ff0218a9d36ab608a is the first bad commit
commit 950b605b429e95ffef8a184ff0218a9d36ab608a
Author: UbitUmarov <ajlduarte@sapo.pt>
Date: Sun Jan 6 20:10:43 2019 +0000

    more changes on scenegraph etc

:040000 040000 3b055304f8f0362ff532c81a62f2d2d0bc003778 9516e7ff55139164a0af33044124d63cc08153d3 M OpenSim
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineubODE
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0033842)
UbitUmarov (administrator)
2019-01-18 23:11

yeap my bad one changing fast prims and groups find code
hope better now
(0033843)
mewtwo0641 (reporter)
2019-01-19 04:28

No worries, seems to be working good now. Thanks!
(0034315)
BillBlight (developer)
2019-02-05 12:27

Old Issues, closed, can be reopened if they still exist

- Issue History
Date Modified Username Field Change
2019-01-18 19:49 mewtwo0641 New Issue
2019-01-18 19:59 mewtwo0641 Description Updated View Revisions
2019-01-18 22:57 mewtwo0641 Description Updated View Revisions
2019-01-18 22:57 mewtwo0641 Additional Information Updated View Revisions
2019-01-18 23:11 UbitUmarov Note Added: 0033842
2019-01-19 04:28 mewtwo0641 Note Added: 0033843
2019-01-19 04:28 mewtwo0641 Status new => resolved
2019-01-19 04:28 mewtwo0641 Fixed in Version => master (dev code)
2019-01-19 04:28 mewtwo0641 Resolution open => fixed
2019-01-19 04:28 mewtwo0641 Assigned To => mewtwo0641
2019-02-05 12:27 BillBlight Note Added: 0034315
2019-02-05 12:27 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker