Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008435opensim[REGION] OpenSim Corepublic2018-12-30 06:482019-01-05 12:38
Reportercontributor 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0008435: Navigation lag 10 seconds, Cross region lag 30 seconds
DescriptionI installed the latest master version. The textures indeed load faster, but navigation has more lag and at times it is unable to move at all. And cross-region takes ages to be accomplished. What would be the best parameters to improve navigation and cross-region, even at the expense of slower textures?
Steps To ReproduceView distance 1024m. The regions are cities of 25,000 prims with many textures.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0033690)
danbanner (manager)
2018-12-30 06:58

Are the regions running in separate instances or all in the same simulator?
(0033691)
paela argus (reporter)
2018-12-30 07:03

Use view at 256 max 512 never 1024
(0033692)
danbanner (manager)
2018-12-30 07:04

You might try turning your view distance down too. 1024m view distance with 50k prims and "many textures" is bound to lag most viewers.
(0033693)
UbitUmarov (administrator)
2018-12-30 07:29

sorry, no miracles :(
look also to your viewer FPS, it may also be low

reduce view distance as already said
you may also reduce viewer bandwith a bit.
default textures and meshes bandwidth is a multiple of that.

you can override (meshes + textures) max bandwidth with setting
Cap_AssetThrottle (in bytes/s) in section ClientStack.LindenCaps
(0033697)
contributor (reporter)
2018-12-31 02:18

What would be the best parameters when it is local (my home) network only, and there is only one client (myself)?

I notice that the opensim server installed on a dedicated machine (intel i5 32GB DDR4 ram) running opensim and robust and mysql on 100Mbit network, all of them use only 5% of resources of that server machine, whatever parameters I put.
(0033698)
Luisillo_Contepomi (reporter)
2018-12-31 06:02

Please how much is the default value in Cap_AssetThrottle (in bytes/s) in section ClientStack.LindenCaps?
(0033699)
UbitUmarov (administrator)
2018-12-31 06:25

default is approx. 2x the viewer bandwidth setting with a min of 50000bytes/s
(0033709)
contributor (reporter)
2019-01-03 03:07

I understand that setting a throttle cap in a multi-user environment is desirable in order to prevent a single client from consuming all available bandwidth. However, my question was regarding one client only connected to a local server. In that case it would be significant benefit to remove any cap and use all available bandwidth and not just 5% as it is used now. This would drastically increase loading speed and prevent movement lag. I think this would be of benefit to developers who connect to local test grids.
(0033710)
danbanner (manager)
2019-01-03 03:44

from my experience removing the cap or increasing it will only flood the viewer more and cause freezes, etc. reducing your draw distance to a sane value and optimizing your builds will have more benefit. Most likely the issues are not opensim but the viewer getting lagged from trying to render 50k prims and textures so quickly.
(0033719)
contributor (reporter)
2019-01-05 01:14

I lived one year with the version 0.9. Sim crossing worked effortlessly without remarkable lag. Then I installed the last development edition, which quite improved the texture loading up to 2 times. But I miss the experience of sim crossing of the previous version and I wonder whether any change towards
faster texture response affected the particular sim crossing feature. The avatar movements are ok inside one single 256x256 region. It is only when sim crossing is attempted, that may pass from 30 seconds up to 5 minutes to regain avatar control.
The delay at sim crossing is regardless of viewer version.

One more remark of the new development version: At power up, it takes three times the duration to power up regions as before.
(0033723)
UbitUmarov (administrator)
2019-01-05 12:38
edited on: 2019-01-06 01:13

on 0.9.1 warp3d map module does a bit more things and so takes a lot more time ( and has a higher peak cpu and memory usage)


- Issue History
Date Modified Username Field Change
2018-12-30 06:48 contributor New Issue
2018-12-30 06:58 danbanner Note Added: 0033690
2018-12-30 07:03 paela argus Note Added: 0033691
2018-12-30 07:04 danbanner Note Added: 0033692
2018-12-30 07:29 UbitUmarov Note Added: 0033693
2018-12-31 02:18 contributor Note Added: 0033697
2018-12-31 06:02 Luisillo_Contepomi Note Added: 0033698
2018-12-31 06:25 UbitUmarov Note Added: 0033699
2019-01-03 03:07 contributor Note Added: 0033709
2019-01-03 03:44 danbanner Note Added: 0033710
2019-01-05 01:14 contributor Note Added: 0033719
2019-01-05 12:38 UbitUmarov Note Added: 0033723
2019-01-06 01:13 aiaustin Note Edited: 0033723 View Revisions


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker