Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008416opensim[REGION] Scripting Enginepublic2018-12-07 16:532018-12-08 22:42
Reporterunregi 
Assigned Tounregi 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Platformmono 5.16.0.179OSDebian GNU/LinuxOS Version9
Product Version0.9.0.1 
Target VersionFixed in Version 
Summary0008416: String Comparision of Unicode Character TRUE that should be FALSE
DescriptionFollowing script says "True" on Nearby Chat (it doesn't in SecondLife):

default
{
    state_entry()
    {
        if ("?" == "?")
        {
            llSay(0, "True");
        }
    }
}

Edit: can't write special characters here, one is http://graphemica.com/%E2%81%95 [^] and the other one is http://graphemica.com/%E2%9D%8E [^]
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono Version5.x
ViewerFirestorm 5.1.7
Attached Files

- Relationships

-  Notes
(0033569)
UbitUmarov (administrator)
2018-12-07 17:14

what the script engine?
testing with Yengine on windows works correctly, on mono does not
fun fun...
(0033570)
unregi (reporter)
2018-12-07 17:22

Both, had the Bug before in XEngine and now still in YEngine.
(0033571)
UbitUmarov (administrator)
2018-12-07 17:25

just tested at lbsa Xengine, and worked fine
(0033572)
unregi (reporter)
2018-12-07 17:32

ok, i have to admit that the script where i discovered this issue previously also didn't work because of other reasons... so it could be that when we had XEngine, it didn't had that Bug and failed because something else.

I will test on XEngine regions too now.
(0033573)
unregi (reporter)
2018-12-07 17:39

Tested it on different XEngine regions, no issue there.
Bug just appears in YEngine
(0033574)
UbitUmarov (administrator)
2018-12-07 18:39

changed on master the Yengine generated code for string compare
lets see if works or smokes
(0033575)
unregi (reporter)
2018-12-07 20:00

Compiled it from master and tested it, it's working now.
Thank you very much, Ubit! Nice work.
(0033577)
Sheera Khan (reporter)
2018-12-07 23:04

Issue reported and resolved in two hours. Well done! And some other people complain and can't be bothered to write a meaningful mantis entry ...

- Issue History
Date Modified Username Field Change
2018-12-07 16:53 unregi New Issue
2018-12-07 16:57 unregi Description Updated View Revisions
2018-12-07 17:14 UbitUmarov Note Added: 0033569
2018-12-07 17:22 unregi Note Added: 0033570
2018-12-07 17:25 UbitUmarov Note Added: 0033571
2018-12-07 17:32 unregi Note Added: 0033572
2018-12-07 17:39 unregi Note Added: 0033573
2018-12-07 18:39 UbitUmarov Note Added: 0033574
2018-12-07 20:00 unregi Note Added: 0033575
2018-12-07 23:04 Sheera Khan Note Added: 0033577
2018-12-07 23:19 unregi Status new => resolved
2018-12-07 23:19 unregi Resolution open => fixed
2018-12-07 23:19 unregi Assigned To => unregi


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker