Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008399opensim[REGION] Script Functionspublic2018-10-22 02:232018-10-22 02:55
ReporterTony12345 
Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformWindowsOS7OS VersionPro
Product Version0.9.0.1 
Target VersionFixed in Version 
Summary0008399: Function not working after sim restart.
Descriptionlist parameters = [HTTP_METHOD, "GET"];
When OpenSim.exe is started this works perfect however it stops working if a region was restarted.

To make work again have to actually close OpenSim.exe then start again
Steps To Reproduce( script in world )


key requestKey;
string URL;
default
{
state_entry()
{
string body = "";
URL = "http://www.YOUR_URL/test.php"; [^]
list parameters = [HTTP_METHOD, "GET"];
requestKey = llHTTPRequest(URL, parameters, body);
}

http_response( key request_id, integer status, list metadata, string body ){
if(request_id == requestKey){
llReleaseURL(URL);
llOwnerSay((string)body);
}
}
}

( php script on server )
<?php
echo "Worked this time!";
?>
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineBulletSim
EnvironmentMono / Windows
Mono Version4.0
ViewerFirestorm
Attached Files

- Relationships

-  Notes
(0033239)
Tony12345 (reporter)
2018-10-22 02:55

Ok, Seems as though if 1 region is restarted inworld, sometimes [HTTP_METHOD, "GET"] will work again and sometimes not but if admin_restart with web UI was used and all the regions restarted at once then [HTTP_METHOD, "GET"] just don't work again until OpenSim.exe manually restarted.

- Issue History
Date Modified Username Field Change
2018-10-22 02:23 Tony12345 New Issue
2018-10-22 02:30 Tony12345 Steps to Reproduce Updated View Revisions
2018-10-22 02:55 Tony12345 Note Added: 0033239


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker