Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008376opensim[REGION] OpenSim Corepublic2018-09-19 01:542018-09-19 14:04
ReporterLotek 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0008376: Agent doesn't become root agent on teleport, but does on login to sim
DescriptionWhen an agent teleports to a region, then they always become child agent in the new region; seen when 'show circuits' is used on the console.

When a agent logs in to a region they do become root agent as should.

The strange thing is 'show users' does show the teleporter as root agent but 'show circuits' doesn't.

------

Region (lotekmaster) # show users

Agents connected: 1

Firstname Lastname Agent ID Root/Child Region Position
Lotek Ixtar fa7b1481-0f28-4b1f-9ee7-e2979346b9a3 Root lotekmaster <85.3127, 135.6034, 26.36598>

Region (lotekmaster) # show circuits
Region Avatar name Type Code IP Viewer Name
lotekmaster Lotek Ixtar child 1736923120 <my ip address> Firestorm-Releasex64 5.1.7.55786


------

When an agent crosses to a neighbouring region (different simulator, same server) they again become child agent in the new region (wrong) and child in the old region (right):


Agents connected: 1

Firstname Lastname Agent ID Root/Child Region Position
Lotek Ixtar fa7b1481-0f28-4b1f-9ee7-e2979346b9a3 Root lotekmaster2 <230.4235, 125.1266, 26.36598>

Region (lotekmaster2) # show circuits
Region Avatar name Type Code IP Viewer Name
lotekmaster2 Lotek Ixtar child 1736923120 <my ip address> Firestorm-Releasex64 5.1.7.55786


It could be 'show circuits' just gives wrong info (avatar showing as child agent in the region they reside in) or there is a more serious problem.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Script Engine
EnvironmentMono / Linux64
Mono Version5.x
Viewer
Attached Files

- Relationships

-  Notes
(0033024)
BillBlight (developer)
2018-09-19 14:04
edited on: 2018-09-19 14:05

Tested this a couple of ways, and show circuits always shows as child, but
show users and show connections does not

Region (DragonShire) # show connections
Region Avatar name Circuit code Endpoint Active? ChildAgent? ping(ms)
DragonShire Bill Blight 934949758 <my ip>:55342 True False 159


Region (DragonShire) # show users

Agents connected: 1

Firstname Lastname Agent ID Root/Child Region Position
Bill Blight f507a280-c270-11e6-b5ef-00269e0b06c2 Root DragonShire <188.6945, 245.6535, 21.25036>

Region (DragonShire) # show circuits
Region Avatar name Type Code IP Viewer Name
DragonShire Bill Blight child 934949758 <my ip> Firestorm-OSL 5.1.9.56005

So I'd guess something is not getting updated ..

just to confirm what Lotek is seeing ..


- Issue History
Date Modified Username Field Change
2018-09-19 01:54 Lotek New Issue
2018-09-19 14:04 BillBlight Note Added: 0033024
2018-09-19 14:05 BillBlight Note Edited: 0033024 View Revisions


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker