Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008344opensim[REGION] OpenSim Corepublic2018-07-19 21:332019-10-25 16:05
ReporterMandarinka Tasty 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusacknowledgedResolutionwon't fix 
PlatformOSOS Version
Product Version0.9.0.1 
Target VersionFixed in Version 
Summary0008344: Possibility to complete disabling parcel bans - free proposition.
DescriptionThe patch has been included.

I've thought of making some better usage of hidden config boolean: DisableParcelBans and I've decided to share my idea of solution.

A scenario of situations that one might use with DisableParcelBans = true can be found in educational social virtual environments or in some RP game simulators.

Sometimes it is just better to find compromise, than to use ban hammer )
Certainly estate bans work with my patch, since they are higher level of region's management ( example: for teachers etc).
If one finds it interesting, take the patch and apply into your source code or read how I've written it and repeat in your code.
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics, ODE, BulletSim, ubODE
Script Engine
EnvironmentMono / Linux32, Mono / Linux64, Mono / Windows, Mono / OSX, .NET / Windows32, .NET / Windows64
Mono Version5.x
ViewerFirestorm 5.0.11
Attached Files

- Relationships

-  Notes
(0035782)
Mandarinka Tasty (reporter)
2019-10-25 14:47

The patch has been removed by the author.

- Issue History
Date Modified Username Field Change
2018-07-19 21:33 Mandarinka Tasty New Issue
2018-07-19 21:33 Mandarinka Tasty File Added: 0001-The-complete-disabling-parcel-bans.patch
2018-07-19 21:34 Mandarinka Tasty Status new => patch included
2019-10-25 14:47 Mandarinka Tasty File Deleted: 0001-The-complete-disabling-parcel-bans.patch
2019-10-25 14:47 Mandarinka Tasty Note Added: 0035782
2019-10-25 14:47 Mandarinka Tasty Status patch included => resolved
2019-10-25 14:47 Mandarinka Tasty Resolution open => won't fix
2019-10-25 14:47 Mandarinka Tasty Assigned To => Mandarinka Tasty
2019-10-25 16:05 BillBlight Assigned To Mandarinka Tasty =>
2019-10-25 16:05 BillBlight Status resolved => acknowledged


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker