Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008319opensim[REGION] OpenSim Corepublic2018-04-17 10:392018-04-17 10:39
Reportertamagotchii2003 
Assigned To 
PriorityhighSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformanyOSDibianOS Version8 jessie
Product Version0.9.0 
Target VersionFixed in Version 
Summary0008319: Error getting response stream (ReadDone2): ReceiveFailure
Descriptionerror on 2nd login attempt. 1st login always works. on 2nd attempt im
getting this error

request failed: Error getting response stream (ReadDone2): ReceiveFailure
R.O.B.U.S.T.# Service request failed: Error getting response stream (ReadDone2)
Steps To Reproduce1.Have robust set at robustHG.ini on separate machine ip ex 111.111.11.111
2.Have region simulators on separate machine using Include-Architecture = "config-include/GridHypergrid.ini" on ip ex 222.222.222.222
3. have 9 simulators running 256X in a 3x3 pattern with middle region being 5000,5000
4. start robust on ex. 111.111.111.111
5. start opensim on ex. 222.222.222.222
6. opensim @ 222.222.222.222 registers all 9 regions with robust @ 111.111.111.111 setup estate for all 9 as same name and confirms up and logins ready
7.using firestorm x64 login to the robust at ip ex 111.111.111.111:8002
8. everything logs in and no issues at this currernt step
9. logout and logback in immediatly and get ERROR
Robust error = JSON-RPC request 26 QUERYACCESS to http://222.222.222.222:9000/agent/f2d2bbf1-ccdf-41df-a4a3-6986468e239a/f384ee50-9039-408c-a7ad-8d442b3e950a/ [^] [^] FAILED: Error getting response stream (ReadDone2): ReceiveFailure

10. shutdown opensim on 222.222.222.222 and restart opensim and you can login again (takes you back to step 7) but after you logout and attempt to log back in you will get error msg agian.

11. running 6 regions or less via 1 region.ini file eliminates this error.
12. OR running 7 regions via 7 renion.ini files also eliminates this reattempt to login error
ALSO have noticed if you wait 5 minutes after you revieve the error and reattempt to log back in it will login without error.

ALSO Standing at any of the 4 corners at the outside of the 3x3 regions staring off into the abyss also totally eliminates this error

Updating to mono version 5.10 lowered the occurrence rate of the error but the error is still happening on every other attempt to login
Additional Informationmono version 5.10
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono VersionOther
Viewer
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2018-04-17 10:39 tamagotchii2003 New Issue


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker