Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008218opensim[REGION] Physics Enginespublic2017-07-27 05:092017-07-30 14:09
Reporteraiaustin 
Assigned ToUbitUmarov 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Versionmaster (dev code) 
Summary0008218: [BULLETSIM SHAPE]: Fetched asset would not mesh - many instances after update
DescriptionOn updating to opensim-0.9.0-1624-g6996bab.zip (2017-07-26 19:13)on a 0.9.0 dev master ROBUST grid with multiple regions (AiLand grid) on Windows, I am seeing many new messages of the form

[BULLETSIM SHAPE]: Fetched asset would not mesh...

I am seeing about 3,000 these messages. Essentially for every mesh on some regions.

Reverting to my last working setup opensim-0.9.0-1597-gf921ad0.zip (2017-07-16 23:58) these console messages go away.
Additional InformationTrying to trace a possible commit that may have introduced this issue... as I am using the default physics engine BULLETSIM I can only see opensim-0.9.0-1601-gc1ab128.zip (2017-07-18 13:09). I installed this and it does indeed seem to be the cause of these many console messages.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Files

- Relationships

-  Notes
(0032177)
Uraquitan Matova (reporter)
2017-07-27 06:04

Did you edit your OpenSimDefault.ini ? has new parameters about it
(0032178)
aiaustin (developer)
2017-07-27 06:20
edited on: 2017-07-27 06:22

@Uraquitan, I only edit OpenSim.ini as usual... though we can copy over rarer parameters from OpenSimDefaults.ini if that is necessary. However, I could only see additions for ubODE and I am using the default BulletSim.

Did you have a specific setting in mind that has changes for BulletSim?

(0032179)
Uraquitan Matova (reporter)
2017-07-27 06:26

I did a test with default current OpenSimDefaults.ini on the compilation folder. To me works same to bullet. Try to make a test with official current OpenSimDefault.ini to a new instance to test.
(0032180)
aiaustin (developer)
2017-07-27 06:39
edited on: 2017-07-27 06:46

I checked across at the current OSGrid version of OpenSim.ini where I have copies of the same kind of mesh rich regions that don't currently show the messages... and indeed if I add the following to openSimlini the issue/messages go away...

[Mesh]
    ; enable / disable Collada mesh support
    ; default is true
    AllowMeshUpload = true

    ; if you use Meshmerizer and want collisions for meshies, setting this to true
    ; will cause OpenSim to attempt to decode meshies assets, extract the physics
    ; mesh, and use it for collisions. This is currently experimental code and enabling
    ; it may cause unexpected physics problems.
    UseMeshiesPhysicsMesh = true


The current OpenSim.ini.example does not though have the [Mesh] section in it and OpenSimDefaults.ini indicates this

[Mesh]
    ; enable / disable mesh asset uploads
    ; mesh asset must conform to standard mesh format, with OpenSim extensions
    ; default is true
    AllowMeshUpload = true

    ; Minimum user level required to upload meshes
    ;LevelUpload = 0

    ; support meshs on physics
    ; UseMeshiesPhysicsMesh = true

So as the UseMeshiesPhysicsMesh line is commented here, it must be that the code default for UseMeshiesPhysicsMesh is actually FALSE not true?

Typo noted on meshs too (should be meshes). @Ubit informed.

(0032181)
Uraquitan Matova (reporter)
2017-07-27 06:48

OpenSimDefaults.ini

[startup]

physical_prim = true
meshing = Meshmerizer
physics = BulletSim

?
my [Mesh] parameters same as you and works fine. no mesh issue message
(0032182)
aiaustin (developer)
2017-07-27 08:29
edited on: 2017-07-27 10:19

Those are the defaults and commented out in OpenSim.ini.example, as they are in my OpenSim.ini files. So it looks like the problem is that with nothing explicitly changed in OpenSim.ini [Startup] and [Mesh] sections the 0.9.0 dev master now throws the new messages with some mesh objects. It is a change after opensim-0.9.0-1597-gf921ad0.zip (2017-07-16 23:58) and probably at opensim-0.9.0-1601-gc1ab128.zip (2017-07-18 13:09).

(0032183)
UbitUmarov (administrator)
2017-07-27 09:22

Yes problem was that UseMeshiesPhysicsMesh had the default of false from the early testing days, on the Meshmerizer used on Bullet, and I missed that
fixed
(0032185)
aiaustin (developer)
2017-07-27 10:22

Great, thanks @Ubit. Would it be worth adding the extra lines into OpenSim.ini.example for this? Or is it okay to just leave this as a "rare change" in OpenSimDefaults.ini only?

I note that OSGrid's provided OpenSim.ini includes the following two parameters explicitly uncommented...

[Mesh]
     AllowMeshUpload = true
     UseMeshiesPhysicsMesh = true
(0032186)
UbitUmarov (administrator)
2017-07-27 11:03

Having the option uncomment is just a performance issue
Only when the default does match code default we can comment it out to reduce the size of the options parsing structures.
(0032221)
aiaustin (developer)
2017-07-30 14:09

Changes made to dev master by @Ubitmarov fixed this.

- Issue History
Date Modified Username Field Change
2017-07-27 05:09 aiaustin New Issue
2017-07-27 06:04 Uraquitan Matova Note Added: 0032177
2017-07-27 06:20 aiaustin Note Added: 0032178
2017-07-27 06:22 aiaustin Note Edited: 0032178 View Revisions
2017-07-27 06:22 aiaustin Note Edited: 0032178 View Revisions
2017-07-27 06:26 Uraquitan Matova Note Added: 0032179
2017-07-27 06:39 aiaustin Note Added: 0032180
2017-07-27 06:44 aiaustin Note Edited: 0032180 View Revisions
2017-07-27 06:45 aiaustin Note Edited: 0032180 View Revisions
2017-07-27 06:46 aiaustin Note Edited: 0032180 View Revisions
2017-07-27 06:48 Uraquitan Matova Note Added: 0032181
2017-07-27 08:29 aiaustin Note Added: 0032182
2017-07-27 09:22 UbitUmarov Note Added: 0032183
2017-07-27 10:19 aiaustin Note Edited: 0032182 View Revisions
2017-07-27 10:22 aiaustin Note Added: 0032185
2017-07-27 11:03 UbitUmarov Note Added: 0032186
2017-07-30 14:06 aiaustin Assigned To => UbitUmarov
2017-07-30 14:06 aiaustin Status new => assigned
2017-07-30 14:07 aiaustin Note Added: 0032218
2017-07-30 14:07 aiaustin Status assigned => resolved
2017-07-30 14:07 aiaustin Resolution open => fixed
2017-07-30 14:07 aiaustin Note Added: 0032219
2017-07-30 14:07 aiaustin Status resolved => closed
2017-07-30 14:07 aiaustin Note Added: 0032220
2017-07-30 14:07 aiaustin Status closed => feedback
2017-07-30 14:07 aiaustin Resolution fixed => reopened
2017-07-30 14:08 aiaustin Note Edited: 0032219 View Revisions
2017-07-30 14:08 aiaustin Note Deleted: 0032219
2017-07-30 14:08 aiaustin Note Deleted: 0032220
2017-07-30 14:08 aiaustin Note Deleted: 0032218
2017-07-30 14:09 aiaustin Note Added: 0032221
2017-07-30 14:09 aiaustin Status feedback => assigned
2017-07-30 14:09 aiaustin Status assigned => resolved
2017-07-30 14:09 aiaustin Fixed in Version => master (dev code)
2017-07-30 14:09 aiaustin Resolution reopened => fixed
2017-07-30 14:09 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker