Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008216opensim[REGION] Script Functionspublic2017-07-25 15:532017-07-26 08:59
Reporternixnerd 
Assigned Tonixnerd 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformlinuxOSf921ad0-0.9.0-1597-gf921ad0 OS Version0.9.x
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0008216: use any pmac enabled stuff and script debug outputs errors
Descriptionuse any pmac enabled stuff and script debug outputs errors
Additional Informationscript debug output:
[15:45] System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation.

Server stack trace:
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) <0x41c928e0 + 0x00127> in <filename unknown>:0
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) <0x41c46610 + 0x0002a> in <filename unknown>:0
  at OpenSim.Region.ScriptEngine.Shared.ScriptBase.Executor.ExecuteEvent (System.String state, System.String FunctionName, System.Object[] args) <0x41d7f430 + 0x001be> in <filename unknown>:0

Exception rethrown at [0]:
 ---> System.Runtime.Remoting.RemotingException: Server for uri '1baddff8_ae20_4e7f_af66_15e9f2622395/2974137b_199703.rem' not found at (wrapper xdomain-invoke) OpenSim.Region.ScriptEngine.Shared.LSL_Types+list:get_Length ()
  at (wrapper remoting-invoke-with-check) OpenSim.Reg
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineubODE
EnvironmentMono / Linux64
Mono VersionOther
Viewerfirestorm
Attached Files

- Relationships

-  Notes
(0032165)
watcher64 (reporter)
2017-07-25 18:04

I'm just guessing here, but recently in the code some constants have been added there for some things changed a little ..

Try clearing your scriptengines directory and making sure the scripts get re-compiled ..

I have some PMAC stuff and not having this issue, but I had some other scripts throw similar errors due to needing recompiled .
(0032166)
watcher64 (reporter)
2017-07-25 18:10

Just tested with Arcadia's PMAC Bench , did not get any errors ..


https://www.dropbox.com/s/jkkgqz9swm4obkh/pmactest.jpg?dl=0 [^]
(0032167)
nixnerd (reporter)
2017-07-26 04:03

Hello watcher64, I've already tried that but thank you for the suggestion
(0032168)
UbitUmarov (administrator)
2017-07-26 04:28

set AppDomainLoading = false
(0032169)
nixnerd (reporter)
2017-07-26 07:33

Thanks for that suggestion Ubit, I'll give it a try and will update with my findings later
(0032170)
smxy (reporter)
2017-07-26 08:45

I, too, have the same PMAC-enabled bench, and also have no issues with it in my grid, which is running dev code from about two weeks ago.
(0032171)
nixnerd (reporter)
2017-07-26 08:59

Setting AppDomainLoading = false in the relevant OpenSim.ini files did indeed fix the issues with the script debug messages. Thank you Ubit (and smxy and watcher64). Please consider this issue resolved.

- Issue History
Date Modified Username Field Change
2017-07-25 15:53 nixnerd New Issue
2017-07-25 18:04 watcher64 Note Added: 0032165
2017-07-25 18:10 watcher64 Note Added: 0032166
2017-07-26 04:03 nixnerd Note Added: 0032167
2017-07-26 04:28 UbitUmarov Note Added: 0032168
2017-07-26 07:33 nixnerd Note Added: 0032169
2017-07-26 08:45 smxy Note Added: 0032170
2017-07-26 08:59 nixnerd Note Added: 0032171
2017-07-26 08:59 nixnerd Status new => resolved
2017-07-26 08:59 nixnerd Resolution open => fixed
2017-07-26 08:59 nixnerd Assigned To => nixnerd


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker