Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008194opensim[REGION] Script Functionspublic2017-06-20 23:522017-07-29 10:13
Reporterdjphil 
Assigned Todjphil 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS VersionSeven
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0008194: [SCRIPT FUNCTION REQUEST] osDrawFilledEllipse
DescriptionWe have osDrawPolygon and osDrawFilledPolygon
We have osDrawRectangle and osDrawFilledRectangle
We have osDrawEllipse but NOT osDrawFilledEllipse

Strange, why ... ?

I made a proposal there http://opensimulator.org/wiki/OSSL_Proposals [^] but i fear no one will ever see him there.

string osDrawFilledEllipse(string drawList, integer width, integer height)
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineubODE
Environment.NET / Windows32
Mono VersionNone
ViewerFirestorm
Attached Files

- Relationships

-  Notes
(0032056)
UbitUmarov (administrator)
2017-06-23 19:25

please test osDrawFilledEllipse same parameters as the ellipse
and also string form
drawList += "FillEllipse " + width + "," + height + "; ";

I only tested on windows so far
(0032057)
UbitUmarov (administrator)
2017-06-23 21:49

you can also test something like

        string CommandList = "";
        CommandList = osSetPenSize( CommandList, 3 );
        CommandList = osSetPenColor( CommandList, "Red" );
        CommandList = osMovePen( CommandList, 0, 0 );
        CommandList = osDrawFilledEllipse( CommandList, 200, 100 );
 
        // Now draw the rectangle
        string u = osSetDynamicTextureDataFace( "", "vector", CommandList, "width:256,height:256", 0, 4);
        llSay(0, u);
        llSetTexture(u, 2);

osSetDynamicTextureDataFace is new and sets a single face ( can also set all with ALL_SIDES, but that is same as osSetDynamicTextureData)

this do return the new texture ID now (and not a id of a useless internal thing)
(0032060)
djphil (reporter)
2017-06-24 03:02

Tested this morning under win 7, it works fine!
llSetLinkTexture(2, u, i); work fine too :)

Pizza party tonight!
Tyvm Ubit :)
(0032061)
djphil (reporter)
2017-06-24 03:27

Adding doc on wiki:
http://opensimulator.org/wiki/OsDrawFilledEllipse [^]
http://opensimulator.org/wiki/Drawing_commands#FillEllipse [^]
I hope no error ...
(0032062)
djphil (reporter)
2017-06-24 03:40

Firestorm follow https://jira.phoenixviewer.com/browse/FIRE-21301 [^]
(0032066)
UbitUmarov (administrator)
2017-06-24 18:56

so the new functions at the momente are

- string osDrawFilledEllipse(string drawList, int width, int height)
(need to follow the zxspectrum integer graphics of the other similar functions)
- string osSetDynamicTextureDataFace(string dynamicID, string contentType,
                      string data, string extraParams, int timer, int face);
- string osDrawResetTransform(string drawList)
- string osDrawRotationTransform(string drawList, LSL_Float x)
- string osDrawScaleTransform(string drawList, LSL_Float x, LSL_Float y)
- string osDrawTranslationTransform(string drawList, LSL_Float x, LSL_Float y)

last ones should make life easier with texture animation
remember dynamic textures features are not a GIMP replacement.
keep it simple.. or cry :p
(0032068)
djphil (reporter)
2017-06-25 04:01
edited on: 2017-06-25 04:02

- What is osSetDynamicTextureDataFace, is the same like osSetDynamicTextureDataBlendFace without alpha ?
- To reset transform, put the desired value to "0" is also right ?
- The ResetTransform function that you offer reset all the values to transform in one go, is that it ?

Hehe we have a very dynamic Gimp now, no need to take handkerchiefs :)

Doing the doc on the wiki is going to be more complicated.

(0032069)
djphil (reporter)
2017-06-25 04:32
edited on: 2017-06-26 03:16

Call for Volunteers

osDrawFilledEllipse @ http://opensimulator.org/wiki/OsDrawFilledEllipse [^]
osSetDynamicTextureDataFace @ http://opensimulator.org/wiki/OsSetDynamicTextureDataFace [^]
osDrawResetTransform @ http://opensimulator.org/wiki/OsDrawResetTransform [^]
osDrawRotationTransform @ http://opensimulator.org/wiki/OsDrawRotationTransform [^]
osDrawScaleTransform @ http://opensimulator.org/wiki/OsDrawScaleTransform [^]
osDrawTranslationTransform @ http://opensimulator.org/wiki/OsDrawTranslationTransform [^]

(0032070)
UbitUmarov (administrator)
2017-06-25 07:05

all the osSetDynamicTextureData* are identical just same define fixed parameters (like blend = false) the send to lower level execution.

No transforms are accumulative and mb complex(also order matters).
Reset does clean them all so better callit when you "get lost"
if you set a rotation of 45 to cancel it later you need to apply a rotation of -45, etc, similar to all the other transforms.
I can't help much on use, please google about .net drawing since our code in particular this transforms, uses it.
(0032216)
djphil (reporter)
2017-07-29 10:13

Everything works very well here, it's great!
Thanks Ubit :)

- Issue History
Date Modified Username Field Change
2017-06-20 23:52 djphil New Issue
2017-06-23 19:25 UbitUmarov Note Added: 0032056
2017-06-23 21:49 UbitUmarov Note Added: 0032057
2017-06-24 03:02 djphil Note Added: 0032060
2017-06-24 03:27 djphil Note Added: 0032061
2017-06-24 03:40 djphil Note Added: 0032062
2017-06-24 18:56 UbitUmarov Note Added: 0032066
2017-06-25 04:01 djphil Note Added: 0032068
2017-06-25 04:02 djphil Note Edited: 0032068 View Revisions
2017-06-25 04:32 djphil Note Added: 0032069
2017-06-25 07:05 UbitUmarov Note Added: 0032070
2017-06-26 03:16 djphil Note Edited: 0032069 View Revisions
2017-07-29 10:13 djphil Note Added: 0032216
2017-07-29 10:13 djphil Status new => resolved
2017-07-29 10:13 djphil Fixed in Version => master (dev code)
2017-07-29 10:13 djphil Resolution open => fixed
2017-07-29 10:13 djphil Assigned To => djphil
2017-07-29 10:13 djphil Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker