Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008169opensim[REGION] OpenSim Corepublic2017-05-19 08:522019-02-06 11:29
ReporterLotek 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSLinuxOS VersionUbuntu 16.04LTS
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0008169: Setting a parcel to group doesn't stick after a region restart
DescriptionWhen setting a parcel to a group, it will revert to not set to any group after the region has been restarted.

This bug occurs with 'set to group'.
This bug does not occur with 'deed to group'.
Steps To ReproduceMake a parcel
Set the parcel to any group without deeding it
Restart the region
Additional InformationBecause the parcel is not set to group, any items rezzed under the group but not owned by the owner will be autoreturned. That is correct behaviour but a disastrous result if you don't have backups.
TagsNo tags attached.
Git Revision or version numberc28430d52771ed6950e8482095a72ee8ef0c168d
Run Mode Grid (1 Region per Sim)
Physics EngineubODE
EnvironmentMono / Linux64
Mono VersionOther
ViewerFirestorm
Attached Files

- Relationships
related to 0008168closed Object set as group being autoreturned on group owned region 

-  Notes
(0031873)
UbitUmarov (administrator)
2017-05-19 09:38

Yes group was lost on region upload. Fixed on master
(0031875)
aiaustin (developer)
2017-05-19 11:54
edited on: 2017-05-19 11:55

This is probably the cause of my autoreturned object from a parcel recently. Reported in Mantis 8168.

http://opensimulator.org/mantis/view.php?id=8168 [^]

(0031876)
UbitUmarov (administrator)
2017-05-19 11:56

I made this bug with the dwell changes a few days . I did some cleanup on land creation a deletion, and.. oops ;)
(0034447)
BillBlight (developer)
2019-02-06 11:29

Marked as Resolved but never closed, can be reopened if needed.

- Issue History
Date Modified Username Field Change
2017-05-19 08:52 Lotek New Issue
2017-05-19 09:38 UbitUmarov Note Added: 0031873
2017-05-19 11:54 aiaustin Note Added: 0031875
2017-05-19 11:54 aiaustin Relationship added related to 0008168
2017-05-19 11:55 aiaustin Note Edited: 0031875 View Revisions
2017-05-19 11:56 UbitUmarov Note Added: 0031876
2017-05-20 00:19 Lotek Status new => resolved
2017-05-20 00:19 Lotek Resolution open => fixed
2017-05-20 00:19 Lotek Fixed in Version => master (dev code)
2019-02-06 11:29 BillBlight Note Added: 0034447
2019-02-06 11:29 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker