Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008168opensim[REGION] OpenSim Corepublic2017-05-17 04:232019-02-06 11:29
Reporteraiaustin 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformPCOSWindowsOS Version10
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0008168: Object set as group being autoreturned on group owned region
DescriptionUpdated to OpenSim 0.9.1 1377 c28430d (2017-05-15) and for some reason that I have not yet established one item on a region was returned due to "Autoreturn" which is set to 5 minutes for items not owned or set to the group who owns the region. Its odfd as ALL items on the region are owned by the same avatar (my avatar) and set to the group (which the avatar is owner of). The item is a simple cube of 120x120x0.5 set at 196,196,20 and has been in place for several years.

Replacing the item leads to it being returned again after 5 minutes even though its correctly set to the group. Copying a nearby similar item and placing it where it was also gets it autoreturned, as does creating a new prim (still set to group).

Anyone got thoughts as to what might be the cause?
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm 5.0.1.52150
Attached Files

- Relationships
related to 0008169closed Setting a parcel to group doesn't stick after a region restart 

-  Notes
(0031858)
aiaustin (developer)
2017-05-17 04:46
edited on: 2017-05-17 06:09

The 120x120x0.5m object also got returned when placed at 195.9,195.9,20.0 which was a test in case the object edge being exactly at 256.0 was an issue.

BUT... I tried another test placing the object at 128.0,128.0,20.0 and that seems to stay in place, when left fpr over an hour (autoreturn is set to 5 minutes).

Then I shifted it to 150.0,150.0,20.0 and it was immediately returned with the "parcel autoreturn" message. Odd.

(0031859)
UbitUmarov (administrator)
2017-05-17 04:59

just tested and worked fine.
position for returns is the root prim position.
return is by parcel owner/group not region
do you have the parcel group set?
(0031860)
aiaustin (developer)
2017-05-17 06:12

Ah, that's it... I was going on region group. I just checked and I am NOT the owner of that corner parcel. Thanks Ubut.

I wonder what changed... but that explains why the newly placed items are not working. Its an alt of mine that owns the corner so I will replace the item as that avata5r. Thanks.
(0034448)
BillBlight (developer)
2019-02-06 11:29

Marked as Resolved but never closed, can be reopened if needed.

- Issue History
Date Modified Username Field Change
2017-05-17 04:23 aiaustin New Issue
2017-05-17 04:46 aiaustin Note Added: 0031858
2017-05-17 04:59 UbitUmarov Note Added: 0031859
2017-05-17 06:09 aiaustin Note Edited: 0031858 View Revisions
2017-05-17 06:12 aiaustin Note Added: 0031860
2017-05-17 07:45 aiaustin Status new => resolved
2017-05-17 07:45 aiaustin Resolution open => no change required
2017-05-19 11:54 aiaustin Relationship added related to 0008169
2019-02-06 11:29 BillBlight Note Added: 0034448
2019-02-06 11:29 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker