Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008125opensim[REGION] OpenSim Corepublic2017-02-04 19:462017-02-05 15:55
Reporterrevcoyote 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformAlienware Area 51 R2OSWindows 10 ProOS Version10.0.14393
Product Version0.9.0 
Target VersionFixed in Version 
Summary0008125: Crashes on Start
DescriptionOpensim crashes on startup. log included.
Steps To ReproduceEvery time I try to start the sim.
Additional InformationBack history of this problem can be found Mantis ID: 0008123. Looks like this was flagged resolved to soon, this might actually be a bug. This is being run on a local hard drive. Not a network mapped drive.
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Fileslog file icon OpenSim.log [^] (5,800 bytes) 2017-02-04 19:46

- Relationships

-  Notes
(0031582)
BillBlight (developer)
2017-02-05 05:27

Willing to bet you need to install some older versions of .Net ..

Or it is simply a mis-configuration in your diva install ...

But If I had to put some $ on it I'd say installing .net 4.5 might fix this issue ..
(0031583)
BillBlight (developer)
2017-02-05 05:30

Also just out of curiosity, what anti-virus are you using? This error looks like what happens if I forget to turn off sandbox mode on avast and it makes Opensim crash?
(0031584)
BillBlight (developer)
2017-02-05 06:01

Quick question .. You reported this as a .9 issue, but your log shows Diva 8.2.1 ? did you copy .9 over the top of your diva install? This would most certainly cause the issue you are seeing ..

"
  - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration settings
2017-01-24 11:20:39,210 INFO - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration file F:\diva-r08210\diva-r08210\bin\OpenSimDefaults.ini
2017-01-24 11:20:39,223 INFO - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration file F:\diva-r08210\diva-r08210\bin\OpenSim.ini
2017-01-24 11:20:39,225 INFO - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration file F:\diva-r08210\diva-r08210\bin\config-include\DivaPreferences.ini
2017-01-24 11:20:39,227 INFO - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration file F:\diva-r08210\diva-r08210\bin\config-include\MyWorld.ini
"
(0031590)
revcoyote (reporter)
2017-02-05 12:41

I just tried installing the 4.5 framework. Since I a have 4.6.2 framework installed it would not let me saying there is a newer version installed.

My anti virus is McAfee LiveSafe.

The version number is a goof on my part. it's one the reasons why I include log files.
(0031591)
Ferd Frederix (reporter)
2017-02-05 13:39

According to Ai Austin:

A fix was made to OpenSim in bin/OpenSim.exe.config (and bin/Robust.exe.config though that is not used yet in the Diva D2 distribution) on 23-Nov-2013 (git master a68d1fa) for this, adding the following line to the <runtime> section…

    <loadFromRemoteSources enabled="true" />

Check this line is present in the bin/OpenSim.exe.config. If not, add it and run again.
(0031592)
revcoyote (reporter)
2017-02-05 15:55

Progress has been made! However, for some reason on the SQL tables was not created when building the DB. See enclosed OpenSim log

- Issue History
Date Modified Username Field Change
2017-02-04 19:46 revcoyote New Issue
2017-02-04 19:46 revcoyote File Added: OpenSim.log
2017-02-05 05:27 BillBlight Note Added: 0031582
2017-02-05 05:30 BillBlight Note Added: 0031583
2017-02-05 06:01 BillBlight Note Added: 0031584
2017-02-05 12:41 revcoyote Note Added: 0031590
2017-02-05 13:39 Ferd Frederix Note Added: 0031591
2017-02-05 15:55 revcoyote Note Added: 0031592


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker