Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008124opensim[REGION] OpenSim Corepublic2017-01-30 03:402017-05-27 14:51
Reporteraiaustin 
Assigned ToUbitUmarov 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0008124: WARNING: llcorehttp/_httppolicy.cpp and cannot access CAPS/EQG url with Bad Gateway (Http_502)
DescriptionI had cause to look at the viewer debug console and noticed some regular errors and warnings occurring every 5 or 6 seconds on our OSGrid regions with latest (27-Jan-2017 0.9.1 dev master OSGrid add on region build). I wonder if anyone can say what might be causing these. The regions all appear to be working fine and the normal legal OpenSim.log doe snot include any of these warning of errors. The problems have probably been there for a while and juts not noticed.

Snap of console output attached with several instances of the messages.

WARNING: llcorehttp/_httppolicy.cpp(437) : LLCore::HttpPolicy::stageAfterCompletion: HTTP Request 000001F9081E71D0 failed after 0 retries. Reason: Bad Gateway (Http_502)

WARNING: llmessage/llcorehttputil.cpp(282) @ LLCoreHttpUtil:: HttpCoroHandler::onCompleted:

Error[Http_502] cannot access url 'http://shetland.aiai.ed.ac.uk:9000/CAPS/EQG/.../' [^] because Bad Gateway
TagsNo tags attached.
Git Revision or version numberosgrid-opensim-01272017.v0.9.1.056ccae.zip
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm 5.0.1.52150
Attached Filesjpg file icon OSGrid-HTTP-Issues-and-Bad-Gateway.jpg [^] (153,291 bytes) 2017-01-30 03:40

- Relationships

-  Notes
(0031576)
UbitUmarov (administrator)
2017-01-30 06:53

a Linden did forgot that CAPS do return Bad Gateway Error when there is no data, and so forgot to ignore it as a error.
(0031577)
aiaustin (developer)
2017-01-30 07:01
edited on: 2017-01-30 07:04

So its a viewer glitch rather than server side error Ubit?

(0031578)
UbitUmarov (administrator)
2017-01-30 07:01

Viewer glich

- Issue History
Date Modified Username Field Change
2017-01-30 03:40 aiaustin New Issue
2017-01-30 03:40 aiaustin File Added: OSGrid-HTTP-Issues-and-Bad-Gateway.jpg
2017-01-30 03:45 aiaustin Description Updated View Revisions
2017-01-30 06:53 UbitUmarov Note Added: 0031576
2017-01-30 07:01 aiaustin Note Added: 0031577
2017-01-30 07:01 UbitUmarov Note Added: 0031578
2017-01-30 07:03 aiaustin Note Edited: 0031577 View Revisions
2017-01-30 07:04 aiaustin Note Edited: 0031577 View Revisions
2017-05-27 14:51 UbitUmarov Status new => closed
2017-05-27 14:51 UbitUmarov Assigned To => UbitUmarov
2017-05-27 14:51 UbitUmarov Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker