Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008117opensim[REGION] Script Functionspublic2017-01-07 21:432019-02-06 11:29
Reportermakopoppo 
Assigned ToUbitUmarov 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.9.0 
Target VersionFixed in Versionmaster (dev code) 
Summary0008117: llSetPhysicsMaterial cannot be virtually used due to the compilation error.
DescriptionWhen I use llSetPhysicsMaterial() LSL function from any viewer, compilation process fails showing error message:
---------
Error CS1502: The best overloaded method match for 'OpenSim.Region.ScriptEngine.Shared.ScriptBase.ScriptBaseClass.llSetPhysicsMaterial(int, float, float, float, float)' has some invalid arguments
Error CS1503: Argument `0000002' cannot convert `float' expression to type `float'
---------
Additional InformationLooking into ILSL_Api.cs, I found that llSetPhysicsMaterial was defined as the following:

----
void llSetPhysicsMaterial(int material_bits, float material_gravity_modifier, float material_restitution, float material_friction, float material_density);
----

Since there is no other functions which has float value in arguments, I suspect that the parse logic concerning to float type has any flaw, or LSL_Float or double type should be used instead.
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono VersionOther
Viewer
Attached Files

- Relationships

-  Notes
(0031545)
UbitUmarov (administrator)
2017-01-08 03:20

Thanks.
You are right, changed to LSL_Float on master
(0031546)
makopoppo (manager)
2017-01-08 07:34

I confirmed that this issue was fixed in OpenSim 0.9.1.0 Dev 90dee2f build.
Thank you!
(0034462)
BillBlight (developer)
2019-02-06 11:29

Marked as Resolved but never closed, can be reopened if needed.

- Issue History
Date Modified Username Field Change
2017-01-07 21:43 makopoppo New Issue
2017-01-07 22:13 BillBlight Note Added: 0031544
2017-01-07 22:14 BillBlight Note Edited: 0031544 View Revisions
2017-01-07 22:16 BillBlight Note Deleted: 0031544
2017-01-07 22:20 makopoppo Additional Information Updated View Revisions
2017-01-08 03:20 UbitUmarov Note Added: 0031545
2017-01-08 07:34 makopoppo Note Added: 0031546
2017-01-08 07:35 makopoppo Assigned To => UbitUmarov
2017-01-08 07:35 makopoppo Status new => resolved
2017-01-08 07:35 makopoppo Resolution open => fixed
2017-01-08 07:35 makopoppo Fixed in Version => master (dev code)
2019-02-06 11:29 BillBlight Note Added: 0034462
2019-02-06 11:29 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker