Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008018opensim[REGION] OpenSim Corepublic2016-09-03 23:502016-09-04 00:10
Reportertglion 
Assigned To 
PrioritynormalSeverityminorReproducibilityrandom
StatusnewResolutionopen 
PlatformLinuxOSSuse LinuxOS VersionLeap 42.1
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0008018: Strange error in logfile
DescriptionSometimes I see an error in log-file:

08:06:27 - [POLL SERVICE WORKER THREAD]: Error System.ObjectDisposedException: The object was used after being disposed.
  at System.Net.Sockets.Socket.Send (System.Byte[] buf, Int32 offset, Int32 size, SocketFlags flags) [0x0005c] in /home/abuild/rpmbuild/BUILD/mono-4.0.4/mcs/class/System/System.Net.Sockets/Socket.cs:1841
  at HttpServer.HttpClientContext.Send (System.Byte[] buffer, Int32 offset, Int32 size) [0x00000] in <filename unknown>:0
  at HttpServer.HttpResponse.Send () [0x00000] in <filename unknown>:0
  at OpenSim.Framework.Servers.HttpServer.OSHttpResponse.Send () [0x00017] in /opt/opensim/DeepImpact/OpenSim/Framework/Servers/HttpServer/OSHttpResponse.cs:325
  at OpenSim.Framework.Servers.HttpServer.PollServiceHttpRequest.DoHTTPGruntWork (OpenSim.Framework.Servers.HttpServer.BaseHttpServer server, System.Collections.Hashtable responsedata) [0x00067] in /opt/opensim/DeepImpact/OpenSim/Framework/Servers/HttpServer/PollServiceHttpRequest.cs:94

  
08:12:40 - [POLL SERVICE WORKER THREAD]: Error System.Net.Sockets.SocketException: The descriptor is not a socket
  at System.Net.Sockets.Socket.Send (System.Byte[] buf, Int32 offset, Int32 size, SocketFlags flags) [0x0005c] in /home/abuild/rpmbuild/BUILD/mono-4.0.4/mcs/class/System/System.Net.Sockets/Socket.cs:1841
  at HttpServer.HttpClientContext.Send (System.Byte[] buffer, Int32 offset, Int32 size) [0x00000] in <filename unknown>:0
  at HttpServer.HttpResponse.Send () [0x00000] in <filename unknown>:0
  at OpenSim.Framework.Servers.HttpServer.OSHttpResponse.Send () [0x00017] in /opt/opensim/DeepImpact/OpenSim/Framework/Servers/HttpServer/OSHttpResponse.cs:325
  at OpenSim.Framework.Servers.HttpServer.PollServiceHttpRequest.DoHTTPGruntWork (OpenSim.Framework.Servers.HttpServer.BaseHttpServer server, System.Collections.Hashtable responsedata) [0x00067] in /opt/opensim/DeepImpact/OpenSim/Framework/Servers/HttpServer/PollServiceHttpRequest.cs:94

Unfortunatly I don't know what action or script was causing this.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux64
Mono Version4.0.1
Viewer
Attached Files

- Relationships

-  Notes
(0031101)
UbitUmarov (administrator)
2016-09-04 00:10

that means the viewer did timeout the connection before region sending a response.
This can be because of a bit of lag, or simple because viewer already disconnected.
it is now more visible:
A) we allowed it to be visible for debug
B) recent viewers seem to have shorter timeouts.
those 2 are harmless.

- Issue History
Date Modified Username Field Change
2016-09-03 23:50 tglion New Issue
2016-09-04 00:10 UbitUmarov Note Added: 0031101


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker