Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007982opensim[REGION] Specific OpenSim Modulepublic2016-08-01 11:192016-08-07 07:30
ReporterGreg McCray 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOpensimOSOS Version0.9 DEV
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007982: DataSnapShot module not working
DescriptionI have set up my datasnapshot module exactly like the instructions said to. I have load the correct files to my web server, and set up the MySQL database.

When I start opensim I do not see any error messages, but the datasnapshot folder remains empty and in-world search is not working.

I did add the required line for search in my opensim.ini as well.
Additional Informationit appears the snapshot is working--here is what I get when I run the program you suggested:
<regiondata>
<expire>1200</expire>
<region category="Mature" entities="0">
<info>
<uuid>2f42d5c8-2a27-4e06-ab36-93a1535d61b0</uuid>
<url>http://127.0.0.1:9000</url> [^]
<name>Midday</name>
<handle>1103909674543360</handle>
</info>
<grid>
<gatekeeperURL>http://127.0.0.1:8002</gatekeeperURL> [^]
<name>Dreamworld</name>
</grid>
<data>
<estate>
<user>
<name>Test User</name>
<uuid>8a587593-9d81-48b1-8f75-9fd559cca7ad</uuid>
</user>
<name>Sandbox</name>
<id>101</id>
<parentid>1</parentid>
<flags teleport="True" public="True"/>
</estate>
<parceldata>
<parcel showinsearch="true" scripts="true" build="true" public="true" category="0" forsale="false" salesprice="0">
<name>Your Parcel</name>
<description></description>
<uuid>d22955ab-8945-4a9e-a3fa-dafd681b1375</uuid>
<area>65536</area>
<location>128/128/21</location>
<infouuid>00e90300-00ec-0300-8000-000080000000</infouuid>
<dwell>0</dwell>
<owner>
<uuid>8a587593-9d81-48b1-8f75-9fd559cca7ad</uuid>
<name>Test User</name>
</owner>
</parcel>
</parceldata>
<objectdata/>
</data>
</region>
<region category="PG" entities="0">
<info>
<uuid>2f42d8a8-2a32-4e06-ab34-93a1595d61b0</uuid>
<url>http://127.0.0.1:9000</url> [^]
<name>Sandbox</name>
<handle>1099511628032000</handle>
</info>
<grid>
<gatekeeperURL>http://127.0.0.1:8002</gatekeeperURL> [^]
<name>Dreamworld</name>
</grid>
<data>
<estate>
<user>
<name>Test User</name>
<uuid>8a587593-9d81-48b1-8f75-9fd559cca7ad</uuid>
</user>
<name>Sandbox</name>
<id>101</id>
<parentid>1</parentid>
<flags teleport="True" public="True"/>
</estate>
<parceldata/>
<objectdata/>
</data>
</region>
<region category="PG" entities="0">
<info>
<uuid>2f42d5c8-2a22-4e06-ab34-93a1595d61b0</uuid>
<url>http://127.0.0.1:9000</url> [^]
<name>Welcome Center</name>
<handle>1100611139660032</handle>
</info>
<grid>
<gatekeeperURL>http://127.0.0.1:8002</gatekeeperURL> [^]
<name>Dreamworld</name>
</grid>
<data>
<estate>
<user>
<name>Test User</name>
<uuid>8a587593-9d81-48b1-8f75-9fd559cca7ad</uuid>
</user>
<name>Sandbox</name>
<id>101</id>
<parentid>1</parentid>
<flags teleport="True" public="True"/>
</estate>
<parceldata/>
<objectdata/>
</data>
</region>
</regiondata>

which is correct I have 3 regions all of them show up---but when I run in-world search I get this error message.

2016-08-07 10:14:49,763 ERROR (Incoming Packets (Sandbox)) - OpenSimSearch.Modules.OpenSearch.OpenSearchModule [SEARCH]: Unable to connect to Search Server http://127.0.0.1/query.php. [^] Exception System.Xml.XmlException: There are multiple root elements. Line 2, position 2.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at Nwc.XmlRpc.XmlRpcResponseDeserializer.Deserialize(TextReader xmlData)
   at Nwc.XmlRpc.XmlRpcRequest.Send(String url, Int32 timeout)
   at OpenSimSearch.Modules.OpenSearch.OpenSearchModule.GenericXMLRPCRequest(Hashtable ReqParams, String method) in k:\OSGRID\opensim-0.9.0-458-g9b4e83c\addon-modules\OpenSimSearch\Modules\SearchModule\OpenSearch.cs:line 155
2016-08-07 10:14:49,803 ERROR (Incoming Packets (Sandbox)) - OpenSimSearch.Modules.OpenSearch.OpenSearchModule [SEARCH]: Unable to connect to Search Server http://127.0.0.1/query.php. [^] Exception System.Xml.XmlException: There are multiple root elements. Line 2, position 2.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at Nwc.XmlRpc.XmlRpcResponseDeserializer.Deserialize(TextReader xmlData)
   at Nwc.XmlRpc.XmlRpcRequest.Send(String url, Int32 timeout)
   at OpenSimSearch.Modules.OpenSearch.OpenSearchModule.GenericXMLRPCRequest(Hashtable ReqParams, String method) in k:\OSGRID\opensim-0.9.0-458-g9b4e83c\addon-modules\OpenSimSearch\Modules\SearchModule\OpenSearch.cs:line 155
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineOther
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerFirestrorm
Attached Fileslog file icon OpenSim.log [^] (557,251 bytes) 2016-08-07 07:24
? file icon OpenSim.ini [^] (58,188 bytes) 2016-08-07 07:27

- Relationships

-  Notes
(0030981)
kcozens (administrator)
2016-08-03 16:15

If you want to find out if the DataSnapshot module is working look for the entries in the hostsregister table used by the search module and look for the IP address and port number. Use a web browser and enter a URL of the form http://your.i.p.address:port#/?method=collector [^]

If the module is configured and working properly you will get a page of XML code. If you don't see the XML messages there is something wrong. If that is the case for you attach a file to this report showing the contents of the [DataSnapshot] section of your OpenSim.ini file.
(0030991)
Greg McCray (reporter)
2016-08-07 07:30
edited on: 2016-08-07 08:07

I set up the 4 php files in my public folder of my web server (apache). and I updated the databaseinfo.php with the correct database information. The instance shows up in the hostregister of the data base as well.

Data snap shot folder does have xml files for each regions

I setup (through my windows task scheduler) my passer.php file to run every hour.


- Issue History
Date Modified Username Field Change
2016-08-01 11:19 Greg McCray New Issue
2016-08-01 16:32 kcozens Note Added: 0030966
2016-08-01 16:32 kcozens Assigned To => kcozens
2016-08-01 16:32 kcozens Status new => acknowledged
2016-08-03 15:07 kcozens Assigned To kcozens =>
2016-08-03 15:16 kcozens Note Deleted: 0030966
2016-08-03 15:18 kcozens Status acknowledged => new
2016-08-03 16:15 kcozens Note Added: 0030981
2016-08-07 07:22 Greg McCray Additional Information Updated View Revisions
2016-08-07 07:24 Greg McCray File Added: OpenSim.log
2016-08-07 07:27 Greg McCray File Added: OpenSim.ini
2016-08-07 07:30 Greg McCray Note Added: 0030991
2016-08-07 07:59 Greg McCray Note Edited: 0030991 View Revisions
2016-08-07 08:07 Greg McCray Note Edited: 0030991 View Revisions


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker