Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007937opensim[REGION] OpenSim Corepublic2016-06-23 11:132016-06-24 03:05
Reporteraiaustin 
Assigned ToDiva 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Versionmaster (dev code) 
Summary0007937: [EVENTQUEUE]: (Enqueue) No queue found for agent ... when placing message AgentGroupDataUpdate
DescriptionIn recent versions - last few days? - I am seeing yellow warnings of this form

19:07:34 - [EVENTQUEUE]: (Enqueue) No queue found for agent b9112f4c-533b-46bc-be56-22cf1c752d2b when placing message AgentGroupDataUpdate in region Oil Rig

19:08:01 - [EVENTQUEUE]: (Enqueue) No queue found for agent 33705bfc-45a9-4c1d-a1f8-72c84d0b0d95 when placing message AgentGroupDataUpdate in region Marineville
Steps To ReproduceStart up regions on a grid on latest dev master. No avatar is logged in when these appear.
TagsNo tags attached.
Git Revision or version number0.9.0-376-g1065a4c
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Files

- Relationships

-  Notes
(0030694)
Diva (administrator)
2016-06-23 11:19

Ai, I cannot do anything with this bug report.
What do you have on that region? Bots?
(0030695)
aiaustin (developer)
2016-06-23 11:26
edited on: 2016-06-23 11:28

There is indeed one NPC on each of those regions.

These message are new and recent though @Diva... I only started to see them in the last few days I think. I have been keeping up with the very latest 0.9.0 dev master on this AiLand development/experimental grid for OpenSim testing.

Funnily though on the same region server and same instance of OpenSim.exe another region with two NPCs on it and one further region with one NPC does not show this message. Anything I can get in the way of further logs to help?

None of the bots should relate to groups as far as I know.

(0030696)
Diva (administrator)
2016-06-23 11:30

You have to diagnose it yourself, because I cannot reproduce it. Without steps to reproduction, any changes to the code are shots in the dark.

I suspect it's related to your bots.
(0030697)
aiaustin (developer)
2016-06-23 11:39
edited on: 2016-06-23 11:50

You are right... it occurs in fact for every NPC in any region I now can see.

I will give the context here for the message.. this is an example for a "Great White" (shark) NPC on the Marineville region... its the yellow warning - [EVENTQUEUE]: (Enqueue) message that is new and recent.

19:31:51 - [SCENE]: Adding new child scene presence Great White d7d5c035-135b-4da0-84b5-6a385b865cdc to scene Marineville at pos <200, 35, 19>, tpflags: Default
19:31:52 - [HGFRIENDS MODULE]: Fetched 0 local friends for visitor d7d5c035-135b-4da0-84b5-6a385b865cdc
19:31:52 - [SCENE PRESENCE]: Completing movement of Great White into region Marineville in position <200, 35, 19>
19:31:52 - [CompleteMovement]: WaitForUpdateAgent: 15ms
19:31:52 - [MakeRootAgent]: enter lock: 0ms
19:31:52 - [MakeRootAgent]: out lock: 32ms
19:31:52 - [MakeRootAgent]: Grouptitle: 32ms
19:31:52 - [MakeRootAgent]: TriggerSetRootAgentScene: 63ms
19:31:52 - [MakeRootAgent]: position and physical: 78ms
19:31:52 - [HGFRIENDS MODULE]: Fetched 0 local friends for visitor d7d5c035-135b-4da0-84b5-6a385b865cdc
19:31:52 - [EVENTQUEUE]: (Enqueue) No queue found for agent d7d5c035-135b-4da0-84b5-6a385b865cdc when placing message AgentGroupDataUpdate in region Marineville

(0030699)
Diva (administrator)
2016-06-23 11:55

Are you using the very latest? I may have fixed it a few hours ago when I fixed the failing test.
(0030704)
aiaustin (developer)
2016-06-23 12:04
edited on: 2016-06-23 12:05

I installed opensim-0.9.0-376-g1065a4c.zip which included your failing test fix at opensim-0.9.0-372-g648cf51.zip. That gives the same messages @Diva.

Should we be trying to look up [HGFRIENDS] for NPCs too?

(0030705)
Diva (administrator)
2016-06-23 12:11

[12:11] <cia-opensim> opensim: diva * rcec5682da96a OpenSim (2 files in 2 dirs):
[12:11] <cia-opensim> Mantis 0007937: don't send group info to NPCs
(0030706)
aiaustin (developer)
2016-06-23 12:14

Thanks @Diva... will update and test when the Httpserver errors in this build are fixed.
(0030734)
aiaustin (developer)
2016-06-24 03:05

This now works well.

- Issue History
Date Modified Username Field Change
2016-06-23 11:13 aiaustin New Issue
2016-06-23 11:13 aiaustin Status new => assigned
2016-06-23 11:13 aiaustin Assigned To => Diva
2016-06-23 11:19 Diva Note Added: 0030694
2016-06-23 11:20 Diva Assigned To Diva => aiaustin
2016-06-23 11:23 aiaustin Assigned To aiaustin => Diva
2016-06-23 11:26 aiaustin Note Added: 0030695
2016-06-23 11:27 aiaustin Note Edited: 0030695 View Revisions
2016-06-23 11:28 aiaustin Note Edited: 0030695 View Revisions
2016-06-23 11:30 Diva Note Added: 0030696
2016-06-23 11:39 aiaustin Note Added: 0030697
2016-06-23 11:50 aiaustin Note Edited: 0030697 View Revisions
2016-06-23 11:55 Diva Note Added: 0030699
2016-06-23 12:04 aiaustin Note Added: 0030704
2016-06-23 12:05 aiaustin Note Edited: 0030704 View Revisions
2016-06-23 12:11 Diva Note Added: 0030705
2016-06-23 12:14 aiaustin Note Added: 0030706
2016-06-24 03:05 aiaustin Note Added: 0030734
2016-06-24 03:05 aiaustin Status assigned => resolved
2016-06-24 03:05 aiaustin Fixed in Version => master (dev code)
2016-06-24 03:05 aiaustin Resolution open => fixed
2016-06-24 03:05 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker