Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007932opensim[REGION] Script Functionspublic2016-06-21 15:502019-02-06 11:30
Reportershin ingen 
Assigned ToDiva 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionno change required 
PlatformLinuxOSDebianOS Version8
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007932: llRezObject ignores the Velocity parameter even when the rezzed object is physical
DescriptionllRezObject(string inventory, vector pos, vector vel, rotation rot, integer param)

I have tested this function on 0.8.2 and it works but not in master dev.
Steps To ReproduceI attached an iar of the rocket launcher I am using for testing. Touch to launch. For the master dev, the rocket will rez but will not go anywhere while in 0.8.2 it will rez and accelerate.
TagsNo tags attached.
Git Revision or version numberopensim-0.9.0-316-gbcee4e3
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
EnvironmentMono / Linux64
Mono Version3.2
Viewer
Attached Files? file icon rocketlauncher.iar [^] (155,080 bytes) 2016-06-21 15:50

- Relationships

-  Notes
(0030642)
Diva (administrator)
2016-06-21 18:04

Looks like this is a regression
(0030643)
Diva (administrator)
2016-06-21 18:05

Why are there two launchers in the iar?
(0030644)
shin ingen (reporter)
2016-06-21 19:07

sorry about that, I didn't realize there are two. One goes further than the other.
(0030645)
kcozens (administrator)
2016-06-21 19:10

I was working on a fireworks launcher in a grid running 080PF when I first noticed this issue. The rezzed object appeared but didn't move.
(0030646)
Diva (administrator)
2016-06-21 19:10

oh so this was already a bug in 082?
(0030648)
Diva (administrator)
2016-06-21 20:29

[20:29] <cia-opensim> opensim: diva * rf19199cf4a6e OpenSim/Region/Framework/Scenes/Serialization (SceneObjectSerializer.cs):
[20:29] <cia-opensim> Mantis 0007932: Some objects were being serialized with PCode=9 and State != 0 (meaning attachments). That should never happen.
(0030650)
nebadon (administrator)
2016-06-21 21:44

There seems to be a problem with this fix, if i teleport to another simulator running same version, I loose all my attachments and can not get them back on unless I log out and back in, this has been reported by Mandarinka_T18 and confirmed as well by me.
(0030655)
Diva (administrator)
2016-06-22 06:20

hmm, ok. I was afraid this would happen.
(0030656)
Diva (administrator)
2016-06-22 06:26

WRT this specific object: I don't know how this might have happened, but the projectile that's being rezzed is tagged as attachment. That's why it's not being added to the physics scene. Did you ever wear it?
(0030657)
Diva (administrator)
2016-06-22 06:34

And btw, it also doesn't work in 0.8.2 -- I just tested it. So it's really this particular projectile that's broken, not the code to rez it. I don't know what exactly you did for it to end up being marked as attachment. Somewhere along the way of doing that, something went wrong. If you can remember, that would be great. But otherwise, there is no bug in llRez. The bug is somewhere along the way of creating this projectile.
(0030658)
nebadon (administrator)
2016-06-22 06:43

Could it be that this projectile is part of a weapon you wear such as a gun or something?
(0030659)
Diva (administrator)
2016-06-22 06:44

[06:35] <cia-opensim> opensim: diva * r0b32cf0e8f0e OpenSim/Region/Framework/Scenes/Serialization (SceneObjectSerializer.cs):
[06:35] <cia-opensim> Can't do it do it this low in the stack. Attachments on teleports apparently rely on
[06:35] <cia-opensim> State being != 0.
[06:35] <cia-opensim> Revert "Mantis 0007932: Some objects were being serialized with PCode=9 and State != 0 (meaning attachments). That should never happen."
[06:35] <cia-opensim>
[06:35] <cia-opensim> This reverts commit f19199cf4a6ef9cdcfbdbff3a1f604f595216f65.
(0030670)
shin ingen (reporter)
2016-06-22 13:07

Thanks Diva-- It is probably more accurate to say that it works for the pre-avination merge version of Opensim since I just learned that the 0.8.2 I used to test it on is the pre-Avination.

I designed this projectile for 0.8.1 so yes it is possible that this item had been worn as attachment since it is a common practice at that time to wear an object when taking items from the hypergrid.

I will scrub the object and start over and I will mark this post as resolve.
(0030671)
shin ingen (reporter)
2016-06-22 13:08

scripter snafu
(0034514)
BillBlight (developer)
2019-02-06 11:30

Marked as Resolved but never closed, can be reopened if needed.

- Issue History
Date Modified Username Field Change
2016-06-21 15:50 shin ingen New Issue
2016-06-21 15:50 shin ingen File Added: rocketlauncher.iar
2016-06-21 18:04 Diva Note Added: 0030642
2016-06-21 18:04 Diva Assigned To => Diva
2016-06-21 18:04 Diva Status new => confirmed
2016-06-21 18:05 Diva Note Added: 0030643
2016-06-21 19:07 shin ingen Note Added: 0030644
2016-06-21 19:10 kcozens Note Added: 0030645
2016-06-21 19:10 Diva Note Added: 0030646
2016-06-21 20:29 Diva Note Added: 0030648
2016-06-21 21:44 nebadon Note Added: 0030650
2016-06-22 06:20 Diva Note Added: 0030655
2016-06-22 06:26 Diva Note Added: 0030656
2016-06-22 06:34 Diva Note Added: 0030657
2016-06-22 06:43 nebadon Note Added: 0030658
2016-06-22 06:44 Diva Note Added: 0030659
2016-06-22 13:07 shin ingen Note Added: 0030670
2016-06-22 13:08 shin ingen Note Added: 0030671
2016-06-22 13:08 shin ingen Status confirmed => resolved
2016-06-22 13:08 shin ingen Resolution open => no change required
2019-02-06 11:30 BillBlight Note Added: 0034514
2019-02-06 11:30 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker