Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007930opensim[REGION] Specific OpenSim Modulepublic2016-06-20 00:502016-06-20 09:51
Reporteraiaustin 
Assigned ToDiva 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformPCOSWindowsOS Version10
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0007930: [Groups Module v2] In some cases for inviting a new member the Role shows as "(loading...)"
DescriptionWhen using [Groups Module v2], in the case of some specific (but not all) groups, and when the group owner is inviting a new member the Role shows as "(loading...)" and never resolves. This therefore does not allow an invitation to be sent.

The MySQL data bases all look reasonable with the Owner and Everyone roles present for the group affected. I cannot see a pattern on the groups that show this bug and those that don't yet.

This was originally noticed on opensim-0.9.0-343-gfe1f01d.zip (2016-06-17) but was probably there for some time. it is still there on the latest opensim-0.9.0-353-gff65248.zip (2016-06-20) in which @Diva has made some Group handling changes to update information in more places.

 
Steps To ReproduceUsing the groups v2 module on Openvue and AiLand grids, which were originally created at very different times, Using the groups tool on Firestorm 4.7.7 and looking at each group.

Go to the members & Roles tab and then the Members subtab and try to Invite a user. The avatar picker can be used to select a potential member, but the drop down to select a role does not allow a selection, indicating "(Loading...)" instead and that never resolved.
TagsNo tags attached.
Git Revision or version numberopensim-0.9.0-353-gff65248
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm 4.7.7
Attached Filesjpg file icon 2016-06-17-OpenSim-Groups-v2-Role-Loading.jpg [^] (173,310 bytes) 2016-06-20 00:50

- Relationships

-  Notes
(0030596)
aiaustin (developer)
2016-06-20 04:05
edited on: 2016-06-20 05:03

Looking more at this, it also seems that if a role label is changed (in Firestorm 4.7.7) it does not show as having been changed in the groups tool info -> Members & Roles tab or on the label over the avatar. But if a relog is done it then shows. So it seems to be being changed, but it is not being updated dynamically in the viewer correctly (until after a relog).

But note that the main issue reported here occurs without any such role label change beng done.

Looking at the MySQL data base record for the os_groups_roles table it seems that the "Everyone" role always has a null UUID (00000000-0000-0000-0000-000000000000) as its role UUID. This is the case for the groups that exhibit the "(loading...)" issue and those that show the roles correctly. Is that use of the null UUID there correct?

(0030598)
Diva (administrator)
2016-06-20 09:15

Try hitting "refresh" in the groups floater
(0030599)
aiaustin (developer)
2016-06-20 09:36

Hitting the refresh button in the groups floater for each of the affected groups fixes the problem Diva. Thanks.

Was it a viewer cache issue? It did persist over several days and a number of relogs after I first spotted it.
(0030600)
Diva (administrator)
2016-06-20 09:42

The regions cache the group information for a couple of minutes. There's some more love that this could get, so that the viewer would be immediately updated, but it's very low priority for me. Hit refresh, and things will work.
(0030601)
aiaustin (developer)
2016-06-20 09:49

That makes sense given what I saw when i hit refresh.. MOST of the groups worked fit time. one did not but was right shortly afterwards. Closing issue. Thanks.
(0030602)
aiaustin (developer)
2016-06-20 09:51

Use refresh in Groups tool if you experience this.

- Issue History
Date Modified Username Field Change
2016-06-20 00:50 aiaustin New Issue
2016-06-20 00:50 aiaustin Status new => assigned
2016-06-20 00:50 aiaustin Assigned To => Diva
2016-06-20 00:50 aiaustin File Added: 2016-06-17-OpenSim-Groups-v2-Role-Loading.jpg
2016-06-20 01:03 aiaustin Description Updated View Revisions
2016-06-20 01:03 aiaustin Viewer Firestorm 4.7.7. => Firestorm 4.7.7
2016-06-20 04:05 aiaustin Note Added: 0030596
2016-06-20 04:05 aiaustin Note Edited: 0030596 View Revisions
2016-06-20 05:02 aiaustin Note Edited: 0030596 View Revisions
2016-06-20 05:03 aiaustin Note Edited: 0030596 View Revisions
2016-06-20 09:12 aiaustin Description Updated View Revisions
2016-06-20 09:12 aiaustin Steps to Reproduce Updated View Revisions
2016-06-20 09:13 aiaustin Git Revision or version number This was originally noticed on opensim-0.9.0-343-gfe1f01d => opensim-0.9.0-353-gff65248
2016-06-20 09:15 Diva Note Added: 0030598
2016-06-20 09:36 aiaustin Note Added: 0030599
2016-06-20 09:42 Diva Note Added: 0030600
2016-06-20 09:49 aiaustin Note Added: 0030601
2016-06-20 09:51 aiaustin Note Added: 0030602
2016-06-20 09:51 aiaustin Status assigned => resolved
2016-06-20 09:51 aiaustin Resolution open => no change required
2016-06-20 09:51 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker