Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007917opensim[REGION] Specific OpenSim Modulepublic2016-06-05 12:502019-02-06 11:30
Reporterdanbanner 
Assigned ToDiva 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0007917: PrimLimitsModule does not work correctly after selling land
DescriptionSetting up a 512x512 var with 15 parcels and primlimits enabled works fine until parcel is sold to a resident. In my regions i tested this in the parcel limits were 676 with a total of 28000 defined by MaxPrims for the entire var. 600 prims objects rez fine in the parcels until they are sold and then the new land owner cannot rez more than 100 or so prims.
Steps To Reproducecreate a 512x512 var region and enable the primlimits module in your ini..

    permissionmodules = DefaultPermissionsModule,PrimLimitsModule

create several parcels and test
sell parcels to others and test again

TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Script Engine
EnvironmentMono / Linux64
Mono Version3.2
Viewerany
Attached Files

- Relationships

-  Notes
(0030415)
Mandarinka Tasty (reporter)
2016-06-07 09:11

Hello Dan :)

I was testing Your issue, but I can't see anything wrong or I do not understand

precisely what You were doing with problematic parcel.

1. You have created parcel with prim capacity: 676 prims.

2. You have rezzed 600 prims

3. You have set parcel for the sale, but you did not remove your 600 prims, yes or no ?

4. when you have set parcel for the sale, you have also set objects for sale or no ? I'm asking about it, because, when oen sets parcel for the sale, viewer also asks about changing ownership of objects afger transaction.

5. I assume, that You have chosen option : No

6. Other resident has purchased the parcel, but still on this parcel, there are your objects, right ?

&. So , assume, John Smith is new owner of the parcel, and there are 600 prims of Yours on his parcel,

7. So that is clear for me, that John = new owner can't rezz more than 76 prims on his parcel, since Your objects ( Dan's prims ) are there.

So i can't see anythign wrong with it,

to allow John to rezz 676 prims, you need to remove your 600 prims earlier,

before John purchases the parcel.

PrimlimitsModule works due to such condition:

if ((objectCount + lo.PrimCounts.Total) > simulatorCapacity)
            {
                response = "Unable to rez object because the parcel is too full";
            }

where simulatorCapacity = newParcel.GetSimulatorMaxPrimCount

If your situation looks different than my description, please describe it

more specifically.

Regards
(0030423)
danbanner (manager)
2016-06-08 04:13

No, i only use my 600 prim linkset to test the capacity and remove it. After parcel sale the empty parcel will not allow anyone to rez the 600 prim linkset, not even in god mode.
This worked like it was supposed to last year on 0.8.2 although to get approx. the same 676 limit for a 1536 sqm parcel on a 512x512 var i had to set MaxPrims = 110000

did you test this on a var?
(0030565)
Diva (administrator)
2016-06-18 22:08

22:07] <cia-opensim> opensim: diva * rce7fa728efa5 OpenSim/Region (2 files in 2 dirs):
[22:07] <cia-opensim> Mantis 0007917: regression on prim limits module.
(0030567)
danbanner (manager)
2016-06-19 04:35

I had to set MaxPrims = 111900 to achieve the 676 prim allowance for the parcels, which is fine. Prim limits do seem to work correctly, and I was allowed to fill the parcel to 676 and I could not rez anymore objects.

About land however is still showing the entire region limits http://danbanner.onikenkon.com/screen/Image1466336018.png [^]

Which to me is a minor issue, since actual prim limits are working as expected.
(0030568)
danbanner (manager)
2016-06-19 05:01
edited on: 2016-06-19 05:07

Update: I updated another identical region with the same MaxPrims = 111900, same size parcels and again i could not rez past 676 however on this region its displaying the parcel limit incorrectly at 2704

land show [parcel id] does show the correct 676 limit

http://danbanner.onikenkon.com/screen/Image1466337477.png [^]

When i set MaxPrims = 28000 it shows 676 limit but its actually much lower.
I'll update the 3rd region and see what happens. More info shortly.

(0030569)
danbanner (manager)
2016-06-19 05:18

Updated the 3rd region and parcels are displaying the correct 676 limit. I checked object bonus on all 3 regions and all are set to 1.0 so I'm not sure why the 2nd one is not displaying the correct values. I'll do a compare of the ini's and see what i can find out.
(0030570)
Diva (administrator)
2016-06-19 06:36

How large are these regions?
(0030571)
Diva (administrator)
2016-06-19 06:56
edited on: 2016-06-19 07:09

About the "Simulator primitive usage": I still don't know what that is supposed to show. Right now it shows
<Max prims the owner has in the region> out of <MaxPrims in the region>

(0030572)
danbanner (manager)
2016-06-19 07:05

they are all three 512x512 vars and the parcels are 1584 sqkm
(0030573)
danbanner (manager)
2016-06-19 07:22

Okay, second simulator 2704 prim limit issue resolved and was due to pebkac (blush)
(0030574)
Diva (administrator)
2016-06-19 09:23

[09:17] <cia-opensim> opensim: diva * r12b73603cc46 OpenSim (4 files in 3 dirs):
[09:17] <cia-opensim> Still related to mantis 0007917, parcel prims info. Now sending the correct numbers for "Simulator primitive usage" related to the parcel owner, not the entire region.
(0030575)
Mandarinka Tasty (reporter)
2016-06-19 10:13

Hello.

Have you tested your report, after Diva's patch, against situation when you sell the parcel ?

In actual, code, in my opinion, problem exists not in public void SendLandProperties, where diva has replaced: GetParcelBasePrimCount() with GetParcelMaxPrimCount()

but in public void UpdateLandSold

Because there is commented line:

// m_scene.EventManager.TriggerParcelPrimCountUpdate();

and it was made by mistake.


Please notice,that in public void DeedToGroup

this line is alive.

So to make parcel update its prim count after selling, this must be uncommented:

// m_scene.EventManager.TriggerParcelPrimCountUpdate();
(0030576)
Mandarinka Tasty (reporter)
2016-06-19 10:24

public void SendLandProperties , this thing is just responsible for

displaying info to the viewer, because of:

remote_client.SendLandProperties(seq_id,
                    snap_selection, request_result, this,
                    (float)m_scene.RegionInfo.RegionSettings.ObjectBonus,
                    GetParcelBasePrimCount(),
                    GetSimulatorMaxPrimCount(), regionFlags);

So in fact, that does not update parcel's prim capacity, that simply sends info

about it.

And GetParcelBasePrimCount() has been offered to improve displaying

situations that appear where region's bonus factor is > 1 ( greater than 1.0 )
(0030577)
danbanner (manager)
2016-06-19 10:24

This fixes the total count and available prims for the parcel owner. I also did test a sale and the prim counts and amounts did seem to update correctly.
(0030579)
Mandarinka Tasty (reporter)
2016-06-19 10:37

Ah yes :))

Diva has added additional corrections:

updateMessage.SimWideMaxPrims = lo.GetSimulatorMaxPrimCount();

and

private void FinalizeLandPrimCountUpdate()

so all is ok :) I'm happy then too.

Thank You for such quick answer :)

Regards
(0030580)
Gavin Hird (reporter)
2016-06-19 12:45

Question to the commit message as it says "Simulator primitive usage" but should it not be region primitive usage as a simulator can have multiple regions either as standard regions or joined to a var?

For a joined var where there is a one to one relationship between the var and the simulator, this should be OK, as it also should be if there is a one-to-one relationship between a standard region and a simulator. But otherwise it would go wrong if the parcel ownership over multiple regions in a simulator was tallied up?
(0030581)
Diva (administrator)
2016-06-19 13:29

As per reported
(0034531)
BillBlight (developer)
2019-02-06 11:30

Marked as Resolved but never closed, can be reopened if needed.

- Issue History
Date Modified Username Field Change
2016-06-05 12:50 danbanner New Issue
2016-06-07 09:11 Mandarinka Tasty Note Added: 0030415
2016-06-08 04:13 danbanner Note Added: 0030423
2016-06-18 22:08 Diva Note Added: 0030565
2016-06-19 04:35 danbanner Note Added: 0030567
2016-06-19 05:01 danbanner Note Added: 0030568
2016-06-19 05:02 danbanner Note Edited: 0030568 View Revisions
2016-06-19 05:07 danbanner Note Edited: 0030568 View Revisions
2016-06-19 05:18 danbanner Note Added: 0030569
2016-06-19 06:36 Diva Note Added: 0030570
2016-06-19 06:56 Diva Note Added: 0030571
2016-06-19 07:04 Diva Note Edited: 0030571 View Revisions
2016-06-19 07:05 danbanner Note Added: 0030572
2016-06-19 07:09 Diva Note Edited: 0030571 View Revisions
2016-06-19 07:22 danbanner Note Added: 0030573
2016-06-19 09:23 Diva Note Added: 0030574
2016-06-19 10:13 Mandarinka Tasty Note Added: 0030575
2016-06-19 10:24 Mandarinka Tasty Note Added: 0030576
2016-06-19 10:24 danbanner Note Added: 0030577
2016-06-19 10:37 Mandarinka Tasty Note Added: 0030579
2016-06-19 12:45 Gavin Hird Note Added: 0030580
2016-06-19 13:29 Diva Note Added: 0030581
2016-06-19 13:29 Diva Status new => resolved
2016-06-19 13:29 Diva Resolution open => fixed
2016-06-19 13:29 Diva Assigned To => Diva
2019-02-06 11:30 BillBlight Note Added: 0034531
2019-02-06 11:30 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker