Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007916opensim[REGION] Script Functionspublic2016-06-03 23:372019-10-25 16:05
ReporterMandarinka Tasty 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusacknowledgedResolutionwon't fix 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007916: osSetTerrainTexture and osSetTerrainTextureHeight neither work for Estate Owner nor Estate Manager without God Powers
DescriptionHello !

I have noticed that functions:

osSetTerrainTexture and osSetTerrainTextureHeight work only for Grid Administrators and Region Administrators, if God Powers are enabled for them.

And this situation exists , regardless settings in osslEnable.ini

Hence, it can be considered as limitation of using these functions.

In my opinion estate owner and estate manager with userLevel = 0 ( no god powers)

should also have possibility to use such script functions in their objects.
Steps To ReproduceI have attached PATCH: that includes solution:

I have replaced condition:

if (World.Permissions.IsGod(m_host.OwnerID) with condition:

if ((World.Permissions.CanIssueEstateCommand(m_host.OwnerID, false)) && (estate != null))

In this way, every user with access to Estate Menu is able to use those functions

regardless of UserLevel assigned to the account.

Certainly, by design , those functions require appropriate Thread Level or

individual settings in osslEnable.ini.

That I have not changed to preserve compatibility.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Script Engine
EnvironmentMono / Linux64
Mono VersionOther
Viewer
Attached Files

- Relationships

-  Notes
(0035775)
Mandarinka Tasty (reporter)
2019-10-25 14:40

The patch has been deleted by the author.

- Issue History
Date Modified Username Field Change
2016-06-03 23:37 Mandarinka Tasty New Issue
2016-06-03 23:37 Mandarinka Tasty File Added: 0001-Fix-for-osSetTerrainTexture-osSetTerrainTextureHeigh.patch
2016-06-03 23:38 Mandarinka Tasty Status new => patch included
2016-06-05 23:27 Mandarinka Tasty Run Mode Grid (Multiple Regions per Sim) => Grid (1 Region per Sim)
2019-10-25 14:40 Mandarinka Tasty File Deleted: 0001-Fix-for-osSetTerrainTexture-osSetTerrainTextureHeigh.patch
2019-10-25 14:40 Mandarinka Tasty Note Added: 0035775
2019-10-25 14:41 Mandarinka Tasty Status patch included => resolved
2019-10-25 14:41 Mandarinka Tasty Resolution open => won't fix
2019-10-25 14:41 Mandarinka Tasty Assigned To => Mandarinka Tasty
2019-10-25 16:05 BillBlight Assigned To Mandarinka Tasty =>
2019-10-25 16:05 BillBlight Status resolved => acknowledged


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker