Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007908opensim[GRID] Hypergridpublic2016-05-13 16:092017-12-26 05:43
Reportersmxy 
Assigned To 
PriorityhighSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007908: OpenSim broken with respect to Melanie's recommended Mono, re: reverse DNS lookups that don't match the forward lookup.
DescriptionMany grids are hosted in such a way (shared hosting or home-hosted with a Dynamicly-assigned address, for example) that their reverse DNS lookup will never match their forward lookup. This has not been a problem until recent Mono versions. According to Melanie, Mono used to cache the forward lookup and return a reverse lookup that was based on the forward lookup, but it no longer does that in recent versions. An example of this is Mono 4.3.2, which is what Melanie recommends as *THE* version of Mono to use. However, as it no longer "fakes" an appropriate reverse lookup, this breaks Hypergrid teleports for any avatar trying to TP to a grid running Mono 4.3.2, when their home grid does not have a reverse DNS entry that matches its forward entry.

Melanie has stated that OpenSim must be fixed to deal with this.
Additional InformationIn the case of my grid, I'm able to enter a local A record, for most such grids, into my pfSense firewall, and it generates an appropriate reverse lookup entry for me (like Mono used to), that resolves the problem. However, I'm unable to do that for all such grids, as I found out today, when I discovered two grids on the same hosted server. The reverse lookup, whether provided by their DNS provider or my firewall, can only point to one of them, and the other one is screwed.
TagsNo tags attached.
Git Revision or version number97a471c (doesn't really matter though - any would be affected)
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono VersionOther
ViewerN/A
Attached Files

- Relationships

-  Notes
(0030409)
Diva (administrator)
2016-06-06 09:50
edited on: 2016-06-06 20:20

smxy, can you provide more info so I can repro this. Ideally I would like to see:

- a controlled setup where you get the failure, and a detailed description of that setup (i.e. which process is running which version of mono), so that I can repro. By 'controlled' I mean something that is 100% under your control and doesn't depend on other people's grids

- a scanned sketch of the network setup, including the two robusts, the two sims and the viewer

- logs of the failure

Thanks.

(0030429)
Mata Hari (reporter)
2016-06-08 15:32
edited on: 2016-06-08 16:05

<post removed....apparently irrelevant>

(0030430)
smxy (reporter)
2016-06-08 16:00

You folks are posting about a different issue altogether, hijacking my mantis. Please open a separate mantis for your issues.
(0031920)
Diva (administrator)
2017-05-22 13:41

Ping.
I'd like to get to the bottom of this.
I need a lot more detailed instructions for how to recreate this problem.

- Issue History
Date Modified Username Field Change
2016-05-13 16:09 smxy New Issue
2016-06-06 09:50 Diva Note Added: 0030409
2016-06-06 20:20 Diva Note Edited: 0030409 View Revisions
2016-06-08 14:05 Mandarinka Tasty Note Added: 0030427
2016-06-08 14:49 Mandarinka Tasty Note Added: 0030428
2016-06-08 15:32 Mata Hari Note Added: 0030429
2016-06-08 15:34 Mata Hari Note Edited: 0030429 View Revisions
2016-06-08 15:38 Mata Hari Note Edited: 0030429 View Revisions
2016-06-08 16:00 smxy Note Added: 0030430
2016-06-08 16:05 Mata Hari Note Edited: 0030429 View Revisions
2016-06-08 17:56 Mandarinka Tasty Note Deleted: 0030428
2016-06-08 17:56 Mandarinka Tasty Note Deleted: 0030427
2017-05-22 13:41 Diva Note Added: 0031920


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker