Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007881opensim[REGION] Physics Enginespublic2016-04-17 02:092016-04-17 22:32
ReporterGavin Hird 
Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Statuspatch includedResolutionno change required 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007881: Updated ODE dylib for OS X
DescriptionThe ODE dylib for OS X has been updated with the latest code changes and for ubODE.

The library has been compiled as a fat binary with both 32 and 64 bit support with Xcode 7.3, the OS X 10.11 SDK and O3 optimization, and been tested to work with both ODE and ubODE for the latest development code.

lipo -info libode.dylib
Architectures in the fat file: libode.dylib are: i386 x86_64

A copy of the library should be placed in both bin/lib32 and bin/lib64
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / OSX
Mono VersionOther
ViewerN/A
Attached Files? file icon libode.dylib [^] (1,686,484 bytes) 2016-04-17 02:09

- Relationships

-  Notes
(0030192)
Gavin Hird (reporter)
2016-04-17 22:30

This is to remain open till the updated library is pushed to master
(0030193)
Gavin Hird (reporter)
2016-04-17 22:32

@SkyFlier This comment may be relevant to the ODE library, but probably should have been added to some other issue #.

Found the cause of the problem: llRezObject sets the property DieAtEdge to true
in the rezzed prim, That will make the vehicle die when crossing regions.
the solution is to include:

llSetStatus(STATUS_DIE_AT_EDGE,FALSE) in the vehicle initialization

- Issue History
Date Modified Username Field Change
2016-04-17 02:09 Gavin Hird New Issue
2016-04-17 02:09 Gavin Hird File Added: libode.dylib
2016-04-17 02:10 Gavin Hird Status new => patch included
2016-04-17 08:47 Gavin Hird Description Updated View Revisions
2016-04-17 18:22 SkyFlier Severity major => minor
2016-04-17 18:22 SkyFlier Status patch included => resolved
2016-04-17 18:22 SkyFlier Resolution open => no change required
2016-04-17 18:22 SkyFlier Additional Information Updated View Revisions
2016-04-17 22:30 Gavin Hird Note Added: 0030192
2016-04-17 22:30 Gavin Hird Status resolved => patch included
2016-04-17 22:30 Gavin Hird Additional Information Updated View Revisions
2016-04-17 22:32 Gavin Hird Note Added: 0030193


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker