Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007874opensim[REGION] OpenSim Corepublic2016-04-08 02:532019-02-06 11:30
ReporterLotek 
Assigned ToDiva 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSUbuntu LinuxOS Version14.04 LTS
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007874: Parcel properties don't take effect when entering parcel
DescriptionParcel name stays the same in the viewer on the top bar
Music stream of previous parcel keeps playing
Steps To Reproduce* Divide some land and make it a parcel
* Give both parcels its own radio stream, parcel name and description

Notice how walking from one parcel into the other doesn't update parcel name in the top bar of the viewer and the radio stream keeps playing from the old parcel
Additional InformationThis bug doesn't seem to effect parcel perms (rez, no entry, banlines etc) which would be bad. For example if rezzing is allowed in parcel A but not B.. then coming from A into B doesn't let us rez in B (which is correct) but the parcel name, about land, music keeps playing from parcel A. I tested this by having each parcel owned by a different user.
Tagsparcel
Git Revision or version numbered9d4feef587a057b73925bd29e6f0f0c5d55d70
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono Version3.2
ViewerFirestorm, Singularity
Attached Filesdiff file icon parcelentry.diff [^] (16,737 bytes) 2016-05-31 07:09 [Show Content]

- Relationships

-  Notes
(0030152)
Gavin Hird (reporter)
2016-04-09 09:14

Yes, I noticed this too for 0.9 dev.

The condition crept in just around this commit, http://opensimulator.org/viewgit/?a=commit&p=opensim&h=efc062b0ccfc0c1bbe305d7ce26b0521b53f1d74 [^]

But I have not entirely been able to pinpoint exactly why.
(0030390)
Lotek (reporter)
2016-05-30 11:18

I figured out this to be caused by the changes in commit http://opensimulator.org/viewgit/?a=commit&p=opensim&h=41ae6f06e01e29ae4d9637d6682a47f6d4964f75 [^]

I made a patch for my own use that reverses this commit (for master) and after applying entering parcels with my avi works correct again.

Ideally the code of the original commit needs some attention
(0030400)
Gavin Hird (reporter)
2016-05-31 00:04

OK, so if I understand you correct, reverting this commit, restored the functionality without any other effects on functionality?
(0030403)
Lotek (reporter)
2016-05-31 05:22
edited on: 2016-05-31 07:10

I'm not sure, this would need testing to see how it affects parcel bans as the original commit seems to be a refactoring of parcel bans.

I don't know how to attach a patch so I put it on Dropbox. It applies cleanly to master.

(0030404)
Gavin Hird (reporter)
2016-05-31 06:54

There is an Upload file section above where you choose the patch file you want to upload, and then hit Upload file to attach it tooth's mantis.
(0030405)
Gavin Hird (reporter)
2016-05-31 07:26

That worked on my test regions. I have not checked out the consequence for bans and ban lines yet, but I'll bring up this mantis at the developer meeting today so someone can help you get it all worked out and into master.

Thanks so far!
(0030406)
Lotek (reporter)
2016-05-31 07:33

Thanks :) couldn't find that earlier. Uploaded for completeness..

I tested a bit.

Group only parcels keep non-group people out;
Avatar-specific bans in parcels keep that banned person out.
This is on trying to walk into the parcels as well as teleport.
Banlines seem to extend to the right height (avatar ban unlimited height and group parcel until about 70m). I noticed I can't fly above group-only parcel banlines like in SL.
TP into a region with only 1 parcel that the visitor is banned from returns 'You don't have access to the region parcels' which is correct. Same with trying to walk/fly into that region.
I don't get a popup when entering a parcel I'm not allowed, I'm not sure if that's in line with SL, and did see a change in that in the commit.

Meanwhile the 'See and chat with avatars on this parcel' functionality introduced in 0.9 works correctly (it can hide people on the parcel to outsiders and vice versa and chat won't cross parcels). Not sure if related but I report anyway.

The actual updating of parcel name in the top of the viewer (and music stream) is slightly delayed until after entering the parcel but is much better than no update at all and I think just the same speed as 0.8. Might be my slow connection.
(0030448)
Diva (administrator)
2016-06-11 10:24

[10:23] <cia-opensim> opensim: diva * r53d8b8a83f82 OpenSim/Region/CoreModules/World/Land (LandManagementModule.cs):
[10:23] <cia-opensim> Mantis 0007874: parcel properties not being updated upon avatar entering new parcel. Root cause: update of the avatar's current property was being made too soon.

Got a clean repro, and this fixed it for me. Please confirm.
(0030451)
Lotek (reporter)
2016-06-11 12:20
edited on: 2016-06-11 12:20

Yes looks like it's sorted in master, tested your change and everything works as it should now

(0030454)
Diva (administrator)
2016-06-11 13:39

Fixed
(0034534)
BillBlight (developer)
2019-02-06 11:30

Marked as Resolved but never closed, can be reopened if needed.

- Issue History
Date Modified Username Field Change
2016-04-08 02:53 Lotek New Issue
2016-04-08 03:16 Lotek Tag Attached: parcel
2016-04-09 09:14 Gavin Hird Note Added: 0030152
2016-05-30 11:18 Lotek Note Added: 0030390
2016-05-31 00:04 Gavin Hird Note Added: 0030400
2016-05-31 05:22 Lotek Note Added: 0030403
2016-05-31 05:28 Lotek Note Edited: 0030403 View Revisions
2016-05-31 06:54 Gavin Hird Note Added: 0030404
2016-05-31 07:09 Lotek File Added: parcelentry.diff
2016-05-31 07:10 Lotek Note Edited: 0030403 View Revisions
2016-05-31 07:26 Gavin Hird Note Added: 0030405
2016-05-31 07:33 Lotek Note Added: 0030406
2016-06-11 10:24 Diva Note Added: 0030448
2016-06-11 12:20 Lotek Note Added: 0030451
2016-06-11 12:20 Lotek Note Edited: 0030451 View Revisions
2016-06-11 13:39 Diva Note Added: 0030454
2016-06-11 13:39 Diva Status new => resolved
2016-06-11 13:39 Diva Resolution open => fixed
2016-06-11 13:39 Diva Assigned To => Diva
2019-02-06 11:30 BillBlight Note Added: 0034534
2019-02-06 11:30 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker