Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007828opensim[REGION] OpenSim Corepublic2016-02-13 07:052019-02-06 11:30
ReporterLotek 
Assigned ToLotek 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007828: Seated vehicle should not be autoreturned if vehicle owner/group doesn't match current parcel owner/group
DescriptionSeated vehicles are being auto returned when the vehicle owner/group differs from the parcel owner/group. The right behaviour would be for the vehicle to auto return only when its driver stands up from the vehicle in such a parcel.

Steps To Reproduce1) Make a seperate parcel, set its autoreturn to 1 minute. Deed the parcel to a group

2) Rez a vehicle outside the just created parcel, set the vehicle to a different group than the parcel just created

3) Drive the vehicle into the newly created parcel

4) Wait a minute while staying seated
Additional InformationIn SL, a vehicle would also be auto returned also in the following cases:

* When trying to enter a parcel that has no public access (banlines)

* When the parcel doesn't have enough free prims to hold the entering vehicle

This is not of primary importance but maybe worth mentioning. They are also annoyances of the vehicle community (pilots, sailors etc).


A common use case of this bug report could be a racetrack sim with public rezzing and short autoreturn as seen in SL. People can then rez their own car/bike and race as long as they don't standup (and then some minutes depending on the autoreturn value).
Tagsautoreturn, Vehicles
Git Revision or version numberOSgrid 0.9.0.0 (Dev) b34652e: 2016-01-26 (Unix/Mono)
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono Version3.2
ViewerSingularity
Attached Filesdiff file icon 00-no_autoreturn_on_object_owner_seated.diff [^] (1,071 bytes) 2016-06-28 20:21 [Show Content]
diff file icon 01-no_autoreturn_on_any_avi_seated.diff [^] (1,303 bytes) 2016-07-03 13:30 [Show Content]

- Relationships

-  Notes
(0030806)
Lotek (reporter)
2016-06-28 01:54

I worded this bug too difficult, it can be easier titled as:
'Bug: Foreign seated(!) object gets auto returned'

Whether a vehicle or a static object (like a chair), a seated object should NOT be auto returned, even if it is not owned by the land owner/group.

The object should ONLY be auto returned if the avatar stands up AND the object has been there longer than the parcel auto return time.

In SL this can be tested: in any open-to rez parcel you don't own, rez a chair and sit out the parcel auto return time. Notice how you can sit as long as you want. When standing up some time after the auto return time has expired, notice how the chair is neatly auto returned.
(0030830)
Lotek (reporter)
2016-06-28 20:23

Included patch brings auto return in line with SL. Please review and test :)
(0030831)
Lotek (reporter)
2016-06-28 20:58

Actually, in SL the object stays as long as ANY avatar sits on it, not just its OWNER so my version is a bit more tight (secure?).

To have it 100% SL compatible, the object should be checked against ANY avatar sitting I think by iterating over the avatars in the scene and doing the same check, unless there is a more straightforward way.

But this is already very usable :) What lead to me reporting this bug is because I wanted to create public rez zones for people to rez their vehicles on my sims to then drive around and explore by car. Similar like you see on SL mainland.
(0030861)
Lotek (reporter)
2016-07-03 13:43
edited on: 2016-07-03 13:48

OK now with diff 01 made it 100% SL compatible; it works exactly the same now as per SL spec. The attached diff 01 supersedes the older diff 00

Tested with parcel owned by avatar A, with auto-return 1 minute and rez allowed:
* Avatar B rezzed 2 cubes
* Avatar B and avatar C sat on cubes
* Avatar B and avatar C were able to remain seated indefinitely
* The moment avatar B and avatar C stood up, the boxes were auto returned (to avatar B) as avatar A owns the land and the boxes were foreign objects.

Test successful :)

(0030881)
UbitUmarov (administrator)
2016-07-08 02:00

[09:58] <cia-opensim> opensim: ajlduarte * r11a8a722df89 OpenSim/Region/Framework/Scenes (SceneObjectGroup.cs): don't auto return objects if they have sitting avatars (not npcs) - mantis 7828 with diferent code

sorry I didn't use your code but thx
(0030882)
Gavin Hird (reporter)
2016-07-08 02:53

This can also be used for squatting / harassment, so any object should be auto returned after the timeout. For roads the owner usually will set the auto return timeout to a reasonable number.
(0030883)
Lotek (reporter)
2016-07-08 03:34

Ubit: Cool, much better code but why no NPCs? I guess no sim tours by a NPC bus/train/ferry/airballoon driver then or is that a fringe case.. (no prob I can always 'patch the patch' for my own use ;) Can't NPC's cross sims borders? I never tried.

Gavin: The change makes it functionally equal to how it works in SL. Reproduce my test (note 30861) in SL (in a SL rez zone with 10 minute autoreturn for example). I can't think of any case that this would lead to bad things as long as either auto return or no entry is used wisely.

In the case of a squatter, they would have to remain seated on the object for as long the land is to be occupied. The moment he/she stands up, then poof gone is the object. I only know of some rare times where aircraft carriers do this on the Blake Sea to have a mobile base where aircrafts land, and that's more roleplay than griefing.
(0030884)
UbitUmarov (administrator)
2016-07-08 03:42

no NPCs can't cross borders, and NPCs could eventually hold a object "forever" and potentially aggravate the "squatter" problem.

the pros and cons of this are open to debate (not much the NPCs case ;) )

in last case this can be made a option, but we have so many of those that I would like to avoid it.
(0030885)
Gavin Hird (reporter)
2016-07-08 03:54

In SL I've had a squatter who was there for weeks on end off of a public road. Did not do any harm, but could easily have.

I have also had people launch griefing off of the SLRR track using this "feature". Not everything is optimal as it is implemented in SL.

Configurable might make sense.
(0034520)
BillBlight (developer)
2019-02-06 11:30

Marked as Resolved but never closed, can be reopened if needed.

- Issue History
Date Modified Username Field Change
2016-02-13 07:05 Lotek New Issue
2016-02-13 07:12 Lotek Tag Attached: Vehicles
2016-02-13 07:12 Lotek Tag Attached: autoreturn
2016-06-28 01:54 Lotek Note Added: 0030806
2016-06-28 20:21 Lotek File Added: 00-no_autoreturn_on_object_owner_seated.diff
2016-06-28 20:23 Lotek Note Added: 0030830
2016-06-28 20:23 Lotek Status new => patch feedback
2016-06-28 20:58 Lotek Note Added: 0030831
2016-07-03 13:30 Lotek File Added: 01-no_autoreturn_on_any_avi_seated.diff
2016-07-03 13:43 Lotek Note Added: 0030861
2016-07-03 13:47 Lotek Note Edited: 0030861 View Revisions
2016-07-03 13:48 Lotek Note Edited: 0030861 View Revisions
2016-07-08 02:00 UbitUmarov Note Added: 0030881
2016-07-08 02:53 Gavin Hird Note Added: 0030882
2016-07-08 03:34 Lotek Note Added: 0030883
2016-07-08 03:42 UbitUmarov Note Added: 0030884
2016-07-08 03:54 Gavin Hird Note Added: 0030885
2016-07-08 07:44 Lotek Status patch feedback => resolved
2016-07-08 07:44 Lotek Fixed in Version => master (dev code)
2016-07-08 07:44 Lotek Resolution open => fixed
2016-07-08 07:44 Lotek Assigned To => Lotek
2019-02-06 11:30 BillBlight Note Added: 0034520
2019-02-06 11:30 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker