Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007757opensim[REGION] OpenSim Corepublic2015-11-24 08:222015-11-28 01:13
Reporteraiaustin 
Assigned Toaiaustin 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0007757: Region lost its properies, terrain information and other things
DescriptionThis was an odd one.. when I logged onto the Openvue grid with Firestorm 4.7.5 I could not see two nearby regions adjacent to the one the avatar was in, even though the server was up and the region maps had generated properly. Teleporting via the map, rather than walking across, I could get onto them but the region and plot properties were partially, but not completely, missing. The region name was missing in the address bar (but it showed the x,y,z location of the avatar), the type showed as unknown (its set to Mainland) and the rating was unknown (its set to general). Also when I looked some terrain textures were missing and the upper and lower terrain bounds (which were custom settings) had reset (presumably to defaults). Yet the map tile had correctly generated things in that same run of the server.

I am posting this Mantis now just in case it rings any bells with anyone or if others observe something similar. I am still investigating as I have many other issues I am trying to pry apart.

See 2015-11-24-Openvue-Unknown-Region-Name-and-Properties.jpg
and 2015-11-24-Openvue-Terrain-Texture-Wrong.jpg

As the above was happening, I was getting a dozen XESTATE messages... even though I was not attempting to set or change any covenant.

16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:14 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
16:05:24 - [XESTATE HANDLER]: query String: METHOD=update_covenant&CovenantID=00000000-0000-0000-0000-000000000000&EstateID=100
TagsNo tags attached.
Git Revision or version numberopensim-0.9.0-96-ga0c3297.zip
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm 4.7.5
Attached Filesjpg file icon 2015-11-24-Openvue-Unknown-Region-Name-and-Properties.jpg [^] (268,577 bytes) 2015-11-24 08:23
jpg file icon 2015-11-24-Openvue-Terrain-Texture-Wrong.jpg [^] (323,084 bytes) 2015-11-24 08:23
jpg file icon 2015-11-24-Openvue-Correct-Region-Name-and-Properties.jpg [^] (323,278 bytes) 2015-11-24 08:42

- Relationships

-  Notes
(0029634)
aiaustin (developer)
2015-11-24 08:42

Could it be that there is a change in behaviour for what happens when an openSim.exe instance comes on line while a viewer is running and the avatar is on the same grid but another region server instance?

The attached image 2015-11-24-Openvue-Correct-Region-Name-and-Properties.jpg shows the correct properties and was obtained after retsrating the Robust server, each OpenSim.exe instance, waiting until they were all p and loging for all regions available and then starting the viewer.

The faulty case MAY have been when the avatar was on the Robust/initial region setup and the second server was not fully up, but then moving across to a region on that second server when it became available. Due to the multiple changes of the server and region code today I may have got in quickly to expose his potential issue.

I will add more information to this Mantis if I spot this again, or see any pattern. I encourage others to do the same.
(0029636)
aiaustin (developer)
2015-11-24 08:59
edited on: 2015-11-24 09:14

Using opensim-0.9.0-96-ga0c3297.zip on both grids involved here...

On another Grid (AiLand) which was all up and running, after visiting with another grid avatar, I am seeing some regions with partially missing properties, and on those regions NPCs have no name label... whereas NPCs on the same grid on regions that do show plot properties have their label correctly showing. Hovering over one of the NPCs without a label it showed "person". where does that come from.. its not related to the NPC's name. Show Profile showed on its UUID, no name was in that as is usual. The NPCs did have their correct names in show users list on the console.

This loss of names of NPCs on some regions MAY be another separate issue, but there seemed to be a connection to the partially missing properties issue in two region cases.

I killed the NPCs that were not correctly showing their name labels, and when they reappeared they did show the name labels, and show profile on them, correctly showed that proper name too.

(0029637)
UbitUmarov (administrator)
2015-11-24 09:25

those regions are also all on same instance?
(0029639)
aiaustin (developer)
2015-11-24 10:05
edited on: 2015-11-24 10:08

The AiLand grid has

1 X Robust.exe
1 X OpenSim.exe with 4 core regions on same server as Robust,.exe

1 X OpenSim.exe for 8 further add on regions on a different server on same subnet.

The regions that had NPCs that lost their names were on the second server hence on the same OpenSim.exe, but 2 other regions on the same server had NPCs with their labels intact.

(0029656)
UbitUmarov (administrator)
2015-11-24 20:25

did some changes that may improve this...
(0029731)
UbitUmarov (administrator)
2015-11-27 15:39

Visited OpenVue again
In world experience seems good.. crossings now work as expected.
with low view range only first order neighbours are connected.. more than 512m, second order also. information about parcels on nearby region seems correct...
(0029743)
aiaustin (developer)
2015-11-28 01:13

All looks good on this issue now Ubit.

I could not find you in the list of users who can have issues assigned. Can you get yourself added to that list for OpenSim Mantis so we can properly credit you when marking issues as resolved.

- Issue History
Date Modified Username Field Change
2015-11-24 08:22 aiaustin New Issue
2015-11-24 08:23 aiaustin File Added: 2015-11-24-Openvue-Unknown-Region-Name-and-Properties.jpg
2015-11-24 08:23 aiaustin File Added: 2015-11-24-Openvue-Terrain-Texture-Wrong.jpg
2015-11-24 08:42 aiaustin Note Added: 0029634
2015-11-24 08:42 aiaustin File Added: 2015-11-24-Openvue-Correct-Region-Name-and-Properties.jpg
2015-11-24 08:46 aiaustin Description Updated View Revisions
2015-11-24 08:59 aiaustin Note Added: 0029636
2015-11-24 09:12 aiaustin Note Edited: 0029636 View Revisions
2015-11-24 09:14 aiaustin Note Edited: 0029636 View Revisions
2015-11-24 09:21 aiaustin Description Updated View Revisions
2015-11-24 09:25 UbitUmarov Note Added: 0029637
2015-11-24 10:05 aiaustin Note Added: 0029639
2015-11-24 10:07 aiaustin Note Edited: 0029639 View Revisions
2015-11-24 10:08 aiaustin Note Edited: 0029639 View Revisions
2015-11-24 20:25 UbitUmarov Note Added: 0029656
2015-11-27 15:39 UbitUmarov Note Added: 0029731
2015-11-28 01:13 aiaustin Note Added: 0029743
2015-11-28 01:13 aiaustin Status new => resolved
2015-11-28 01:13 aiaustin Fixed in Version => master (dev code)
2015-11-28 01:13 aiaustin Resolution open => fixed
2015-11-28 01:13 aiaustin Assigned To => aiaustin
2015-11-28 01:13 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker