Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007736opensim[GRID] Messaging Servicepublic2015-11-01 10:292015-11-02 14:16
Reporterstephenxootfly 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusnewResolutionfixed 
Platformopensim 0.8.1.2OSDebianOS VersionWheezy
Product Version 
Target VersionFixed in Version 
Summary0007736: enabling groups leads to crash looking for
DescriptionRunning .tar binary of opensim 0.8.1.2 on Debian. It's configured to run StandaloneHypergrid.ini.

Enabling Groups in OpenSim.ini leads to crash on startup:

These are the changes to OpenSim.ini from the defaults (no other changes other than setting HOME_URI)

[Groups]
    Enabled = true
    Module = "Groups Module V2"
    StorageProvider = OpenSim.Data.MySQL.dll
    ServicesConnectorModule = "Groups HG Service Connector"
    MessagingModule = "Groups Messaging Module V2"

Error message

APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.Exception: [Groups.RobustHGConnector]: please provide OfflineIMService in section Groups
  at OpenSim.Groups.HGGroupsServiceRobustConnector..ctor (IConfigSource config, IHttpServer server, System.String configName, IOfflineIMService im, IUserAccountService users) [0x00000] in <filename unknown>:0
  at OpenSim.Groups.GroupsServiceHGConnectorModule.RegionLoaded (OpenSim.Region.Framework.Scenes.Scene scene) [0x00000] in <filename unknown>:0
Additional InformationInterestingly, I have another server set up at .8.1Dev with these exact same settings which works fine. Was there a configuation change from Dev to Release?

In looking at http://opensimulator.org/wiki/Offline_Instant_Messaging_v2 [^]

The instructions under The Offline Instant Messaging v2 Module uses the following MySQL storage and migrations:

regarding diva_im_offline seems nonsensical because that table or information does not exist in our database. It just gives error messages that that table does not exist. Can someone clarify what steps need to be taken to modify a database when upgrading opensim but using the older database?

This is my first Mantis submission, so sorry if the info is incomplete or unclear.
TagsNo tags attached.
Git Revision or version number
Run Mode Standalone (Multiple Regions)
Physics EngineBulletSim
Script Engine
EnvironmentMono / Linux64
Mono Version2.10
ViewerNA
Attached Files

- Relationships

-  Notes
(0029527)
stephenxootfly (reporter)
2015-11-02 14:16

Fixed it by double checking configuration files. I must have mistyped [Messaging in my search because I didn't enable the items in that block. All seems to be working now.

- Issue History
Date Modified Username Field Change
2015-11-01 10:29 stephenxootfly New Issue
2015-11-02 14:16 stephenxootfly Note Added: 0029527
2015-11-02 14:16 stephenxootfly Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker