Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007725opensim[GRID] Inventory Servicepublic2015-09-14 16:412015-11-19 19:15
ReporterMata Hari 
Assigned ToMata Hari 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel i7 930 quadOSWindows .NETOS VersionWin10 x64
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007725: Current Outfit folder and Current Appearance Issues (Firestorm)
DescriptionThere are currently issues with the current outfit and display of current appearance when using Firestorm 4.7.3 (47323) with opensim-a6012a3.

When changing appearance to a stored outfit, the new items are correctly worn and the Current Outfit system folder is populated with a link to the Outfit folder. When you change to a different appearance, the new items are again correctly worn however the link to the old outfit folder is *not* removed from Current Outfits when the new folder link is added. Further, the Firestorm display of the currently worn outfit (in Appearances) doesn't update and will continue to show the old outfit as being worn. Over time this can result in dozens of extra folder links in the Current Outfit folder and the viewer can become confused about which items need to be added or removed when you change outfits.
Steps To ReproduceUsing Firestorm, create and store at least two outfits (appearances)

Wear 1

Change to the other

Inspect Appearances which will then display the old outfit as still being worn even though it isn't

Inspect the Current Outfit folder in inventory and note that there are now links to both of the outfit folders you've worn.

If you have multiple stored appearances, continue to change and you'll see that new fonders continue to be added a old ones are never removed (unless you do so manually)
Additional InformationThis is a relatively new issue which *may* have been introduced with the time of Firestorm 4.7.3 release; however that coincided with other significant changes made to inventory handling in Opensim code.
TagsNo tags attached.
Git Revision or version numbera6012a3
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm 4.7.3 (47323)
Attached Files

- Relationships

-  Notes
(0029525)
UbitUmarov (administrator)
2015-11-02 12:12

That seems to be a Firestorm issue. It does not send any commands to delete the link to the old outfit.
(0029542)
UbitUmarov (administrator)
2015-11-13 08:22

From firestorm jira seems this issue was correct. I can't check it now..
(0029544)
Mata Hari (reporter)
2015-11-13 08:46

Yes, I'm going to mark this as resolved since it appears to have been a FS-only bug and they immediately addressed my Jira and patched it. I expect the fixed version will be part of the next FS public release (it's currently in RC testing).

In the meantime the work-around is to manually delete the excess folder link entries from the Current Outfit folder.
(0029545)
Mata Hari (reporter)
2015-11-13 08:47

FS issue which will be fixed in 4.7.5

See: http://jira.phoenixviewer.com/browse/FIRE-17217 [^]
(0029579)
Mata Hari (reporter)
2015-11-19 19:15

Firestorm 4.7.5 released and confirmed fixed this issue

- Issue History
Date Modified Username Field Change
2015-09-14 16:41 Mata Hari New Issue
2015-11-02 12:12 UbitUmarov Note Added: 0029525
2015-11-13 08:22 UbitUmarov Note Added: 0029542
2015-11-13 08:46 Mata Hari Note Added: 0029544
2015-11-13 08:47 Mata Hari Note Added: 0029545
2015-11-13 08:47 Mata Hari Status new => resolved
2015-11-13 08:47 Mata Hari Fixed in Version => master (dev code)
2015-11-13 08:47 Mata Hari Resolution open => fixed
2015-11-13 08:47 Mata Hari Assigned To => Mata Hari
2015-11-19 19:15 Mata Hari Note Added: 0029579
2015-11-19 19:15 Mata Hari Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker